Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,730,914 Members 45,783 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Restoring Sony's stock camera after flashing Cyanogenmod

Tip us?
 
karelb.
Old
#1  
Junior Member - OP
Thanks Meter 1
Posts: 4
Join Date: Nov 2010
Location: Assen

 
DONATE TO ME
Camera [Q] Restoring Sony's stock camera after flashing Cyanogenmod

A while back I rooted my Xperia ZR, backed up the TA partition, and flashed CM10.
To my regret, the camera performances aren't nearly as good as with the stock Xperia camera app.
So I was wondering if I could somehow restore the camera app, so I can use it alongside Cyanogenmod.

After googling a lot, the only solution I could find was to restore the TA partition.
Is this possible after flashing a different ROM?
Or does anyone know another solution?

Thanks in advance
 
Daedroza
Old
#2  
Junior Member
Thanks Meter 4
Posts: 25
Join Date: Jun 2014
Quote:
Originally Posted by karelb. View Post
A while back I rooted my Xperia ZR, backed up the TA partition, and flashed CM10.
To my regret, the camera performances aren't nearly as good as with the stock Xperia camera app.
So I was wondering if I could somehow restore the camera app, so I can use it alongside Cyanogenmod.

After googling a lot, the only solution I could find was to restore the TA partition.
Is this possible after flashing a different ROM?
Or does anyone know another solution?

Thanks in advance
Flash 4.4 CM and flash this CAMERA ADDON : - http://forum.xda-developers.com/show....php?t=2672765
 
karelb.
Old
#3  
Junior Member - OP
Thanks Meter 1
Posts: 4
Join Date: Nov 2010
Location: Assen

 
DONATE TO ME
I'm on CM11 now with Android 4.4.4

Tried standard camera first: rubbish
Tried Google Camera next: rubbish
Tried Focal camera: rubbish

Next, I tried to install the ported Xperia Z2 camera: couldn't even open app, just errors

I'm starting to think it's the hardware that sucks.

When taking a picture of a newspaper or a book page (using any camera app on 13MP), you can't even read the letters, too blurry..

Does anyone know what may cause it?

Thanks
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes