Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,809,019 Members 53,607 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Sony Xperia ZR Wifi & Bluetooth functionality Disabled

Tip us?
 
velasoraptor
Old
#1  
Junior Member - OP
Thanks Meter 1
Posts: 2
Join Date: Aug 2014
Question [Q] Sony Xperia ZR Wifi & Bluetooth functionality Disabled

Hi,
Brought the Sony Xperia ZR a few months ago.
It was giving problem with Bluetooth right from the beginning but haven't bothered about it as I used it rarely.
The wifi initially was working fine, but few days ago it just refuse to turn ON.

When tried to turn ON the wifi using ON/OFF slider it hangs up showing pale blue color & comes back to OFF state.
The exact same thing happens to the Bluetooth slider as well. (See attached screenshot)

Searched in some forums & see many people faced similar problems with their device as well.
However no one have given proper solution for it.

Tried everything from Re-boot, Factory Reset & Phone repair option using PC Comparison...None have worked to resolve the problem.

Some people say it is hardware issue & needs replacement of device however others say they had same problem come back even in replaced phone as well.

There was something mentioned about region code reset mentioned here

android.kul.is/2013/09/sony-xperia-zr-wifi-problem.html

but it looks unverified.

PLEASE provide solution for this issue.

Thanks in Advance.
Attached Thumbnails
Click image for larger version

Name:	1.png
Views:	50
Size:	169.8 KB
ID:	2915853  
The Following User Says Thank You to velasoraptor For This Useful Post: [ Click to Expand ]
 
genieass
Old
#2  
Senior Member
Thanks Meter 16
Posts: 183
Join Date: Aug 2011
Location: Kochi
There are other people who have similar issues, including me. Symptoms vary, but ultimately we are unable to use wifi and BT.

I have an additional issue with no USB connection to PC

Sent from my C5502 using XDA Free mobile app
Free as in Freedom.
 
velasoraptor
Old
#3  
Junior Member - OP
Thanks Meter 1
Posts: 2
Join Date: Aug 2014
Default Will downgrading work?

Quote:
Originally Posted by genieass View Post
There are other people who have similar issues, including me. Symptoms vary, but ultimately we are unable to use wifi and BT.

I have an additional issue with no USB connection to PC

Sent from my C5502 using XDA Free mobile app
One of my friend is using the same phone for over a year now & have not upgraded to Kitkat & never had any issue.

Do you think downgrading the phone from Kitkat to JelllyBean will resolve this?
 
genieass
Old
#4  
Senior Member
Thanks Meter 16
Posts: 183
Join Date: Aug 2011
Location: Kochi
Don't know. People say that things work igf you poke the phone at right places. (is the ZR a human to get excited when fingered right?)

I had some success doing it and wifi worked for a few hours. This is obviously a hardware issue.

Sent from my C5502 using XDA Free mobile app
Free as in Freedom.
 
Silverdace
Old
#5  
Member
Thanks Meter 5
Posts: 42
Join Date: Aug 2010
Quote:
Originally Posted by velasoraptor View Post
Hi,
Brought the Sony Xperia ZR a few months ago.
It was giving problem with Bluetooth right from the beginning but haven't bothered about it as I used it rarely.
The wifi initially was working fine, but few days ago it just refuse to turn ON.

When tried to turn ON the wifi using ON/OFF slider it hangs up showing pale blue color & comes back to OFF state.
The exact same thing happens to the Bluetooth slider as well. (See attached screenshot)

Searched in some forums & see many people faced similar problems with their device as well.
However no one have given proper solution for it.

Tried everything from Re-boot, Factory Reset & Phone repair option using PC Comparison...None have worked to resolve the problem.

Some people say it is hardware issue & needs replacement of device however others say they had same problem come back even in replaced phone as well.

There was something mentioned about region code reset mentioned here

android.kul.is/2013/09/sony-xperia-zr-wifi-problem.html

but it looks unverified.

PLEASE provide solution for this issue.

Thanks in Advance.
It's a hardware fault. There's a flex cable attached to the motherboard that comes loose and this leads to bluetooth and WIFI problems. Bluetooth seems to be the thing that goes first which is what you've seen people complaining about.

You can fix (at least temporarily) by pushing the flex cable in.

1. turn off phone
2. take out battery
3. carefully peel up black adhesive tape that was underneath battery. You only need to peel up top right corner near battery connection.
4. Underneath you'll see flex cable going into main body toward camera.
5. Carefully push this in or get something very thin and flat and carefully slide in under flex cable toward camera.
6. Reassemble and see if it worked.

I haven't had bluetooth in ages. Then my 2.4 WIFI dropped out like yours and I could only use 5G WIFI. FM radio also stopped working. I looked at the disassembly manual and worked out it must be that flex cable as pushing in the body below the flash fixes bluetooth/WIFI/Radio temporarily. I tried pushing flex cable in and voila FM Radio and WIFI started working. A bit more wriggling and bluetooth came back on.

However, it seems to keep coming loose again and so I'm going to have a go disassembling fully soon to see if I can make a permanent fix. Just waiting on replacement glue strips from China for underneath the screen.

It's just a poor quality connector that comes loose. It would be an easy fix if you could access the insides but because it's waterproof the only way to get in is removing screen etc.
The Following User Says Thank You to Silverdace For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes