How to Listen to Beats 1 on Android Right Now

If you felt a bit left out by Apple launching their own online radio station Beats 1 … more

NVidia SHIELD TV – XDA TV Device Review

The SHIELD TV is a not an Android smartphone device. However, that doesn’t mean it … more

PSA: Having cellular connectivity or texting issues tonight?

You’re not alone…Tonight, many users are experiencing a myriad … more

Beats Music No Longer Accepting New Accounts

Whenever Apple launches a new product or service, it definitely manages to grab the … more

Xposed - Legacy thread. Don't panic, Xposed is still here.

2,447 posts
Thanks Meter: 35,659
 
By rovo89, Senior Recognized Developer on 31st March 2012, 02:55 PM
Thread Closed Subscribe to Thread Email Thread
21st February 2014, 01:29 PM |#9001  
CodeingBoy's Avatar
Member
Flag GuangZhou
Thanks Meter: 7
 
More
Quote:
Originally Posted by rovo89

Yes, that might be helpful. If I understand you right, the official ROM on that page does probably not contain the incompatibility (yet)?



You can just reboot the device as usual from the power menu. The next version of Xposed Installer will use a custom build of BusyBox to reboot, so this error and also a problem with some HTC phones shouldn't happen anymore.

Maybe,I don't have a I9100 to test.Though it is the latest weekly-build, but I don't make sure of it.Someone who use I9100 said it is OK to use.
Maybe it just a bug which only cause on MI2/MI3, because many people who use them said xposed can't work on it, others seems not.
And I heard WSM is working on it...Anyway, here is the log.
 
 
21st February 2014, 01:36 PM |#9002  
CodeingBoy's Avatar
Member
Flag GuangZhou
Thanks Meter: 7
 
More
Quote:
Originally Posted by rovo89

Yes, that might be helpful. If I understand you right, the official ROM on that page does probably not contain the incompatibility (yet)?



You can just reboot the device as usual from the power menu. The next version of Xposed Installer will use a custom build of BusyBox to reboot, so this error and also a problem with some HTC phones shouldn't happen anymore.

Sorry for I forgot to upload logs.
Attached Files
File Type: zip Logs.zip - [Click for QR Code] (145.7 KB, 4 views)
21st February 2014, 02:21 PM |#9003  
chavocarlos's Avatar
Senior Member
Flag Guayaquil
Thanks Meter: 103
 
More
Anybody have issues using OpenVPN https://play.google.com/store/apps/d...penvpn.openvpn with Xposed Installed ??
I can't connect and logcat show like OpenVPN program detects xposed framework.

02-21 10:08:58.721 E/VpnConfirm(20698): at de.robv.android.xposed.XposedBridge.main(XposedBri dge.java:126)

Regards.
Last edited by chavocarlos; 21st February 2014 at 03:13 PM.
21st February 2014, 02:49 PM |#9004  
Junior Member
Flag Fuerth
Thanks Meter: 0
 
More
Quote:
Originally Posted by GermainZ

Define "nothing." Does the application fail to install? Or does the installer install correctly, but you're unable to install the framework from within the app? Can you get a logcat?

Sorry for being unclear. The application fails to install. It simply seems to be busy for some time and then ends without visible result. And as I"m not that familiar with the terms (plus English is not my native tongue) , what please is a logcat?
21st February 2014, 04:12 PM |#9005  
claytonjn's Avatar
Senior Member
Thanks Meter: 818
 
Donate to Me
More
Quote:
Originally Posted by phisama

Sorry for being unclear. The application fails to install. It simply seems to be busy for some time and then ends without visible result. And as I"m not that familiar with the terms (plus English is not my native tongue) , what please is a logcat?

http://lmgtfy.com/?q=logcat
The Following User Says Thank You to claytonjn For This Useful Post: [ View ]
21st February 2014, 05:36 PM |#9006  
GermainZ's Avatar
Forum Moderator / Recognized Developer / XDA Portal Team
Thanks Meter: 8,274
 
More
Quote:
Originally Posted by phisama

Sorry for being unclear. The application fails to install. It simply seems to be busy for some time and then ends without visible result. And as I"m not that familiar with the terms (plus English is not my native tongue) , what please is a logcat?

If it fails to install, you might not be running a supported Android version. Which OS version are you on?
We'd need a logcat to be sure about the reason, though. There are many tutorials around on how to take a logcat.
21st February 2014, 05:49 PM |#9007  
rovo89's Avatar
OP Senior Recognized Developer
Thanks Meter: 35,659
 
Donate to Me
More
Quote:
Originally Posted by CodeingBoy

Sorry for I forgot to upload logs.

I had a quick look at it:
Code:
02-19 20:08:50.988: W/Zygote(5264): Caused by: java.lang.NullPointerException
02-19 20:08:50.988: W/Zygote(5264): 	at android.content.res.MiuiResources.loadOverlayDrawable(MiuiResources.java:212)
02-19 20:08:50.988: W/Zygote(5264): 	at android.content.res.Resources$Injector.createFromResourceStream(Resources.java:81)
02-19 20:08:50.988: W/Zygote(5264): 	at android.content.res.Resources.loadDrawable(Resources.java:1966)
Not sure what exactly they have changed, maybe it is simple to fix. Do you happen to have the framework*.jar (+odex if applicable) of the last working version AND the this version or a link where I could download these ROMs to extract it myself?

Quote:
Originally Posted by chavocarlos

Anybody have issues using OpenVPN https://play.google.com/store/apps/d...penvpn.openvpn with Xposed Installed ??
I can't connect and logcat show like OpenVPN program detects xposed framework.

02-21 10:08:58.721 E/VpnConfirm(20698): at de.robv.android.xposed.XposedBridge.main(XposedBri dge.java:126)

Regards.

This line just says that Xposed is installed, nothing else. You will find it in any stack trace because it's at the entry point of the Android system. You can easily test if Xposed has something to do with it by uninstalling Xposed temporarily.
21st February 2014, 06:00 PM |#9008  
chavocarlos's Avatar
Senior Member
Flag Guayaquil
Thanks Meter: 103
 
More
Quote:
Originally Posted by rovo89

I had a quick look at it:

Code:
02-19 20:08:50.988: W/Zygote(5264): Caused by: java.lang.NullPointerException
02-19 20:08:50.988: W/Zygote(5264): at android.content.res.MiuiResources.loadOverlayDrawable(MiuiResources.java:212)
02-19 20:08:50.988: W/Zygote(5264): at android.content.res.Resources$Injector.createFromResourceStream(Resources.java:81)
02-19 20:08:50.988: W/Zygote(5264): at android.content.res.Resources.loadDrawable(Resources.java:1966)
Not sure what exactly they have changed, maybe it is simple to fix. Do you happen to have the framework*.jar (+odex if applicable) of the last working version AND the this version or a link where I could download these ROMs to extract it myself?



This line just says that Xposed is installed, nothing else. You will find it in any stack trace because it's at the entry point of the Android system. You can easily test if Xposed has something to do with it by uninstalling Xposed temporarily.

Yes, I did it, and then works. Install again and stop working.

Regards.

Sent from my Nexus 4 using Tapatalk
21st February 2014, 06:07 PM |#9009  
rovo89's Avatar
OP Senior Recognized Developer
Thanks Meter: 35,659
 
Donate to Me
More
Quote:
Originally Posted by rovo89

FYI, I will participate in a Reddit AMA ("Ask Me Anything") this Friday (Feb 21) at 19:00 CET (other timezones here).

I'm new to Reddit, so I'm not sure yet what kind of questions I will get. We will see. If you have a question as well, feel free to join.

Just to set expectations right (and even though it's called AMA):
I will NOT answer support "questions" in this session, they should be asked here (for the framework/installer) or in the module threads.
I will NOT (and cannot) answer questions about specific modules.
I will NOT answer module requests and probably I cannot say whether high-level feature XYZ can be implemented with Xposed - that's only possible after a time-consuming technical analysis.

As a reminder, I'm now answering questions on Reddit: http://www.reddit.com/r/Android/comm...of_xposed_ama/
The Following 14 Users Say Thank You to rovo89 For This Useful Post: [ View ]
21st February 2014, 06:24 PM |#9010  
Senior Member
Metz
Thanks Meter: 16
 
More
Hi @rovo89,

People like me with MTK6592 have some issues with Xposed Framework when we installed it we have a bootloop, what we can do to help you to solve this issues?!

Thx in advance

Regards
Dexx
The Following User Says Thank You to dexxa05 For This Useful Post: [ View ]
Thread Closed Subscribe to Thread

Tags
don't ask questions about modules here!!!, framework, xposed
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes