Android 5.0.2 and New Factory Images For Nexus 7 (Wi-Fi) Available

Android 5.0 is has been publicly available since early November, and the … more

Github Tutorial App Shows You How to Use… Github

Github can get pretty complicated and using it can become quite daunting, especially … more

Google Glass-like Clip-On For Regular Glasses Developed by Sony

For the price of $2,000, a pair of glasses that can run apps, take pictures, … more

Micromax Takes OnePlus to Court! Android Wear Receives Lollipop – XDA TV

Android 5.0 Lollipop is available officially for the Moto 360! … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Xperia Home FC

OP Rumman Shaikh

30th May 2014, 05:22 AM   |  #1  
Rumman Shaikh's Avatar
OP Senior Member
Flag Mumbai
Thanks Meter: 563
 
283 posts
Join Date:Joined: Apr 2013
More
After upgrading to Kitkat, I've started getting FC 's everytime the screen is rotated in any app, after opening camera, even while on homescreen :-/

I disabled xposed and the problem was gone....so something in xposed causing problems here.
I even tried disabling many modules that effect system ui but still same.

Can anyone please help me, to identify what's wrong here?
Anything related to framework /module that's causing the FC?

I've provided logcat,logs below for the FC.

Please help, as the FC is very annoying, everytime

Xposed log: https://www.dropbox.com/s/xcn92mpx8toid76/error.log

Logcat: https://www.dropbox.com/s/qk9cyzbwsh...0-08-36-09.txt



Sent from my Xperia ZL (4.4.2 Stock , Rooted , De-odexed, Xposed) (C6502) using Tapatalk Pro


XDA Y U SO AWESOME?? ლ(ಠ益ಠლ)
30th May 2014, 08:09 AM   |  #2  
rovo89's Avatar
Senior Recognized Developer
Thanks Meter: 15,323
 
2,386 posts
Join Date:Joined: Jan 2012
More
Please disable all modules. There is at least one (something Xperia specific) which is causing errors.
30th May 2014, 08:30 AM   |  #3  
Rumman Shaikh's Avatar
OP Senior Member
Flag Mumbai
Thanks Meter: 563
 
283 posts
Join Date:Joined: Apr 2013
More
Quote:
Originally Posted by rovo89

Please disable all modules. There is at least one (something Xperia specific) which is causing errors.

I tried that,disabled all Xperia related modules, but the problem was still there
What's strange is that sometimes after fiddling with some modules the problem vanishes, and suddenly comes back out of nowhere :-/
The logs,logcats didn't give any hint of what's wrong?at least some idea? 😅
Please help
Last edited by Rumman Shaikh; 30th May 2014 at 08:32 AM.
30th May 2014, 08:42 AM   |  #4  
rovo89's Avatar
Senior Recognized Developer
Thanks Meter: 15,323
 
2,386 posts
Join Date:Joined: Jan 2012
More
As I said, please disable absolutely all modules, no exceptions. Only then I will have a look at a logcat.
1st June 2014, 07:57 AM   |  #5  
Rumman Shaikh's Avatar
OP Senior Member
Flag Mumbai
Thanks Meter: 563
 
283 posts
Join Date:Joined: Apr 2013
More
Quote:
Originally Posted by rovo89

As I said, please disable absolutely all modules, no exceptions. Only then I will have a look at a logcat.

I did just that,and I found that there's not one "single" module that's causing the problem, but I think it's because of two or maybe three conflicting modules.
Only workaround that I found, was to disable resource hooks, and then enable it(tick... Untick :P ) ,that solves the FC till next boot.... Strange.
3rd August 2014, 10:16 AM   |  #6  
irvingyeh85's Avatar
Junior Member
Thanks Meter: 1
 
7 posts
Join Date:Joined: Oct 2013
Can U tell me what module makes home FC?
I've disturb to the problem for a long time

Sent from my C6503 using XDA Free mobile app
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes