Post Reply

Xposed modules not working!

OP simanto117

3rd September 2014, 01:39 AM   |  #1  
OP Junior Member
Flag Dhaka
Thanks Meter: 0
 
3 posts
Join Date:Joined: Sep 2014
More
Device name: Walton Primo G4 (MT6572)
OS: 4.2.2

i installed Xposed installer. then updated it and rebooted my device. it seemed ok. then i downloaded some modules, activated it and rebooted my device. unfortunately it didn't work. here's the log file. plz help
Attached Files
File Type: txt xposed_error_20140903_061802.txt - [Click for QR Code] (1.1 KB, 26 views)
3rd September 2014, 05:51 AM   |  #2  
GermainZ's Avatar
Forum Moderator / Recognized Developer / XDA Portal Team
Thanks Meter: 6,833
 
5,719 posts
Join Date:Joined: Aug 2012
Donate to Me
More
Looks like you've installed the modules to your external SD card. Try moving them to the internal storage.
The Following User Says Thank You to GermainZ For This Useful Post: [ View ]
3rd September 2014, 06:44 AM   |  #3  
OP Junior Member
Flag Dhaka
Thanks Meter: 0
 
3 posts
Join Date:Joined: Sep 2014
More
Quote:
Originally Posted by GermainZ

Looks like you've installed the modules to your external SD card. Try moving them to the internal storage.

thanks. it works now
5th September 2014, 07:39 PM   |  #4  
zzEvilGeniuszz's Avatar
Member
Thanks Meter: 17
 
94 posts
Join Date:Joined: Jun 2014
Sorry if this is wrong place to put this but I am having a similar issue,

Sep 5, 2014 6:25:43 PM UTC
Loading Xposed v54 (for Zygote)...
Running ROM 'MT2-L03V100R001C00B126' with fingerprint 'Huawei/MT2L03/hwMT2L03:4.3/HuaweiMT2L03/C00B126:user/ota-rel-keys,release-keys'
Errors during Xposed initialization
java.lang.ClassCastException: class android.content.res.XResources doesn't extend class android.content.res.ResourcesEx
at de.robv.android.xposed.XposedBridge.cloneToSubclas s(XposedBridge.java:787)
at de.robv.android.xposed.XposedBridge.hookResources( XposedBridge.java:365)
at de.robv.android.xposed.XposedBridge.initXbridgeZyg ote(XposedBridge.java:267)
at de.robv.android.xposed.XposedBridge.main(XposedBri dge.java:117)
at dalvik.system.NativeStart.main(Native Method)
5th September 2014, 07:58 PM   |  #5  
GermainZ's Avatar
Forum Moderator / Recognized Developer / XDA Portal Team
Thanks Meter: 6,833
 
5,719 posts
Join Date:Joined: Aug 2012
Donate to Me
More
Quote:
Originally Posted by zzEvilGeniuszz

Sorry if this is wrong place to put this but I am having a similar issue,

Sep 5, 2014 6:25:43 PM UTC
Loading Xposed v54 (for Zygote)...
Running ROM 'MT2-L03V100R001C00B126' with fingerprint 'Huawei/MT2L03/hwMT2L03:4.3/HuaweiMT2L03/C00B126:user/ota-rel-keys,release-keys'
Errors during Xposed initialization
java.lang.ClassCastException: class android.content.res.XResources doesn't extend class android.content.res.ResourcesEx
at de.robv.android.xposed.XposedBridge.cloneToSubclas s(XposedBridge.java:787)
at de.robv.android.xposed.XposedBridge.hookResources( XposedBridge.java:365)
at de.robv.android.xposed.XposedBridge.initXbridgeZyg ote(XposedBridge.java:267)
at de.robv.android.xposed.XposedBridge.main(XposedBri dge.java:117)
at dalvik.system.NativeStart.main(Native Method)

Check the FAQ.
5th September 2014, 08:00 PM   |  #6  
zzEvilGeniuszz's Avatar
Member
Thanks Meter: 17
 
94 posts
Join Date:Joined: Jun 2014
Quote:
Originally Posted by GermainZ

Check the FAQ.

Yes I did that and found nothing about my situation.
5th September 2014, 08:54 PM   |  #7  
GermainZ's Avatar
Forum Moderator / Recognized Developer / XDA Portal Team
Thanks Meter: 6,833
 
5,719 posts
Join Date:Joined: Aug 2012
Donate to Me
More
Quote:
Originally Posted by zzEvilGeniuszz

Yes I did that and found nothing about my situation.

http://forum.xda-developers.com/show...82&postcount=8
5th September 2014, 09:23 PM   |  #8  
zzEvilGeniuszz's Avatar
Member
Thanks Meter: 17
 
94 posts
Join Date:Joined: Jun 2014
Quote:
Originally Posted by GermainZ

http://forum.xda-developers.com/show...82&postcount=8

That you for that. It says...

Quote:

Solution:
As a workaround, you can simply disable the resources API in the Xposed Installer settings. Some modules won't work anymore, but most should still work. Mid-term, I hope that I can build a solution that works with such ROMs as well, however it will take some time.

However I am on 2.7 and it does not have this option.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Xposed General by ThreadRank