FORUMS

[ROM][OFFICIAL][mermaid][10] LineageOS 17.1

7,872 posts
Thanks Meter: 16,389
 
By LuK1337, Recognized Developer on 16th February 2020, 10:50 PM
Post Reply Email Thread


LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

Instructions :
  • Download the latest build and gapps
  • Boot to recovery
  • Flash the latest build
  • Boot to recovery again
  • Flash gapps
  • Reboot
Downloads :Reporting Bugs
  • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
  • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
  • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
  • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

Code:
What is your--
LineageOS version:
LineageOS Download url:
Gapps version:
 
Did you--
wipe:
 restore with titanium backup:
reboot after having the issue:
 
Are you using--
a task killer:
a non-stock kernel:
other modifications:
 
Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
XDA:DevDB Information
[ROM][OFFICIAL][mermaid][10] LineageOS 17.1, ROM for the Sony Xperia X10 Plus

Contributors
LuK1337
Source Code: https://github.com/LineageOS

ROM OS Version: Windows 8 Mobile

Version Information
Status: Testing

Created 2020-02-16
Last Updated 2020-04-01
The Following 3 Users Say Thank You to LuK1337 For This Useful Post: [ View ]
17th February 2020, 10:54 AM |#3  
Junior Member
Flag Saint-Petersburg
Thanks Meter: 0
 
More
Just bootlop
Great performance and smoothness.
17th February 2020, 10:59 AM |#4  
Quote:
Originally Posted by reintal

Just bootlop

Did you format data? If that didn't help, mind sending me a msg on irc?
https://kiwiirc.com/nextclient/irc.f...nnel=#titandev
20th February 2020, 01:38 PM |#5  
Junior Member
Flag Saint-Petersburg
Thanks Meter: 0
 
More
NFC does not work
20th February 2020, 05:23 PM |#7  
Junior Member
Flag Saint-Petersburg
Thanks Meter: 0
 
More
Quote:
Originally Posted by LuK1337

Works here? I just tried Android Beam.

He works with some issues, sometimes i can't read nfc cards and use android beam. I assume this is an application problem.
22nd February 2020, 03:21 PM |#8  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by LuK1337

oh btw you might want to use this TWRP for flashing my builds.


X10 plus I4293, use this TWRP 3.3.1-1,
if use fastboot boot twrp.img, the touch is right,
if install Recovery ramdisk, then use Vol- and Power into twrp, the Touch is unavailable!
22nd February 2020, 03:46 PM |#9  
Quote:
Originally Posted by easyt

X10 plus I4293, use this TWRP 3.3.1-1,
if use fastboot boot twrp.img, the touch is right,
if install Recovery ramdisk, then use Vol- and Power into twrp, the Touch is unavailable!

Oh. I kinda understand why something like this would happen...
Can you come irc? I don't want to reflash stock just to debug this.

EDIT: Maybe fixed in twrp-3.3.1-2-mermaid.img.
The Following User Says Thank You to LuK1337 For This Useful Post: [ View ]
27th February 2020, 07:17 AM |#10  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by LuK1337

Oh. I kinda understand why something like this would happen...
Can you come irc? I don't want to reflash stock just to debug this.

EDIT: Maybe fixed in twrp-3.3.1-2-mermaid.img.


I re-flashed the official firmware, and then flash twrp again, it's right!
thank you
The Following User Says Thank You to easyt For This Useful Post: [ View ] Gift easyt Ad-Free
29th February 2020, 12:08 PM |#11  
Junior Member
Flag Yekaterinburg
Thanks Meter: 0
 
More
Two sim
Quote:
Originally Posted by LuK1337

Oh. I kinda understand why something like this would happen...
Can you come irc? I don't want to reflash stock just to debug this.

EDIT: Maybe fixed in twrp-3.3.1-2-mermaid.img.

Two sim does not work when an SD card is inserted
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes