FORUMS

[ROM][9.0_r46][mermaid] SonyAOSP

491 posts
Thanks Meter: 553
 
By Haxk20, Senior Member on 11th September 2019, 05:11 PM
Post Reply Email Thread
Code:
#include "std_disclaimer.h"
/*
 * Your warranty is now void.
 *
 * I am not responsible for bricked devices, dead SD cards,
 * thermonuclear war, or you getting fired because the alarm app failed. Please
 * do some research if you have any concerns about features included in this ROM
 * before flashing it! YOU are choosing to make these modifications, and if
 * you point the finger at me for messing up your device, I will laugh at you.
 */
The Sony Open Devices Project is always happy about volunteers (coding, testing, etc)

Whats Working:
Probably everything.

Whats not Working:
Everything should work. If you find bug then please report it here: https://github.com/sonyxperiadev/bug_tracker/issues

Steps to flash:
  • fastboot flash boot boot.img
  • fastboot flash system system.img
  • fastboot flash vendor vendor.img
  • fastboot flash userdata userdata.img (WARNING: This will delete all your data on device so have a backup before doing anything)
  • fastboot flash oem NameOfOEMFile.img
You only need to flash userdata.img when you are going from Stock Firmware to AOSP or when you get issues with future builds.

Downloads:
ROM Dual SIM: Download all the files in that folder
ROM Single SIM: Download all the files in that folder
OEM: OEM Unzip this and flash it as OEM. Instructions above

XDA:DevDB Information
[ROM][9.0_r46][mermaid] SonyAOSP, ROM for the Sony Xperia X10 Plus

Contributors
Haxk20
Source Code: https://android.googlesource.com/platform/manifest

ROM OS Version: 9.x Pie
ROM Kernel: Linux 4.x

Version Information
Status: Beta

Created 2019-09-11
Last Updated 2020-01-03
The Following 4 Users Say Thank You to Haxk20 For This Useful Post: [ View ] Gift Haxk20 Ad-Free
11th September 2019, 05:11 PM |#2  
Haxk20's Avatar
OP Senior Member
Thanks Meter: 553
 
More
Reserved
NOW: Build for both Dual and Single SIM variants is in to download and test.
11th September 2019, 05:11 PM |#3  
Haxk20's Avatar
OP Senior Member
Thanks Meter: 553
 
More
Reserved
18th September 2019, 11:32 AM |#4  
Junior Member
Thanks Meter: 0
 
More
Help, brothers! Dual sim dont work!!! The network appears and disappears. I bought a phone in Russia. presented to my sister in Belarus. And stumbled upon this problem. Need detailed instructions for flashing the radio module, please!
18th September 2019, 03:29 PM |#5  
Haxk20's Avatar
OP Senior Member
Thanks Meter: 553
 
More
Quote:
Originally Posted by [email protected]

Help, brothers! Dual sim dont work!!! The network appears and disappears. I bought a phone in Russia. presented to my sister in Belarus. And stumbled upon this problem. Need detailed instructions for flashing the radio module, please!

Is this issue with the ROM ? Or is the phone running stock firmware ?
If its stock then please move the discussion to questions and answers in 10 Plus forum.
If this is issue with AOSP then please flash stock firmware to check if its working on stock firmware.
3rd January 2020, 12:05 AM |#6  
Junior Member
Thanks Meter: 0
 
More
I flashed and was able to boot up ok. Initially the phone would only boot up to a blank screen. You could see the volume change when hit vol+ or vol-, the background would remain black. Pulling the SD card and Sim out cause a reboot automatically that seemed to resolve this. The connection to wifi and lte connects and unexpectedly drops. This happens over and over, I cannot make calls or use sms . The browser works fine with the limited LTE time and wifi. There is a vzwinternet apn, I cannot edit them. I wasn't sure if here or where to post. The link to github doest work. The rom is fine otherwise and easily root with magisk 20.1
3rd January 2020, 06:43 PM |#7  
Haxk20's Avatar
OP Senior Member
Thanks Meter: 553
 
More
Quote:
Originally Posted by yitakumini

I flashed and was able to boot up ok. Initially the phone would only boot up to a blank screen. You could see the volume change when hit vol+ or vol-, the background would remain black. Pulling the SD card and Sim out cause a reboot automatically that seemed to resolve this. The connection to wifi and lte connects and unexpectedly drops. This happens over and over, I cannot make calls or use sms . The browser works fine with the limited LTE time and wifi. There is a vzwinternet apn, I cannot edit them. I wasn't sure if here or where to post. The link to github doest work. The rom is fine otherwise and easily root with magisk 20.1

Link to github is fixed. Thank you for that.

I can say that the ROM worked just fine for me. I switched to different ROM few months ago now and this ROM has no support now. It is very likely you installed wrong OEM image. Please install the latest one for 4.9 kernel.
Because we have started working on 4.14 and well its still in alpha and those 4.14 images there are for us to test it properly.
The WiFi dropping out is known bug and sadly we do not have a fix for it yet.
Please open a bug report on that github repo and explain the issue and post logcat and dmesg files there.

EDIT: Ah my bad. It seems like i already pointed to the correct OEM image. Interesting that calls dont work.
The Following User Says Thank You to Haxk20 For This Useful Post: [ View ] Gift Haxk20 Ad-Free
11th January 2020, 08:27 PM |#8  
Junior Member
Thanks Meter: 0
 
More
Yo, i've installed the ROM and tried to flash gapps but they didn't install. Is there a way to flash them?
11th January 2020, 10:14 PM |#9  
Haxk20's Avatar
OP Senior Member
Thanks Meter: 553
 
More
Quote:
Originally Posted by demonic8383

Yo, i've installed the ROM and tried to flash gapps but they didn't install. Is there a way to flash them?

You will have to boot TWRP and flash it trough TWRP as AOSP recovery doesnt support flashing openGapps.
Booting up TWRP can be a bit tricky so well good luck.
11th January 2020, 11:36 PM |#10  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Haxk20

You will have to boot TWRP and flash it trough TWRP as AOSP recovery doesnt support flashing openGapps.
Booting up TWRP can be a bit tricky so well good luck.

Booting into TWRP after the first boot into AOSP is kinda impossible - as far as I know the only way to get TWRP to boot for this device is first to flash the stock ROM -> wait for it to boot completely -> go to bootloader through the ADB command (key combination results in stuck TWRP logo) -> then boot into TWRP. Getting there through the key combination results in black screen. TWRP is in unofficial state - it works only on the stock ROM and only with "fastboot boot twrp.img", it cannot be flashed yet. I'm using this version - https://forum.xda-developers.com/10-...icial-t3954147
Installing it is possible, however the touchscreen stops working in TWRP when booting the installed version.
Any suggestions on that?
12th January 2020, 12:28 AM |#11  
Haxk20's Avatar
OP Senior Member
Thanks Meter: 553
 
More
Quote:
Originally Posted by demonic8383

Booting into TWRP after the first boot into AOSP is kinda impossible - as far as I know the only way to get TWRP to boot for this device is first to flash the stock ROM -> wait for it to boot completely -> go to bootloader through the ADB command (key combination results in stuck TWRP logo) -> then boot into TWRP. Getting there through the key combination results in black screen. TWRP is in unofficial state - it works only on the stock ROM and only with "fastboot boot twrp.img", it cannot be flashed yet. I'm using this version - https://forum.xda-developers.com/10-...icial-t3954147
Installing it is possible, however the touchscreen stops working in TWRP when booting the installed version.
Any suggestions on that?

Unfortunately no. SODP does not officially support openGapps and this rom isnt maintained anymore as we are working on 10.
Also twrp for our device will never be flashable image as its useless to do so. We do not have recovery partition and thus have to have recovery in boot image and we build AOSP with stock recovery as its almost impossible to build it with TWRP using AOSP sources. And my guess is that TWRP wont get any better until it supports android 10 which is when we can finally start working on it.
Also on twrp i was able to boot to twrp using this ROM. It was tricky and im guessing the times i did boot it it was just luck.

So so far its a mess.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes