FORUMS

WiFi Calling / VoLTE on Mi 9

53 posts
Thanks Meter: 32
 
By lightcao, Member on 3rd April 2019, 05:33 PM
Post Reply Email Thread
Just wanted to share my experience with WiFi Calling. I am in the US on T-Mobile and WiFi calling has been working for me surprisingly. VoLTE has also been working wonderfully. I've tested this on a Global Mi 9 running Stock and the Xiaomi.eu rom.

Enter these codes into the Dialer to enable the options in Settings. (Settings < SIM Cards & mobile networks < Sim Card Settings < VoLTE Enabled/Make Calls using WLAN)

VoLTE *#*#86583#*#*
VoWIFI *#*#869434#*#*


Things should work after you enable the two options. This depends on whether or not your carrier supports it and your e911 address set (US only?).

Some issues you might run into is that the option for Network Preference is greyed out and you will unable to change that option. I've had some success if you disable it and re-enable it and click on that option really fast, it will go through. When you first enable VoWiFi, it is important that you get into this menu and change it to WiFi preferred or WiFi Calling won't work.

UPDATE:

Manually creating your carrier APN worked great for me. Been testing it for about 2 weeks and I haven't had any issues with VoLTE/VoWiFi. For example, for me on T-Mobile, I created a new one with the following settings. The important part I'm guessing is the APN type. Also make sure that your carrier has enabled WiFi Calling on their end as well.

APN: fast.t-mobile.com
MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
MMC : 310
MNC: 260
APN type: default,supl,mms,ims,cbs
APN protocol: IPv4/IPv6
APN roaming protocol: IPv4/IPv6
The Following 15 Users Say Thank You to lightcao For This Useful Post: [ View ] Gift lightcao Ad-Free
4th April 2019, 01:54 AM |#2  
Ulver's Avatar
Senior Member
Thanks Meter: 491
 
More
On a side note, since you're on T-Mobile US, are you getting LTE+? I was showing LTE+ on my Mix 2S and Mi 8, but doesn't show up on my Mi 9.
8th April 2019, 08:24 AM |#3  
fp1707's Avatar
Senior Member
Flag Los Angeles
Thanks Meter: 117
 
More
Can verify, works with Chinese Mi 9 8GB 128GB version. I'm also on T-Mobile. Now there is "HD" written on the signal icon.

---------- Post added at 08:24 AM ---------- Previous post was at 08:22 AM ----------

Quote:
Originally Posted by Ulver

On a side note, since you're on T-Mobile US, are you getting LTE+? I was showing LTE+ on my Mix 2S and Mi 8, but doesn't show up on my Mi 9.

It does when I'm outside. RN it isn't showing tho, I'm in the basement. I'm pretty sure I've seen it before when I'm on the bus or something
8th April 2019, 08:34 AM |#4  
ricjuh's Avatar
Member
Flag Heerlen
Thanks Meter: 13
 
More
Also works in Netherlands with Vodafone
11th April 2019, 01:24 PM |#5  
mNiosu's Avatar
Senior Member
Flag Ploiesti
Thanks Meter: 62
 
More
Quote:
Originally Posted by lightcao

Just wanted to share my experience with WiFi Calling. I am in the US on T-Mobile and WiFi calling has been working for me surprisingly. VoLTE has also been working wonderfully. I've tested this on a Global Mi 9 running Stock and the Xiaomi.eu rom.

Enter these codes into the Dialer to enable the options in Settings. (Settings < SIM Cards & mobile networks < Sim Card Settings < VoLTE Enabled/Make Calls using WLAN)

VoLTE *#*#86583#*#*
VoWIFI *#*#869434#*#*


Things should work after you enable the two options. This depends on whether or not your carrier supports it and your e911 address set (US only?).

Some issues you might run into is that the option for Network Preference is greyed out and you will unable to change that option. I've had some success if you disable it and re-enable it and click on that option really fast, it will go through. Another thing is that WiFi calling might glitch out if you have cellular on. It just randomly loses WiFi Calling. To solve this, I've been keeping my phone airplane mode with WiFi on and haven't experienced any type of disruption of service. Calls sounds great.

Worked like a charm on Romania's Orange network. Both VoLTE and VoWiFi seem to work well.
Thank you for the tip.
Quote:
Originally Posted by Ulver

On a side note, since you're on T-Mobile US, are you getting LTE+? I was showing LTE+ on my Mix 2S and Mi 8, but doesn't show up on my Mi 9.

I don't know if it helps, but in Romania on Orange I have 4G+ almost all the time while on my old Oneplus 5T I didn't...
The Following User Says Thank You to mNiosu For This Useful Post: [ View ] Gift mNiosu Ad-Free
11th April 2019, 09:36 PM |#6  
bogdanpop74's Avatar
Senior Member
Thanks Meter: 31
 
More
Volte Orange Romania
Hello , i have activated both, i have no options in settings.
12th April 2019, 07:31 AM |#7  
mNiosu's Avatar
Senior Member
Flag Ploiesti
Thanks Meter: 62
 
More
Quote:
Originally Posted by bogdanpop74

Hello , i have activated both, i have no options in settings.

It's a carrier specific option. So go to phone-> settings-> Sim cards &.....-> Orange and should be the last two options.
Attached Thumbnails
Click image for larger version

Name:	WhatsApp Image 2019-04-12 at 09.29.41.jpeg
Views:	8194
Size:	53.9 KB
ID:	4741164  
14th April 2019, 07:37 AM |#8  
Senior Member
Michigan
Thanks Meter: 15
 
More
Hmm...I've activated both too but only get the volte option, no wifi calling toggle switch. Tmobile USA running no root, stock miui 10.2.3. Did anyone on tmobile USA get wifi calling to work? Also, if you did, does it also activate wifi texting?

Update: guessing the volte doesn't require a restart but wifi calling requires a restart. To those who run into the same prob as me.
20th April 2019, 12:10 PM |#9  
crying's Avatar
Senior Member
Flag Paris
Thanks Meter: 20
 
More
Ídem here, no volte options, my carrier support it and works on a s7 edge, any ideas?

Envoyé de mon MI 9 en utilisant Tapatalk
3rd May 2019, 07:33 AM |#10  
bogdanpop74's Avatar
Senior Member
Thanks Meter: 31
 
More
Quote:
Originally Posted by mNiosu

It's a carrier specific option. So go to phone-> settings-> Sim cards &.....-> Orange and should be the last two options.

After update to Miui 10.2..24.0 options for VoLTE and VoWIFI appears in menu and i can activate both.
3rd May 2019, 09:59 AM |#11  
crying's Avatar
Senior Member
Flag Paris
Thanks Meter: 20
 
More
unlike you, since the last update 10.2.24.0 I lost the option volte/vowifi, when I try to reactivate it, the phone tell me it's enabled for the SIM 2 but I have no sim two,
if i swap the sim card it tell me activated for the sim 1 ...
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes