FORUMS
Remove All Ads from XDA

Installing Google Framework/Playstore without Root 5th Gen Amazon Fire 7in 2015 ONLY

13,217 posts
Thanks Meter: 5,689
 
Post Reply Email Thread
Many have reported issues with google framework on system versions 5.1.X
Google Framework seems to work fine on 5.3.X.X - 12 Aug 2016
Credit:
-http://forum.xda-developers.com/amaz...-fire-t3486603

System version 5.0.1: If you plan to root, just install open gapps using twrp or FlashFire (ARM 5.0.1 micro or smaller)
opengapps.org

How to Use FlashFire App
System version 5.0.0: If you don't take the update to 5.0.1, Google apps are not going to work correctly.
but you can do other things
Disable OTA - Keep SDCard Write Access and Use a Different Launcher *READ BEFORE BOOT by rivethead23
Have a Mac or Linux? see
see Longer Method in post #4
How To Sideload Google Play
(5th Gen Amazon Fire 2015)

Tomsgt has put together a little install bat (Amazon-Fire-5th-Gen-Install-Play-Store.zip)
Now includes Removing Advertising and Blocks Over the Air System Updates (02 Nov 2015)
watch Video here https://youtu.be/j-glxYTY8O8
Required:
PC, Drivers, usb debugging on

Just download to Pc
Amazon-Fire-5th-Gen-Install-Play-Store.zip
MD5: 161C89FCBCB687A81ADA52A993DB52C7
extract files (unzip)
open Amazon-Fire-5th-Gen-Install-Play-Store folder
run 1-Install-Play-Store.bat
follow instructions
reboot


Note: Wait 10 mins or so, before you worry about things not working.
Google play services needs to automatically update, and work things out.


If play store will not open correctly
Reinstall
com.android.vending-5.9.12-80391200-minAPI9.apk


More HereOther Google apk versions
Errors
see Troubleshooting

Not Working
  • Google Inbox: version 1.12(101811474) (only version i have tested)
  • Discussion : Google Inbox by dawithers

03 Oct 2015: current versions I have
Gmail: version 5.6.103338659.release
Google Account Manager: version 4.4.4-1227136 (GoogleloginService.apk)
Google App: version 5.3.23.19.arm
Googgle play services: version 8.1.15 (2250156-230)
Google Services Framework: version 4.4.4.1227136
Google play store 5.9.12

I have had zero issues with playstore.
Playstore loads normally, no "work" issue
Paid apps have installed normally
signing in account, works
2 factor, works

03 Oct 2015: added 1-Install-Play-Store.bat
The Following 57 Users Say Thank You to sd_shadow For This Useful Post: [ View ] Gift sd_shadow Ad-Free
 
 
2nd October 2015, 04:57 PM |#2  
Troubleshooting

Issue connecting to Google servers try
Quote:
Originally Posted by popoyaya


"turn on 2-step authentication. after doing that i happily came across the error “couldn’t sign in: to access your account you must sign in on the web. touch next to start browser sign in.” which i knew would work. case solved for my issue. hope this helps others."




Store app is showing up as "Play Store | Work".
i think every one with that issue, has a grandfathered free Google Apps Account
If that is the case no fix, but should work fine
http://forum.xda-developers.com/show...8&postcount=27


if sign in hangs on connecting to servers, you may need to fix permissions for Google Play services
with an adb command

Enable Developer Options
Settings>Device Options>Tap on Serial Numbers several times>You are now Developer

Enable USB Debugging
Setttings>Device Options>Developer Options>Enable ADB>tap on toggle>Enable

Install ADB drivers

Setup adb.exe
Several options for this, one easy way is
[TOOL] [WINDOWS] ADB, Fastboot and Drivers - 15 seconds ADB Installer v1.4.2 by Snoop05

test adb in command prompt type
Code:
adb devices
press enter
should get a code return of something like
G000H404537702CP device

Note: if you get unauthorized, drivers are not correct

If you got a good code return
copy this code in command prompt
Code:
adb shell pm grant com.google.android.gms android.permission.INTERACT_ACROSS_USERS
and enter

there will not be any code return

retry signing in with google account

if play store fails to open reinstall
Google Play (com.android.vending-5.9.12-80391200-minAPI9.apk)


Quote:

Anyone have an idea how to add a second google Account? I use one account for play store and anotherone for g+, hangouts etc...

open gmail /settings /add account /google
should be options in hangouts also
The Following 15 Users Say Thank You to sd_shadow For This Useful Post: [ View ] Gift sd_shadow Ad-Free
2nd October 2015, 05:34 PM |#3  
dawithers's Avatar
Member
Flag Colorado
Thanks Meter: 13
 
More
Once I finally got a 4.4.4 set of framework and account manager apks and ran the adb permission command I was finally able to get my google apps like gmail and chrome to sign in.

The Play Store app immediately crashes right after opening before loading anything.
Google Inbox loads up and displays a list of emails and then crashes.
Hangouts appears to work well so far for messaging. I haven't tried any of the calling features yet.
Chrome, Gmail, Drive, Docs, Sheets, Books, Keep, Maps, Keyboard, Youtube, Chromecast and Calendar all appear to be working properly. I haven't used any of them extensively yet but they all loaded up and performed some quick basic functions without crashing.
2nd October 2015, 05:41 PM |#4  
Longer Method

Download ES File Explorer from the Amazon Marketplace. It's free.

Allow Apps from Unknown Sources
Settings>Security>tap toggle>Ok

Download https://mega.nz/#F!AI5n0AaR!Qw-WJrBoCP8bce-so0hzFQ
place on sd card

Install these files
Google Play (com.android.vending-5.9.12-80391200-minAPI9.apk)
Google Play Services (com.google.android.gms-6.6.03_(1681564-036)-6603036-minAPI9.apk)
Google Account Manager (GoogleLoginService.apk)
Framework (GoogleServicesFramework.apk)

open with file manager
file manager will ask if you want to install

Rebooting is a good idea.

most likely you will need to grant special permissions for Google Play services
with an adb command see post #2

Done.
The Following 7 Users Say Thank You to sd_shadow For This Useful Post: [ View ] Gift sd_shadow Ad-Free
2nd October 2015, 05:46 PM |#5  
dawithers's Avatar
Member
Flag Colorado
Thanks Meter: 13
 
More
Quote:
Originally Posted by sd_shadow

try com.android.vending-5.9.12-80391200-minAPI9.apk
https://mega.nz/#!pMJVSLgS!r6EiiEvkt...6YyGCLGFbCqSo4

I'll try it this afternoon. What should I expect? Does the play store actually function properly?
2nd October 2015, 05:46 PM |#6  
Quote:
Originally Posted by dawithers

I'll try it this afternoon. What should I expect? Does the play store actually function properly?

Yes everything works
The Following 2 Users Say Thank You to sd_shadow For This Useful Post: [ View ] Gift sd_shadow Ad-Free
2nd October 2015, 05:49 PM |#8  
I tried several things before it worked correctly
com.android.vending-5.9.12-80391200-minAPI9.apk is the last one I tried, but didn't update Mega folder.
The Following User Says Thank You to sd_shadow For This Useful Post: [ View ] Gift sd_shadow Ad-Free
2nd October 2015, 06:09 PM |#9  
Member
Thanks Meter: 23
 
More
Shadow, many thanks for this useful info and I now have Google Play working on Fire 7.

1, I downloaded the initial Google APKs
2, Installed them but Google Play would not load.
3, Unable to run suggest 'adb devices' command as using Linux and not Wintel platform.
4, installed [ com.android.vending-5.9.12-80391200-minAPI9.apk] onto Fire 7
5, Google Play and App install working

I have not tested any other features yet regarding Google Play.

UPDATE:
Not sure if there is a possible bug but when I try to install apps from Google store that I have already paid for I am prompted to pay again. The Google Play on my Fire 7 knows it is myself (it is logged in as me), as it is prompting for my card payment but it is not recognising I have paid for the apps previously.

The two apps I have tested are Google Analytixs and Aqua Mail Pro Key - both apps are not a one time purchase. I can install on as many Android based devices as possible.
The Following 4 Users Say Thank You to k3ll0gs For This Useful Post: [ View ] Gift k3ll0gs Ad-Free
2nd October 2015, 10:12 PM |#10  
Member
Thanks Meter: 4
 
More
google play services wants to update, do i let it?
2nd October 2015, 10:20 PM |#11  
Quote:
Originally Posted by shiz0id

google play services wants to update, do i let it?

Should be fine to update

Sent from my XT907 using Tapatalk
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes