FORUMS
Remove All Ads from XDA

Mate 10 with Astra K - Black HU Screen

165 posts
Thanks Meter: 21
 
By drwharris, Senior Member on 26th January 2018, 11:48 AM
Post Reply Email Thread
Ive just bought a brand new Mate 10 which came with EMUI 8.0.0 (Android Oreo 8.0). Everything is great except that when I plug the phone into my car Android Auto starts on the phone (Black AA Screen) and the HU starts to switch to AA but all I get is a black screen. Whats even more interesting is that AA seems to be alive behind it all as if I touch the screen, things happen, eg if I press the hardware phone button and then touch the screen, it will call someone. If I hold the hardware phone button down I can issue voice commands.

Any idea's how I can get my HU screen to work?
 
 
26th January 2018, 02:06 PM |#2  
Senior Member
Thanks Meter: 45
 
More
I am using a Xiaomi A1 running Android8.0 and also have an Opel Astra K - with no AA-problems!
Try to check your cable, or replace your cable to the original one ...
26th January 2018, 08:12 PM |#3  
OP Senior Member
Thanks Meter: 21
 
More
Quote:
Originally Posted by Tiemichael

I am using a Xiaomi A1 running Android8.0 and also have an Opel Astra K - with no AA-problems!
Try to check your cable, or replace your cable to the original one ...

Yep, using the supplied cable. Tried 2 others as well. Same behaviour.

Sent from my ALP-L29 using Tapatalk
29th January 2018, 10:08 AM |#4  
OP Senior Member
Thanks Meter: 21
 
More
Poxy lame response from. Huawei:

"Thank you very much for contacting Huawei and we are truly sorry for the inconvenience caused.


With regards to your inquiry, we would like to inform you that Huawei is currently working with Google to fix this problem. Please look out for new updates for your phone system and Android Auto, and install the updates when possible. It is recommended that you wait for new updates in which the problem is fixed."


So 12 months after the issue was reported with Android 6 devices, it's still happening with Android 8. So #$@&ing lame.

Sent from my ALP-L29 using Tapatalk
2nd February 2018, 06:02 PM |#5  
WDawn's Avatar
Senior Member
Flag Zwevegem
Thanks Meter: 34
 
More
It's really incredible that this issue has not been fixed yet. I have issues too with my Huawei Mate 10 Pro and Android Auto. It's supposed to be a "flagship" device and it doesn't work with Android Auto. Wtf?
The Following User Says Thank You to WDawn For This Useful Post: [ View ] Gift WDawn Ad-Free
8th February 2018, 08:47 AM |#6  
Senior Member
Thanks Meter: 8
 
More
I was thinking about to get a Huawei mate 10 pro.

Googled android Auto and USB-C.

No thanks Looks I like I will look for an old USB phone.
8th February 2018, 09:35 AM |#7  
OP Senior Member
Thanks Meter: 21
 
More
Quote:
Originally Posted by Qefx

I was thinking about to get a Huawei mate 10 pro.

Googled android Auto and USB-C.

No thanks Looks I like I will look for an old USB phone.

DOnt be put off by USB-C. Its purely a Huawei issue. Point in case, my new Nokia 8 works great.
10th February 2018, 06:27 AM |#8  
Junior Member
Thanks Meter: 3
 
More
I dont think is the phone problem in your case it might be the AA car board compatibility! I have Mate 10 pro and honda civic 2018 and AA works with no issue.! I am a happy Huawei AA user: v well connectivity BT phone, media and charging in the same time of usingAA.
10th February 2018, 06:28 AM |#9  
OP Senior Member
Thanks Meter: 21
 
More
Quote:
Originally Posted by crislleen

I dont think is the phone problem in your case it might be the AA car board compatibility! I have Mate 10 pro and honda civic 2018 and AA works with no issue

Car works perfectly with my Oppo R7sf and Nokia 8. It's a phone issue.
10th February 2018, 06:37 AM |#10  
Junior Member
Thanks Meter: 3
 
More
that might be the car bord version of software and phone system... as i explained I do have honda civic 2018 with os 4.2.2 and my mate 10 pro emui 8.0.0
10th February 2018, 06:43 AM |#11  
OP Senior Member
Thanks Meter: 21
 
More
Quote:
Originally Posted by crislleen

that might be the car bord version of software and phone system... as i explained I do have honda civic 2018 with os 4.2.2 and my mate 10 pro emui 8.0.0

Could be. But it's clearly capable of running with Android 7(Oppo) and 8 and 8.1 phones (Nokia) so whose the best candidate?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes