FORUMS
Remove All Ads from XDA

Strange Problems with Joying 2gb Intel Sofia Head Unit on 6.0.1

25 posts
Thanks Meter: 0
 
By gdre, Junior Member on 6th June 2018, 05:19 PM
Post Reply Email Thread
13th June 2018, 07:24 AM |#11  
gdre's Avatar
OP Junior Member
Thanks Meter: 0
 
More
In the gtx thread there is some info in description
"Due to Bluetooth, WiFi, and as well as nvram patches in the ROM and bootloader, you must be running Joying 6.0 firmware dated 2017_12_15 or later to install this ROM."

but i'm on earlier update so i don't know which is the last gtx version i could use.
i have sent gtxaspec a private message couple of days ago but no answer still.

i will try to install twrp first. i think when that works it could take in the right direction
 
 
15th June 2018, 08:30 AM |#12  
gdre's Avatar
OP Junior Member
Thanks Meter: 0
 
More
i managed to install custom.apk. i had to access usb stick over root explorer from playstore because the stock filemanager won't let me access storage.
when i choose install custom recovery from custom.apk i get the message that i'm on the wrong update as i mentioned before
i think i maybe need an older version of custom.apk? hopefully then i'm able to install twrp that suits my current update version...
sadly in the mainthred the older versions if there any exists are not provided.
Attached Thumbnails
Click image for larger version

Name:	IMG_20180615_080129.jpg
Views:	20
Size:	246.7 KB
ID:	4527188  
15th June 2018, 09:42 AM |#13  
gtxaspec's Avatar
Senior Member
Thanks Meter: 484
 
Donate to Me
More
Quote:
Originally Posted by gdre

i managed to install custom.apk. i had to access usb stick over root explorer from playstore because the stock filemanager won't let me access storage.
when i choose install custom recovery from custom.apk i get the message that i'm on the wrong update as i mentioned before
i think i maybe need an older version of custom.apk? hopefully then i'm able to install twrp that suits my current update version...
sadly in the mainthred the older versions if there any exists are not provided.

Didn't see your message(sorry I get a lot)....

Update to the latest joying Intel room, listed in my thread under Q and A, then you should be able to install my ROM. 😀

Don't attempt install on old firmware, it causes issues with the bootloader and if difficult to fix. Follow all directions I'm my thread.
15th June 2018, 09:57 AM |#14  
surfer63's Avatar
Senior Member
Flag Zwolle
Thanks Meter: 643
 
Donate to Me
More
We have to start completely fresh here. If you started from a ROM earlier than October, your current MCU version is < 9.20.
The errors you get ("can't verify ..5009_60.zip") is due to incorrect signing and mixing all kind of ROMs and files and probably the TWRP recovery image. That will definitely not work.

Download/Use the latest ROM (2018-1-26; see below in blue) from here. (From this Joying blog https://www.joyingauto.com/blog/cate...iles-released/)
Code:
Below updated files is (2018-1-26) version . please check :

Updated files for HD resolution 1024*600  :
 MCU version is 9.20 or more later please click Here
 MCU version is 5.25 or more earlier  please click Here
If you flashed the TWRP recovery from the custom.apk then first write the stock recovery back.
Before trying to flash remove all SD-cards and usb-sticks from the unit and reboot with the usb-stick (or sd-card) with the complete unzipped ROM. Do not alter anything on this downloaded ROM.
Please try to flash that first. Then we see if it works or what error message we get. Do not try all kind of things with the TWRP/gtx ROM before your firmware and MCU firmware is correct.
If this doesn't work then we use the reset method: Use the same usb stick and use a "pointy thing" (needle or so) to reset your unit. Do this 3 times (reset immediately when you see the logo coming). Then the unit's leds will cycle purple/pink a few times and reboot the unit again perhaps 3 times and will then (hopefully) start the flash of the ROM. The pink/purple flashing/reboot can take 10 minutes: Have patience.

Maybe @gtxaspec has a few hints here as well.

Edit: and now @gtxaspec's post and mine are crossing.
15th June 2018, 09:24 PM |#15  
gdre's Avatar
OP Junior Member
Thanks Meter: 0
 
More
旧FYT SOFIA 1024x600 did the trick!
Now i think about flashing twrp and gtxrom
some problem left is my steering wheel control. i can't really remember but i think the profile was rcz_vw_low or something like that.
back then when i purchased the HU, steering wheel control works out of the box. with rcz_vw_l mode the buttons response but volume up and down only response repetitive.
before the update i was able to press and hold the button and the volume was increasing or decreasing without having to press again and again.
is this a problem with maybe wrong profile or some setting i missed?
other thing is i don't see setting for deactivating button/touch beep. before the update it was under car settings t think.

but first at all i'm happy and relieved that the HU is working.
thank you both for your help!
15th June 2018, 09:35 PM |#16  
surfer63's Avatar
Senior Member
Flag Zwolle
Thanks Meter: 643
 
Donate to Me
More
Quote:
Originally Posted by gdre

旧FYT SOFIA 1024x600 did the trick!
Now i think about flashing twrp and gtxrom
some problem left is my steering wheel control. i can't really remember but i think the profile was rcz_vw_low or something like that.

Nice to hear.
Try the RZC.XP(L)-VolkswagenALL
18th June 2018, 08:23 PM |#17  
gdre's Avatar
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by surfer63

Nice to hear.
Try the RZC.XP(L)-VolkswagenALL

That worked!
and the volume increase decrease is working too... sometimes i'm a little bit dump ... i had to press quiet a bit longer then the volume goes up or down when i press and hold up or down key at steering wheel. it seems there is a slightly more delay since the update.
only thing that is annoying is the button/touch beep. there is no option to turn it of... maybe i can get root to find and change / rename the soundfile?
any suggestions?
22nd June 2018, 05:13 PM |#18  
gdre's Avatar
OP Junior Member
Thanks Meter: 0
 
More
Ok i figured out the annoying beep thing. In car settings you have to switch to no amp then under sound settings tab the beep can be disabled.
as long as an active amp is choosen the option for beep is gone.
Hope that could help someone.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes