FORUMS
Remove All Ads from XDA

Reverse Camera APP?

4,196 posts
Thanks Meter: 216
 
By dkotoric, Senior Member on 10th March 2017, 01:59 PM
Post Reply Email Thread
Anyone know if there is a reverse camera app I can install so that I can launch my reverse camera even when driving if I wanted to?
 
 
10th March 2017, 04:43 PM |#2  
Senior Member
Thanks Meter: 34
 
More
If your camera isn't wired to your reverse lights (i.e.: only powered when in reverse) you can split the cameras RCA cable with a Y adapter and run one to the backup camera input and one to the AV input, then use AVIN to view the camera at any time. Note AVIN will take over the sound as well as the picture, but this is the easiest way to do that AFAIK.
10th March 2017, 04:55 PM |#3  
dkotoric's Avatar
OP Senior Member
Flag Ankeny
Thanks Meter: 216
 
More
Quote:
Originally Posted by Andromeda_Station

If your camera isn't wired to your reverse lights (i.e.: only powered when in reverse) you can split the cameras RCA cable with a Y adapter and run one to the backup camera input and one to the AV input, then use AVIN to view the camera at any time. Note AVIN will take over the sound as well as the picture, but this is the easiest way to do that AFAIK.

OK thanks, ya its just wired to the cigarette lighter wire for power. ok thanks seems like to much work, I thought it would be something simple like an app, dont feel like running a whole new cable from front to back.
10th March 2017, 05:25 PM |#4  
Senior Member
Thanks Meter: 34
 
More
You don't have to run a new cable like that, or even disconnect everything. Just pull the unit out enough to disconnect the camera, put on a Y splitter and connect it to reverse camera and AV in
If your head unit comes out easy should be ~10 minutes.
14th March 2017, 07:48 PM |#5  
Junior Member
Thanks Meter: 0
 
More
I have a problem with my camera - when the HU is fully booted up, it does not switch to reverse view. When it is booting (i.e. while in boot animation), it shows up correctly. I checked the signal, it's 12v when engaged reverse. I've tried reflashing stock rom with Malaysk, reflashing mcu; nothing works. Enabling the front camera in factory settings, putting in reverse and manually starting AVIN with reverse camera, it works. Any idea why it stopped automatic shift into "backup camera mode" and how to repair it?
14th March 2017, 10:39 PM |#6  
Oldpapa49's Avatar
Senior Member
Flag Eagle Mountain
Thanks Meter: 181
 
More
Quote:
Originally Posted by Tine1984

I have a problem with my camera - when the HU is fully booted up, it does not switch to reverse view. When it is booting (i.e. while in boot animation), it shows up correctly. I checked the signal, it's 12v when engaged reverse. I've tried reflashing stock rom with Malaysk, reflashing mcu; nothing works. Enabling the front camera in factory settings, putting in reverse and manually starting AVIN with reverse camera, it works. Any idea why it stopped automatic shift into "backup camera mode" and how to repair it?

Did you update your MCU file.. Look under factory settings and enable rear camera if it is not (might be called something else)
14th March 2017, 10:52 PM |#7  
Junior Member
Thanks Meter: 0
 
More
actually, i downgraded it.. from 2.86 to 2.85 as i havent found newer one for KLD6. I checked the factory settings toroughly, nothing helped. The problem came out of the blue, one day all was working fine, the next day this problem. No change in settings, installed apps, nothing.
16th March 2017, 09:18 PM |#8  
Junior Member
Thanks Meter: 0
 
More
Found it - using another "radio" setting under factory settings turned the cam back into normal operation!

Now my FM radio doesnt work with neither radio i choose. Some produce weird noise when chosen, some completely silent.

Is there any list of devices which radio should be set to which device? Mine is Eonon GA2114.

Regards,
Tine
13th April 2017, 01:30 PM |#9  
Senior Member
Baltimore
Thanks Meter: 801
 
More
I simply wired in a 12v switch to manually enable the rear camera. You will need a resistor but it's simple. When the head unit notices the camera getting power ( via switch ) it switches to the backup camera automatically. It does require running a power lead from somewhere though. I pulled mine from the power accessory wire, ran it to the switch, from switch to resistor....then to the radio.



Sent from my SM-G935T using Tapatalk
16th April 2017, 07:43 AM |#10  
Discussed before, no as not controlled by Android- it is controlled by the MCU, which receives the reverse switch input and mixes video.
The Following User Says Thank You to marchnz For This Useful Post: [ View ] Gift marchnz Ad-Free
19th April 2017, 02:15 AM |#11  
rickthecabbie's Avatar
Member
Wilkesboro, Or.
Thanks Meter: 25
 
More
O.K. we used to be able to launch the reverse camera by using F-Cam.apk and selecting the camera icon on the left side of the screen.
As long as the camera was powered and video while driving was enabled in the "driving" settings it would give a full screen view of the backup cam at any time regardless of what gear you were in. In malaysk 4.4.4 I have not found the icon on the left side anymore.
I tested his Lollipop build, and the icon is back in F-Cam.apk. and once again I can view the backup cam while driving around.
The backup camera may well be controlled by the MCU, but it is accessible through the F-cam App depending on the version.
Not sure why it doesn't work in the 4.4.4 anymore, but I hope to find a solution.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread