FORUMS
Remove All Ads from XDA

BMW E46 canbus

80 posts
Thanks Meter: 7
 
By pitu120, Member on 6th November 2016, 08:48 PM
Post Reply Email Thread
Hello

I Have MTCD Device (GS). I Have newest MCU 1.93. When I select from factory settings canbus: bmw see in apps application: vehicle but not working, also my steering wheel not working. When I set canbus on none my wheel working (ofc all without next/prev - im using mtcdtools for it). With canbus: BMW cant set buttons.

I Think my canbus decoder working if (in canbus option I have set on: none) steering wheel working? Or device has other way for it?
 
 
7th November 2016, 12:42 PM |#2  
Senior Member
Thanks Meter: 528
 
More
Quote:
Originally Posted by pitu120

Hello

I Have MTCD Device (GS). I Have newest MCU 1.93. When I select from factory settings canbus: bmw see in apps application: vehicle but not working, also my steering wheel not working. When I set canbus on none my wheel working (ofc all without next/prev - im using mtcdtools for it). With canbus: BMW cant set buttons.

I Think my canbus decoder working if (in canbus option I have set on: none) steering wheel working? Or device has other way for it?

I have mazda cx5 and aftermarket can bus decoder.
My decoder is able to get the reverse signal (it is coded by the can bus) and to transform the steering wheel buttons onto standard signals that can be read by aftermarket stereos (Alpine, pioneer, Kenwood, etc)
If I connect the headunit without can bus decoder, steering wheel buttons work...
If I connected the can bus decoder I had to remap again all buttons...as the signal.is different.

In your case you have a permanent decoder so the signal is transformed always....but the stereo is not recognizing at all.
Do you have any other can bus decoder option apart from.bmw? Try it
Did you check if your connections are on? (Not loose plugs)

Enviado desde mi D6603 mediante Tapatalk
7th November 2016, 12:56 PM |#3  
OP Member
Thanks Meter: 7
 
More
Quote:
Originally Posted by ikerg

I have mazda cx5 and aftermarket can bus decoder.
My decoder is able to get the reverse signal (it is coded by the can bus) and to transform the steering wheel buttons onto standard signals that can be read by aftermarket stereos (Alpine, pioneer, Kenwood, etc)
If I connect the headunit without can bus decoder, steering wheel buttons work...
If I connected the can bus decoder I had to remap again all buttons...as the signal.is different.

In your case you have a permanent decoder so the signal is transformed always....but the stereo is not recognizing at all.
Do you have any other can bus decoder option apart from.bmw? Try it
Did you check if your connections are on? (Not loose plugs)

Enviado desde mi D6603 mediante Tapatalk

Thanks for answer. I have canbus decoder like a: http://www.roadnavi.com/wp-content/u..._Decoder02.jpg
When I select BMW in factory setting I have vehicle app, with other dont see this app. So I think canbus working. I will check leter maybe I need to remap all wheel buttons as u said.
7th November 2016, 06:21 PM |#4  
Junior Member
Thanks Meter: 0
 
More
BMW E39, E46 and earlier do not use Canbus if K-Bus, use it from E60, E90

Enviado desde mi MX5 mediante Tapatalk
7th November 2016, 06:30 PM |#5  
OP Member
Thanks Meter: 7
 
More
So I need to remove my canbus decoder from device? Or what? How can I enable functions from vehicle app.
7th November 2016, 11:05 PM |#6  
Member
Flag Flevoland
Thanks Meter: 0
 
More
I have exact the same issue. Canbus is set to NO. Only that way my steering wheel buttons do work, once I tried the BMW Union and BMW Electronic canbussettings, I am not able to use the steering wheel buttons. Either the vehicle information app does not provide any car specific information.

Seems like to CANBUS decoder I received with my Xtrons (MTCD_GS) does not decode any vehicle information.

The thing I would like is a virtual/graphic PDC, I have it built in OEM. But when I put the car in reverse it doesn't show any PDC, only a blackscreen since I dont have a reverse camera.

Does anyone know how to get more information trough canbus?

I've got a BMW E46 320Ci 1999 (European).
7th November 2016, 11:15 PM |#7  
Senior Member
Thanks Meter: 528
 
More
Quote:
Originally Posted by pitu120

So I need to remove my canbus decoder from device? Or what? How can I enable functions from vehicle app.

Check the wire connections if you can bypass the swc controls only directly to the headunit and the input of the can-bus for the rest

Enviado desde mi D6603 mediante Tapatalk
8th November 2016, 11:43 AM |#8  
OP Member
Thanks Meter: 7
 
More
Quote:
Originally Posted by ikerg

Check the wire connections if you can bypass the swc controls only directly to the headunit and the input of the can-bus for the rest

Enviado desde mi D6603 mediante Tapatalk

OK but when I set canbus on BMW (union) I have vehicle app but no informations in, all in blank. So wheel and informations from canbus no working.
The Following User Says Thank You to pitu120 For This Useful Post: [ View ] Gift pitu120 Ad-Free
20th November 2016, 06:23 PM |#9  
Senior Member
Flag Warsaw
Thanks Meter: 234
 
Donate to Me
More
Quote:
Originally Posted by pitu120

OK but when I set canbus on BMW (union) I have vehicle app but no informations in, all in blank. So wheel and informations from canbus no working.

Hi,
For me it works in same way. When any CanBus mode is selected then steering wheel keys do not work. Our BMW are using I-Bus to broadcast messages within vehicle entertainment system.

Here is the scheme:
BMW Bus scheme

So our CanBus decoder is not really CanBus but IBus . It is wired to MFL and used only to obtain steering wheel keys events. This is the reason why "Steering Wheel Keys" mapping tool does not work in case of BMW (E39, E38, E46).

As far as I know in VW dedicated units you can control e.g. climate panel (IHKA) using CanBus decoder.
25th November 2016, 01:16 PM |#10  
Junior Member
Thanks Meter: 2
 
More
Are you sure that E46 actually had IBus? i thought its only using the kbus?
25th November 2016, 01:51 PM |#11  
Senior Member
Flag Warsaw
Thanks Meter: 234
 
Donate to Me
More
Quote:
Originally Posted by Plastefuchs

Are you sure that E46 actually had IBus? i thought its only using the kbus?

K-Bus, I-Bus - there is no difference at all. Protocol structure is the same. Just different peripherals are connected to bus line (see picture above).

E46, E39, E38 - all of them have I-Bus.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes