FORUMS
Remove All Ads from XDA

Chromecast 3rd gen boot loop, any solutions?

8 posts
Thanks Meter: 0
 
By drimena, Junior Member on 8th August 2019, 02:53 PM
Post Reply Email Thread
Hello good people,

A month ago I bought a Chromecast 3rd gen on Ebay and it worked properly until two days ago. I saw a black screen and nothing happened. My phone was unable to detect it in Google Home app. I even tried to factory reset it a dozen times as well as power cycling it. Nothing helps. It turns on, I see a small "Chromecast..." at the bottom followed by a 4 colored dots and the Google Logo. After the logo it's just a blank screen. The led indicator is just pulsing white and then it reboots and starts the same drill again. This same situation actually happened already some 15 days ago but it started working again after just a couple of reboots, but this time it rejects any cooperation. I live in a small country and we don't have Google support here and Ebay seller won't respond to my inquiries so I would like to know if there's a way to fix it myself.
Is there a way to revive the Chromecast somehow? Can I connect it to PC via USB and try executing some shell commands or something? What about flashing a ROM?

Any suggestion will be very much appreciated.

Thanks guys,
 
 
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes