FORUMS
Remove All Ads from XDA

[Test]NFC Enabled on Wear24!

34 posts
Thanks Meter: 9
 
By Steeleio, Member on 5th March 2018, 02:13 AM
Post Reply Email Thread
**Let me start off by saying that I have not had a chance to verify but I do not have the error that NFC is not enabled anymore.**

Requirements -
1. Android Pay (Google Pay will not work on my watch although I read a post by someone who says it works on theirs)
2. Tasker installed on phone
3. Autowear Plugin to Tasker installed on phone and watch
4. A PC with adb installed

Step 1: Enable Developer Options on Watch
Step 2: Turn on ADB Debugging and Debug over WiFi
Step 3: Open command prompt or powershell in the folder where you have adb (hold shift and right click)
Step 4: In powershell, type adb connect 198.162.X.X:5555 (use the actual IP of your watch). Press Enter. The watch will prompt you to accept the connection. Select Always Allow.
Step 5: Type adb shell pm grant com.joaomgcd.autowear android.permission.WRITE_SECURE_SETTINGS. Press Enter. It may take a minute or two but if you don't receive an error, it worked.
Step 6: Open Tasker on your phone. Select Tasks. Hit the + sign in the bottom right. Select Plugin -> Autowear -> Secure Settings. When the new window opens, click the pencil next to Configuration. Set Command to Execute to &CONNECTED&. Click Custom Setting. Setting Type is Global, Name is <NFC>, Input type is Toggle, and Value is 1. Once all those are set, click the back arrow to get back to the AutoWear Secure Settings page. Click the checkmark at the top to save the settings.
Step 7: In powershell on the pc, type adb install com.google.android_apkmirror.com.apk. Press Enter. It should say Success once it finishes.
Step 8: On your phone, under the Task Edit screen (where you should be if you did not exit out from step 6) click the "Play" button on the bottom left. You should get a green dot next to the word configuration at the top.
Step 9: Open Android Pay on the watch. It will take you through the setup and tell you to finish on your phone. Once you finish adding a card, it should show up on the watch. "To pay with your watch, you need to turn on NFC" will show up and blink a couple of times then go away. It should show your card with "Hold to terminal.." above it.

This is something I threw together real quick to get the word out. Like I said in the beginning, I have not tried it at a terminal yet. As soon as I do, I will repost with results. Also in the near future, I will streamline the process, add a command to Tasker to keep NFC on always, and hopefully pay without opening the Android Pay app on the watch (Simply have the watch unlocked). I have attached the Android Pay apk below. If anyone tries this and uses the watch at a terminal, please post results.
Attached Thumbnails
Click image for larger version

Name:	IMG_20180304_210824745.jpg
Views:	2024
Size:	258.5 KB
ID:	4437729   Click image for larger version

Name:	IMG_20180304_210831598.jpg
Views:	2026
Size:	231.7 KB
ID:	4437730  
Attached Files
File Type: apk com.google.android_apkmirror.com.apk - [Click for QR Code] (6.22 MB, 252 views)
The Following 4 Users Say Thank You to Steeleio For This Useful Post: [ View ] Gift Steeleio Ad-Free
 
 
5th March 2018, 09:16 PM |#2  
Senior Member
Flag Ballico
Thanks Meter: 27
 
More
I had a feeling a developer would find a way. I wonder why google pay isn't working for you and why Android pay says it needs NFC when it is already enabled. Have you tested to see if it does indeed enable it?
5th March 2018, 10:40 PM |#3  
OP Member
Flag Columbus
Thanks Meter: 9
 
More
Quote:
Originally Posted by developer209

I had a feeling a developer would find a way. I wonder why google pay isn't working for you and why Android pay says it needs NFC when it is already enabled. Have you tested to see if it does indeed enable it?

I am in no way a developer. Just trying some stuff out. I tried to Pay with the watch and it did not work. Hopefully someone with some knowledge and experience will see something here and guide us in the right direction to get this working.
5th March 2018, 10:44 PM |#4  
Senior Member
Flag Ballico
Thanks Meter: 27
 
More
That could mean one of two things, either the watch's NFC is not actually on or Android pay is not transmitting the signal.
18th March 2018, 11:59 PM |#5  
yochananmarqos's Avatar
Senior Member
Thanks Meter: 1,971
 
Donate to Me
More
This does not actually enable NFC. I tried paying with Google Pay and it did not detect anything. I don't think NFC can be enabled without root and adding some files that are missing.

Sent from my Nexus 6P using XDA Labs
23rd March 2018, 08:11 PM |#6  
adambomb_13's Avatar
Senior Member
Thanks Meter: 43
 
More
Verizon promised to add pay and turn NFC on I say we hold them to it as owners of their watch discontinued or not this is as advertised.
https://www.verizonwireless.com/supp...e-base-209381/
24th May 2018, 01:06 PM |#7  
Junior Member
Thanks Meter: 0
 
More
Is it possible that kernel doesn't include NFC drivers? Kernel sources here contain the NFC drivers, but are they on the device?
25th May 2018, 09:56 AM |#8  
SacredDeviL666's Avatar
Forum Moderator
¤No Man's Land¤
Thanks Meter: 4,060
 
More
Hi,

Added a tag to Title to avoid confusion.
The Following User Says Thank You to SacredDeviL666 For This Useful Post: [ View ] Gift SacredDeviL666 Ad-Free
Post Reply Subscribe to Thread

Tags
verizon-wear24

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes