FORUMS

[APP][MOD][ROOT/NONROOT] YouTube Vanced Edition

14 posts
Thanks Meter: 2,332
 
By Team Vanced, Junior Member on 4th March 2018, 09:06 PM
Post Reply Email Thread
14th February 2020, 02:08 PM |#14041  
Senior Member
Thanks Meter: 41
 
More
I updated the root version. I'm on xiaomi mi a1, Android 8.1, (Resurrection remix) opengapps, xposed framework and twrp. Unfortunately this root vanced version crashes a lot. I deleted cache and data. But the problem persists.
14th February 2020, 02:22 PM |#14042  
Eleo's Avatar
Senior Member
Flag Jena
Thanks Meter: 13,749
 
Donate to Me
More
Quote:
Originally Posted by XtraWater

I updated the root version. I'm on xiaomi mi a1, Android 8.1, (Resurrection remix) opengapps, xposed framework and twrp. Unfortunately this root vanced version crashes a lot. I deleted cache and data. But the problem persists.

You seem to be on an old version of ROM. There are android q ROMs available for mi a1. Even stock firmware is updated to android 9. You didn't even mention what root you are using and which version of that root. Supersu? Magisk? Date of gapps? Did you update gapps?

But either way, if you dont provide logs (since you are rooted you can even use alogcat, matlog and other apps) about "crashes" it is meaningless here. We can't say why or how your device crashes.

Also, xposed is not must to install vanced. There are plenty of other ways. And finally, if you are going to report any issue with logs, you should turn xposed completely off.

Here is a rough guide on "reporting":
https://forum.xda-developers.com/gen...8/post72606811

Last but not least, if you struggle with using rooted, then use unrooted vanced.

Off topic:

I hope moderators and thread contributors could add a rough guide on reporting vanced app issues somewhere to first page instead of giving warnings to users who have to read all these posts. We care about users. That is why we strive. It is not that I hate seeing a user reporting with no info. It is just impossible to ask each user to provide the necessary info for troubleshoot each and every time on each page of thread. And we are also not as cold blooded as to sit and laugh at users who have issues but don't know how to report so that there is no way to help them

But that should be one of the many reasons why there are more questions than answers in threads like these.

Cheers and Ciao

Sent from my Google Pixel 3a XL using XDA Labs
The Following 3 Users Say Thank You to Eleo For This Useful Post: [ View ] Gift Eleo Ad-Free
14th February 2020, 03:45 PM |#14043  
Senior Member
Thanks Meter: 41
 
More
@Eleo

I installed latest Youtube vanced root version. The issue, after a while, the app crashes / stops. It freezes for a second and then it shuts down itself.

What I use: Xiaomi Mi A1
Android 8.1 (Resurrection Remix)
root method: Magisk (19.3)
OpenGapps. (I just updated OpenGapps in hope it would resolve the issue. But no success)

I attach the logcat logfile. May be someone can have a look what might cause the issue. I stopped to recording log about 3 seconds after Vanced has stopped.

Thanks guys.

Edit: A snippet from the log:


[02-14 15:33:40.561 1915:4116 I/ActivityManager]
Start proc 20072:com.google.android.apps.walletnfcrel/u0a226 for broadcast com.google.android.apps.walletnfcrel/com.google.commerce.tapandpay.android.acceptedhere .places.PlacefencingReceiver

[02-14 15:33:40.562 1915:1915 W/XSharedPreferen]
type=1400 audit(0.0:5065): avc: denied { open } for path="/data/data/com.sudocode.sudohide/shared_prefs/com.sudocode.sudohide_preferences.xml" dev="dm-0" ino=2992118 scontext=u:r:system_server:s0 tcontext=ubject_r:app_data_file:s0:c512,c768 tclass=file permissive=0

[02-14 15:33:40.722 1915:1915 I/chatty]
uid=1000 system_server identical 10 lines

[02-14 15:33:40.722 1915:1915 W/XSharedPreferen]
type=1400 audit(0.0:5076): avc: denied { open } for path="/data/data/com.sudocode.sudohide/shared_prefs/com.sudocode.sudohide_preferences.xml" dev="dm-0" ino=2992118 scontext=u:r:system_server:s0 tcontext=ubject_r:app_data_file:s0:c512,c768 tclass=file permissive=0

[02-14 15:33:40.741 3525:3537 I/zygote64]
Background concurrent copying GC freed 267580(14MB) AllocSpace objects, 18(412KB) LOS objects, 50% free, 16MB/32MB, paused 381us total 155.505ms

[02-14 15:33:41.164 971:971 W//system/bin/tombstoned]
crash socket received short read of length 0 (expected 12)

[02-14 15:33:41.168 1915:2021 I/BootReceiver]
Copying /data/tombstones/tombstone_20 to DropBox (SYSTEM_TOMBSTONE)

[02-14 15:33:41.347 627:3107 E/SurfaceFlinger]
Failed to find layer (SurfaceView - com.google.android.youtube/com.google.android.apps.youtube.app.WatchWhileActi vity#0) in layer parent (no-parent).

[02-14 15:33:41.347 627:3107 E/SurfaceFlinger]
Failed to find layer (Background for - SurfaceView - com.google.android.youtube/com.google.android.apps.youtube.app.WatchWhileActi vity#0) in layer parent (no-parent).

[02-14 15:33:41.347 1915:9856 D/MediaSessionService]
Media button session is changed to null

[02-14 15:33:41.348 1915:4116 D/ConnectivityService]
ConnectivityService NetworkRequestInfo binderDied(NetworkRequest [ LISTEN id=52, [ Capabilities: INTERNET&NOT_RESTRICTED&TRUSTED&FOREGROUND] ], [email protected])

[02-14 15:33:41.348 1915:2014 I/MediaFocusControl]
AudioFocus removeFocusStackEntryOnDeath(): removing entry for [email protected]

[02-14 15:33:41.349 1915:2019 W/zygote64]
kill(-15102, 9) failed: No such process

[02-14 15:33:41.350 1915:19513 I/ActivityManager]
Process com.google.android.youtube (pid 15102) has died: fore TOP

[02-14 15:33:41.350 1915:2805 I/WindowManager]
WIN DEATH: Window{705ea9 u0 com.google.android.youtube/com.google.android.apps.youtube.app.WatchWhileActi vity}
Attached Files
File Type: rar logcat_02-14-2020_15-33-50.rar - [Click for QR Code] (194.4 KB, 10 views)
14th February 2020, 04:00 PM |#14044  
Eleo's Avatar
Senior Member
Flag Jena
Thanks Meter: 13,749
 
Donate to Me
More
Quote:
Originally Posted by XtraWater

@Eleo

I installed latest Youtube vanced root version. The issue, after a while, the app crashes / stops. It freezes for a second and then it shuts down itself.

What I use: Xiaomi Mi A1
Android 8.1 (Resurrection Remix)
root method: Magisk (19.3)
OpenGapps. (I just updated OpenGapps in hope it would resolve the issue. But no success)

I attach the logcat logfile. May be someone can have a look what might cause the issue. I stopped to recording log about 3 seconds after Vanced has stopped.

Thanks guys.

1. I still see xposed in your logs. Please read again my post
2. Please describe the method you installed vanced.

Sent from my Google Pixel 3a XL using XDA Labs
14th February 2020, 04:15 PM |#14045  
Senior Member
Thanks Meter: 41
 
More
Quote:
Originally Posted by Eleo

1. I still see xposed in your logs. Please read again my post
2. Please describe the method you installed vanced.

Sent from my Google Pixel 3a XL using XDA Labs

Ok, Xposed Framework is now disabled.

I used SAI (Splitt APKs Installer) to install Youtube vanced. The setting 'Sign APKs' was by default disabled and still is.
After Youtube Vanced was installed, I removed the Youtube Vanced Black theme module from magisk.

I attach the new log file with Xposed framework disabled.
Attached Files
File Type: rar logcat_02-14-2020_16-12-21.rar - [Click for QR Code] (76.2 KB, 0 views)
14th February 2020, 04:42 PM |#14046  
Eleo's Avatar
Senior Member
Flag Jena
Thanks Meter: 13,749
 
Donate to Me
More
Quote:
Originally Posted by XtraWater

Ok, Xposed Framework is now disabled.

I used SAI (Splitt APKs Installer) to install Youtube vanced. The setting 'Sign APKs' was by default disabled and still is.
After Youtube Vanced was installed, I removed the Youtube Vanced Black theme module from magisk.

I attach the new log file with Xposed framework disabled.

You are confusing. You said you installed root vanced. Now you say you used sai (which is for nonroot). Please report your steps. I advise following this post:
https://forum.xda-developers.com/and...7/post81736561

Once you are done, report back

Sent from my Google Pixel 3a XL using XDA Labs
14th February 2020, 05:00 PM |#14047  
Senior Member
Thanks Meter: 41
 
More
Quote:
Originally Posted by Eleo

You are confusing. You said you installed root vanced. Now you say you used sai (which is for nonroot). Please report your steps. I advise following this post:
https://forum.xda-developers.com/and...7/post81736561

Once you are done, report back

Sent from my Google Pixel 3a XL using XDA Labs

Actually I followed this instruction for root, from the official Youtube vanced site apart from step 1.

However, now I'll read your linked post.
Attached Thumbnails
Click image for larger version

Name:	vanced_root.png
Views:	656
Size:	148.2 KB
ID:	4950415  
14th February 2020, 05:08 PM |#14048  
Junior Member
Thanks Meter: 5
 
More
Quote:
Originally Posted by Eleo

You are confusing. You said you installed root vanced. Now you say you used sai (which is for nonroot). Please report your steps. I advise following this post:
https://forum.xda-developers.com/and...7/post81736561

Once you are done, report back

I would advise u not to give conflicting instructions. YouTube Vanced website already included the proper instructions for root and non root. SAI is used for both scenarios.

There is nothing wrong with using Xposed enabled and/or with SAI.

I know it's working with these 2 cause I used the same instructions from the website to update yesterday.
The Following User Says Thank You to cutezi For This Useful Post: [ View ] Gift cutezi Ad-Free
14th February 2020, 06:34 PM |#14049  
Senior Member
Thanks Meter: 41
 
More
@cutezi @Eleo

I repeated all the steps from the official instructions. Before I uninstalled Youtube Vanced with Titanium Backup. The issue is still persistent. If yo guys haven't other suggestions, I'll go back to the previous version with the magisk module.

However, thank you or your help.[COLOR="Silver"]
14th February 2020, 06:44 PM |#14050  
Junior Member
Thanks Meter: 5
 
More
Quote:
Originally Posted by XtraWater

@[email protected]

I repeated all the steps from the official instructions. Before I uninstalled Youtube Vanced with Titanium Backup. The issue is still persistent. If yo guys haven't other suggestions, I'll go back to the previous version with the magisk module.

However, thank you or your help.[COLOR="Silver"]

---------- Post added at 06:34 PM ---------- Previous post was at 06:33 PM ----------

[/COLOR @[email protected]

I repeated all the steps from the official instructions. Before I uninstalled Youtube Vanced with Titanium Backup. The issue is still persistent. If yo guys haven't other suggestions, I'll go back to the previous version with the magisk module.

However, thank you or your help.

I was also using rooted version all along.

All I did to upgrade to this new version via SAI is to use the YouTube vanced uninstaller script in TWRP to uninstall it cleanly. After that I just follow the official instructions on the site.

The uninstaller script can be found in the Reddit wiki for Vanced. Edit the script to uninstall instead of install is what I did.

Generally it's better to move on and follow the installation methods by the devs since Magisk version won't be updated due to Magisk change. The new method is a bit more involved but not that complicated if you really break it down
14th February 2020, 06:59 PM |#14051  
Senior Member
Thanks Meter: 41
 
More
Quote:
Originally Posted by cutezi

I was also using rooted version all along.

All I did to upgrade to this new version via SAI is to use the YouTube vanced uninstaller script in TWRP to uninstall it cleanly. After that I just follow the official instructions on the site.

The uninstaller script can be found in the Reddit wiki for Vanced. Edit the script to uninstall instead of install is what I did.

Generally it's better to move on and follow the installation methods by the devs since Magisk version won't be updated due to Magisk change. The new method is a bit more involved but not that complicated if you really break it down

Thank you. I'll check that script to uninstall it. Not sure if I missed the point, but the first time I tried to update I didn't use Smalipatcher. II just saw this step today and started from new.

Now I downgraded to the previous version. The app is rock solid again.
The Following User Says Thank You to XtraWater For This Useful Post: [ View ] Gift XtraWater Ad-Free
Post Reply Subscribe to Thread

Tags
adfree, mod, noad, youtube

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes