FORUMS

[OFFICIAL XDA][BETA][MAR 19]XDA Labs: Forum App + App Installer + Xposed Repo

3,306 posts
Thanks Meter: 11,538
 
By blk_jack, XDA Labs & Feed Dev/RD on 5th November 2015, 08:30 PM
Post Reply Email Thread
Announcement from blk_jack: Join us on IRC in #xda-labs on Freenode!
28th July 2020, 03:11 PM |#12371  
Nebrassy's Avatar
Senior Member
Flag Lattakia
Thanks Meter: 1,086
 
Donate to Me
More
I've had to relogin at least 5 times during the last day ,sometimes it said wrong password, maintenance I presume?
28th July 2020, 05:52 PM |#12372  
IronTechmonkey's Avatar
Recognized Contributor
Thanks Meter: 9,280
 
More
Quote:
Originally Posted by Nebrassy

I've had to relogin at least 5 times during the last day ,sometimes it said wrong password, maintenance I presume?

Ya, seems even worse than the recent usual which has not been good, download issues, log-in issues affecting LAbs in app or web browsers. Also just now, the return of my most reliable indicator (as an end user) of serous site issues. A rare request for captcha (long story, previously explained) which has never not been associated with these sorts of issues. With any luck and to your point, I hope it's maintenance and this is the bounce back.
The Following User Says Thank You to IronTechmonkey For This Useful Post: [ View ] Gift IronTechmonkey Ad-Free
3rd August 2020, 12:14 PM |#12374  
Senior Member
Thanks Meter: 12
 
More
Can't seem to be able to log in via the app, keeps saying invalid username or password.
3rd August 2020, 12:21 PM |#12375  
Eleo's Avatar
Senior Member
Flag Jena
Thanks Meter: 14,589
 
Donate to Me
More
Quote:
Originally Posted by polygon21

Can't seem to be able to log in via the app, keeps saying invalid username or password.

Try to provide more info like your device, Android version, whether you have changed your username lately, were you able to log in previously and etc. It definitely isn't a widespread issue as I logged out and logged in with no issue
3rd August 2020, 01:17 PM |#12376  
Bonoboo's Avatar
Senior Member
Thanks Meter: 3,935
 
More
Please can someone finally address issue with impossible login ("wrong" password) numerous times mentioned in thread? It took almost 2 months.
Previously was suggested to disable any adblockers - this not helps.

But once I enable VPN (Germany, Netherlands for example) - apps can login immediately.
After disabling VPN - instant sign out, news feed can't be updated.

I'm from Ukrаinе. Opening XDA in browser constantly shows that "Checking your browser before accessing..." page by CloudFlare: my country in some blacklist.
So considering all above it's definitively caused by (recently introduced?) CloudFlare protection "redirect", app just can't handle that.

Debug info (useless in this case): latest XDA Labs 1.1.6b, XDA 1.1.6b-play, Android 9
3rd August 2020, 01:26 PM |#12377  
Muxeu's Avatar
Senior Member
Flag Kharkiv
Thanks Meter: 196
 
More
Quote:
Originally Posted by Bonoboo

Please can someone finally address issue with impossible login ("wrong" password) numerous times mentioned in thread? It took almost 2 months.
Previously was suggested to disable any adblockers - this not helps.

But once I enable VPN (Germany, Netherlands for example) - apps can login immediately.
After disabling VPN - instant sign out, news feed can't be updated.

I'm from Ukrаinе. Opening XDA in browser constantly shows that "Checking your browser before accessing..." page by CloudFlare.
So considering all above it's definitively caused by (recently introduced?) CloudFlare protection "redirect", app just can't handle that.

Debug info (useless in this case): XDA Labs 1.1.6b, XDA 1.1.6b-play, Android 9

Same issue on Android 10
3rd August 2020, 01:46 PM |#12378  
woodman's Avatar
Senior Moderator / Moderator Committee Lead / RC-RT Committee / XDA Labs Contributor
Thanks Meter: 23,866
 
More
Quote:
Originally Posted by Bonoboo

Please can someone finally address issue with impossible login ("wrong" password) numerous times mentioned in thread? It took almost 2 months.
Previously was suggested to disable any adblockers - this not helps.

But once I enable VPN (Germany, Netherlands for example) - apps can login immediately.
After disabling VPN - instant sign out, news feed can't be updated.

I'm from Ukrаinе. Opening XDA in browser constantly shows that "Checking your browser before accessing..." page by CloudFlare: my country in some blacklist.
So considering all above it's definitively caused by (recently introduced?) CloudFlare protection "redirect", app just can't handle that.

Debug info (useless in this case): latest XDA Labs 1.1.6b, XDA 1.1.6b-play, Android 9

I just tried to contact the people concerned/responsible. Hope they will help.
Sorry it the best I can do, after several previous attempts to assist you guys in this thread.
The Following 9 Users Say Thank You to woodman For This Useful Post: [ View ] Gift woodman Ad-Free
3rd August 2020, 02:05 PM |#12379  
Eleo's Avatar
Senior Member
Flag Jena
Thanks Meter: 14,589
 
Donate to Me
More
Quote:
Originally Posted by Muxeu

Same issue on Android 10

Quote:
Originally Posted by Bonoboo

But once I enable VPN (Germany, Netherlands for example) - apps can login immediately.
After disabling VPN - instant sign out, news feed can't be updated.

I'm from Ukrаinе...

Did you try other countries? E.g. choosing Ukraine on VPN as well? It could be a culprit in your internet provider. I know some devs in Ukraine that log in through XDA Labs app as well, so that could have less to do with country rather than your internet provider.

I just tried to switch to Ukraine using my NordVPN (no, it is not advertisement), logged out of XDA Labs and logged back in with no issue.

As I said, we will need to see logs and ask you to try with another internet provider.

I am on android11 beta 3 on pixel 3a xl. But same is on android 10 (xiaomi mi a1) and 9 (samsung galaxy note 3) devices of mine.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20200803-145936.png
Views:	308
Size:	210.6 KB
ID:	5073109   Click image for larger version

Name:	Screenshot_20200803-150001.png
Views:	310
Size:	88.0 KB
ID:	5073111   Click image for larger version

Name:	Screenshot_20200803-150017.jpg
Views:	316
Size:	91.7 KB
ID:	5073113  
The Following 3 Users Say Thank You to Eleo For This Useful Post: [ View ] Gift Eleo Ad-Free
3rd August 2020, 02:47 PM |#12380  
Muxeu's Avatar
Senior Member
Flag Kharkiv
Thanks Meter: 196
 
More
@Eleo: I have tried at least 3 providers - at home, at work and on the mobile network
3rd August 2020, 03:01 PM |#12381  
Bonoboo's Avatar
Senior Member
Thanks Meter: 3,935
 
More
Quote:
Originally Posted by woodman

I just tried to contact the people concerned/responsible. Hope they will help.

Quote:
Originally Posted by Eleo

We will need to see logs and ask you to try with another internet provider.

Thanks for attention to this problem.
Beside home provider also tried 2 mobile (they all not related to each other): still unable to login.
But via some local VPN it works.

Error in logcat when pressing "Submit" in login form.
App just receives HTML page with 503 response instead JSON data.
So CloudFlare blacklist some providers.
Code:
I System.out: Authorization server expects Basic authentication
I System.out: Retry with login credentials
I System.out: Retry with client credentials
I System.out: code [503]
W System.err: org.json.JSONException: Value <!DOCTYPE of type java.lang.String cannot be converted to JSONObject
W System.err: 	at org.json.JSON.typeMismatch(JSON.java:112)
W System.err: 	at org.json.JSONObject.<init>(JSONObject.java:163)
W System.err: 	at org.json.JSONObject.<init>(JSONObject.java:176)
W System.err: 	at org.sdf.danielsz.OAuthUtils.b(Unknown Source:22)
W System.err: 	at org.sdf.danielsz.OAuthUtils.a(Unknown Source:326)
W System.err: 	at org.sdf.danielsz.OAuthUtils.a(Unknown Source:1)
W System.err: 	at org.sdf.danielsz.OAuth2Client.a(Unknown Source:23)
W System.err: 	at org.sdf.danielsz.OAuth2Client.f(Unknown Source:3)
W System.err: 	at com.xda.labs.OAuth2Helper.createToken(Unknown Source:17)
W System.err: 	at com.xda.labs.OAuth2Helper.createToken(Unknown Source:1)
W System.err: 	at com.xda.labs.OAuth2Helper.createToken(Unknown Source:1)
W System.err: 	at com.xda.labs.OAuthHandler.grabAccessToken(Unknown Source:28)
W System.err: 	at com.xda.labs.OAuthHandler.access$000(Unknown Source:0)
W System.err: 	at com.xda.labs.OAuthHandler$2.run(Unknown Source:6)
W System.err: 	at java.lang.Thread.run(Thread.java:764)
The Following 4 Users Say Thank You to Bonoboo For This Useful Post: [ View ] Gift Bonoboo Ad-Free
Post Reply Subscribe to Thread

Tags
xda app

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes