FORUMS

[OFFICIAL XDA][BETA][MAR 19]XDA Labs: Forum App + App Installer + Xposed Repo

3,306 posts
Thanks Meter: 11,545
 
By blk_jack, XDA Labs & Feed Dev/RD on 5th November 2015, 08:30 PM
Post Reply Email Thread
Announcement from blk_jack: Join us on IRC in #xda-labs on Freenode!
11th August 2020, 01:02 PM |#12401  
Account currently disabled
Flag Jena
Thanks Meter: 14,700
 
Donate to Me
More
I know that it was reported before, but I haven't seen users posting logs about it:
https://forum.xda-developers.com/and...6/post78422663
https://forum.xda-developers.com/and...6/post78425524
https://forum.xda-developers.com/and...6/post78426272
https://forum.xda-developers.com/and...6/post80813137

This report is for @blk_jack as asked by @woodman before

Whenever I try submitting a post (even with no attachment and simple latin characters (this example was done with a post consisting of 5 (minimum for a post is 3 characters afaik) latin characters (H e l l o)) into Camera PX gcam thread I get "post creating failed". My main device is unrooted Pixel 3a XL with android 11 beta 3. For investigation, I retrieved my rooted mi a1 device and logged the event using matlog app in case it can be useful.

I am using a rooted (magisk20.1) xiaomi mi a1 with custom android 9 rom (evo x) using XDA Labs 1.1.6b debug version of apk ("debug build" from this post), with logs retrieved using Matlog 1.2.3 apk (downloaded from apkmirror since I couldn't find it on playstore).

Phone was cleaved from useless 3rd party apps and extra standby apps to get cleaner logs. To cut the time of logging (and created lines) short, the post ("Hello") was pre-composed before starting logging and after logging was started, following steps were done:
- switch to XDA Labs app
- click on "submit post" icon
- receive "post creation failed" toast
- switch back to matlog app
- stop logging

Code:
08-11 13:44:01.549 D/SurfaceFlinger(1621): duplicate layer name: changing com.xda.labs/com.xda.labs.one.ui.MainActivity to com.xda.labs/com.xda.labs.one.ui.MainActivity#2
08-11 13:44:01.559 I/GoogleInputMethodService(2302): GoogleInputMethodService.onFinishInput():3162 
08-11 13:44:01.560 I/GoogleInputMethodService(2302): GoogleInputMethodService.onStartInput():1831 
08-11 13:44:02.078 D/NavDrawerPresenter$UpdatesAvailableRunnable(12064): closedrawer firstTimeDrawerFinished [true] appsCount [2] xposedCount [0] lastBuildId [-1] unreadForumNotices [0]
08-11 13:44:02.079 D/NavDrawerPresenter$UpdatesAvailableRunnable(12064): closedrawer firstTimeDrawerFinished [true] appsCount [2] xposedCount [0] lastBuildId [-1] unreadForumNotices [0]
08-11 13:44:02.666 D/RetrofitClient(12064): intercept	Request is not successful - 0
08-11 13:44:04.204 W/System  (12064): A resource failed to call response.body().close(). 
08-11 13:44:04.214 W/System.err(12064): retrofit.RetrofitError: 400 Bad Request
08-11 13:44:04.214 W/System.err(12064): 	at retrofit.RestAdapter$RestHandler.invokeRequest(RestAdapter.java:388)
08-11 13:44:04.214 W/System.err(12064): 	at retrofit.RestAdapter$RestHandler.access$100(RestAdapter.java:220)
08-11 13:44:04.215 W/System.err(12064): 	at retrofit.RestAdapter$RestHandler$2.obtainResponse(RestAdapter.java:278)
08-11 13:44:04.215 W/System.err(12064): 	at retrofit.CallbackRunnable.run(CallbackRunnable.java:42)
08-11 13:44:04.215 W/System.err(12064): 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1167)
08-11 13:44:04.215 W/System.err(12064): 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:641)
08-11 13:44:04.215 W/System.err(12064): 	at retrofit.Platform$Android$2$1.run(Platform.java:142)
08-11 13:44:04.216 W/System.err(12064): 	at java.lang.Thread.run(Thread.java:764)
08-11 13:44:04.220 E/Utils   (12064): XDA-ONE	{"error":{"code":400,"message":"Bad Request"}}
08-11 13:44:04.247 V/ANDR-PERF-MPCTL(495): Invalid profile no. 0, total profiles 0 only
08-11 13:44:04.255 I/GoogleInputMethodService(2302): GoogleInputMethodService.onFinishInput():3162 
08-11 13:44:04.255 I/GoogleInputMethodService(2302): GoogleInputMethodService.onStartInput():1831 
08-11 13:44:04.369 W/SurfaceFlinger(1621): Attempting to set client state on removed layer: Dim Layer for - Task=132#0
08-11 13:44:04.369 W/SurfaceFlinger(1621): Attempting to set client state on removed layer: com.xda.labs/com.xda.labs.one.ui.MainActivity#2
08-11 13:44:04.369 W/SurfaceFlinger(1621): Attempting to destroy on removed layer: Dim Layer for - Task=132#0
08-11 13:44:04.369 W/SurfaceFlinger(1621): Attempting to destroy on removed layer: com.xda.labs/com.xda.labs.one.ui.MainActivity#2
After this line, it was following with my username, quote#, message#, id#, email and etc (it was a "I" type log and contained confidential info) so I removed it. This was the last log line useful for troubleshooting.

I hope it is useful.

Cheers

P.S. I have 2 apps to be updated from XDA Labs on this phone as you can see from logs (appsCount [2]) because I haven't used it for a while


P.P.S. This issue was present since quite a long time ago, but whenever I wanted to report, I didn't have access to a rooted device, so that is the reason why this is so much late response.
The Following 2 Users Say Thank You to Eleo For This Useful Post: [ View ] Gift Eleo Ad-Free
19th August 2020, 09:51 PM |#12402  
Junior Member
Thanks Meter: 1
 
More
what is the minimum android version and services needed?
I can't login via Google (green screen with a white circle starting to form but never finish and gets stuck on rooted one plus x 5.1.1)

thanks!
The Following User Says Thank You to manu.com For This Useful Post: [ View ] Gift manu.com Ad-Free
20th August 2020, 03:41 AM |#12403  
Senior Member
Flag Bay city
Thanks Meter: 31
 
More
Quote:
Originally Posted by manu.com

what is the minimum android version and services needed?
I can't login via Google (green screen with a white circle starting to form but never finish and gets stuck on rooted one plus x 5.1.1)

thanks!

I know I was on rooted Kindle fire 5.1 when it quit letting me sign in. Rerooted and now 7.12 nougat and I'm able to sign in again. Not sure about Android 6
The Following 2 Users Say Thank You to barcia99 For This Useful Post: [ View ] Gift barcia99 Ad-Free
20th August 2020, 05:58 AM |#12404  
Account currently disabled
Flag Jena
Thanks Meter: 14,700
 
Donate to Me
More
Quote:
Originally Posted by manu.com

what is the minimum android version and services needed?
I can't login via Google (green screen with a white circle starting to form but never finish and gets stuck on rooted one plus x 5.1.1)

thanks!

Oneplus X can be officially updated to android 6.0.1 (let alone custom ROMs that can go even higher).
The Following User Says Thank You to Eleo For This Useful Post: [ View ] Gift Eleo Ad-Free
27th August 2020, 08:35 AM |#12405  
Senior Member
Thanks Meter: 13
 
More
Quote:
Originally Posted by Eleo

Lately it was revealed that older Android versions like android 5 (maybe android 6 as well) are unable to login through XDA Labs. I am guessing this is same

yup.. i think my vehicle android headunit is on android 6, no joy logging in the xda labs app for awhile now..
The Following User Says Thank You to polygon21 For This Useful Post: [ View ] Gift polygon21 Ad-Free
27th August 2020, 09:08 PM |#12406  
Senior Moderator / RC-RT Committee
Thanks Meter: 59,858
 
1010101010
Donate to Me
More
Quote:
Originally Posted by Eleo

Oneplus X can be officially updated to android 6.0.1 (let alone custom ROMs that can go even higher).








Quote:
Originally Posted by polygon21

yup.. i think my vehicle android headunit is on android 6, no joy logging in the xda labs app for awhile now..

The Following 4 Users Say Thank You to T.C.Stockdale For This Useful Post: [ View ] Gift T.C.Stockdale Ad-Free
28th August 2020, 04:38 AM |#12407  
coal686's Avatar
Senior Moderator / Moderator Committee / Developer Relations - lim( trolls + Hammer, trolls,∞) = 0
Flag Tampa-ish, FL
Thanks Meter: 21,717
 
More
Quote:
Originally Posted by polygon21

yup.. i think my vehicle android headunit is on android 6, no joy logging in the xda labs app for awhile now..

"Umm, ma'am, you looked pretty distracted. What were you doing?"
"Sorry officer, just helping some noobs flash ROMs on XDA."

The Following 19 Users Say Thank You to coal686 For This Useful Post: [ View ] Gift coal686 Ad-Free
5th September 2020, 06:42 AM |#12408  
Junior Member
Thanks Meter: 0
 
More
Hi, I need help to install bliss Rom because I can't, someone could help me, please, Thanks
xiaomi Redmi 8a de 2gb ram y 32 internal memory
5th September 2020, 07:10 AM |#12409  
Senior Member
Flag Slightly South of London
Thanks Meter: 462
 
More
Quote:
Originally Posted by Customyyy

Hi, I need help to install bliss Rom because I can't, someone could help me, please, Thanks
xiaomi Redmi 8a de 2gb ram y 32 internal memory

Search XDA for your fone's Q&A forum and ask there.

Sent from my SM-T720 using XDA Labs
9th September 2020, 08:44 PM |#12410  
bigsupersquid's Avatar
Senior Member
Flag BFE, MO
Thanks Meter: 1,692
 
Donate to Me
More
I wanted to mention a minor issue with the labs app.
at some point the htc evo 3d forums were all combined into the lowest level forum. the general, q&a, cdma/gsm development forums (and any others I forgot to mention) have all vanished and their threads are now all in the base htc evo 3d forum only organized by date of last post.
the issue with the app is that all the now-nonexistent subforums are still listed in the app, and they're all dead links that either don't work at all or lead to other forums unrelated to the evo 3d.
if that could be cleaned up, it'd look better, and also stop reminding me that all the previous organization that made it easier to search things for that device is gone.
running the labs 1.1.6b.
reproduce the issue by searching for htc evo 3d and look at the crazy number of results that don't lead anywhere relevant anymore. the only forum link that works from those search results is the top result.
The Following User Says Thank You to bigsupersquid For This Useful Post: [ View ] Gift bigsupersquid Ad-Free
Post Reply Subscribe to Thread

Tags
xda app

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes