FORUMS
Remove All Ads from XDA

[guide] Blu Vivo XL4 | | Vivo Xi || Vivo Xi+

2,813 posts
Thanks Meter: 1,115
 
By mrmazak, Senior Member on 9th December 2018, 09:52 PM
Post Reply Email Thread
27th March 2019, 10:53 PM |#41  
mrmazak's Avatar
OP Senior Member
Thanks Meter: 1,115
 
More
Quote:
Originally Posted by Fleated

Will this same method work on the Android 9 beta? I've already unlocked the bootloader.

??

You mean to read back the pie rom?

Should work, yes.
 
 
14th May 2019, 06:25 AM |#42  
Junior Member
Thanks Meter: 4
 
More
Does anyone have a copy of the apn-config.xml for the xI plus on 8.1? I want to compare to the pie one. From what I see there is absolutely nothing about vzw in it. I've got lte but no call or text.
16th May 2019, 12:00 AM |#43  
mrmazak's Avatar
OP Senior Member
Thanks Meter: 1,115
 
More
Quote:
Originally Posted by JimmyJurner

Does anyone have a copy of the apn-config.xml for the xI plus on 8.1? I want to compare to the pie one. From what I see there is absolutely nothing about vzw in it. I've got lte but no call or text.

here is the one from vivo-XL4

should be the same
Attached Files
File Type: xml apns-conf.xml - [Click for QR Code] (496.3 KB, 6 views)
The Following User Says Thank You to mrmazak For This Useful Post: [ View ] Gift mrmazak Ad-Free
18th May 2019, 04:31 PM |#44  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by mrmazak

******EDIT*****
Most of the following problems did not repeat in same way when I tried to repeat the install process.
Main issue was with simcard. But exact process to get installed and working is still not known.

-- install after already having rooted, encryption removed stock, seems to work.

-- fresh full stock rom, full encryption, then gsi seems to not work sim card.









PHH-treble gsi images do boot this device. I do not have a bug list as yet.

  • working:WITH encryption removed:

    1. wifi
    2. camera
    3. fingerprint- unlock
    4. music
    5. video
  • NOT working :WITH encyyption removed:

    1. cell signal
    2. cell data
    3. phone
    4. sms
---------------------------------------------------------------------------------------------------
---------------------------------------------------------------------------------------------------
  • working:WITH encryption enabled

    1. phone
    2. sms
  • NOT working:WITH encryption enabled

    1.. everything else

EDIT

Much of the force closing problems were from a corrupted external sdcard. When I removed the card , the force close messages did not come.

Getting 4G data connection was not stable. after a full reset and rom re-install I was not able to get data connection, and only able to have connection to make calls when set to 3G connection only.

some bugs in vendor I assume will need some help solving this.


EDIT 2

Finally got around to trying again. his time I started with vanilla version of phh-treble gsi.

4G data and sms, calls in out all work. Camera , video both work.
WiFi tethering did not work.

Setup that worked :
force encryption removed with universal dm-verity patcher, ( bothboot.img and vendor partitions both edited).
magisk patched boot






hi ,

so this is my first time asking for spacific help here on xda ...
i just cant seem to flash a working gsi meaning sim network sms data calls anything wigh my vivo xl4
ive been at it since day 1 when you first posted the first working twrp on androidfilehost... i get that the boot image has to be patched with dm and so does the vendor img .... our twrp dosent have decrypt so i have to format data everytime right ?

i really have tried to follow all of your guides and read and read and read before i ever thought about posting this bc i feel like i can do it myself lol but im getting really frustrated bc either i boot to fastboot or i get stuck at logo or no boot at all or i do get it to boot and i dont have cell or sms or data its like the onlything working is stock.... am i missing something ???

Please help mrmazak if your not too busy
i know you are bc i see all the work you do on gethub and things you upload
they all have helped my greatly and i along with EVERYONE here appreciate you and the work you do

sorry long winded just a fanboy writing for the first time

ok well please if you can some help would be greatly appreciated
18th May 2019, 04:53 PM |#45  
mrmazak's Avatar
OP Senior Member
Thanks Meter: 1,115
 
More
Quote:
Originally Posted by jwesterheide

hi ,

so this is my first time asking for spacific help here on xda ...
i just cant seem to flash a working gsi meaning sim network sms data calls anything wigh my vivo xl4
ive been at it since day 1 when you first posted the first working twrp on androidfilehost... i get that the boot image has to be patched with dm and so does the vendor img .... our twrp dosent have decrypt so i have to format data everytime right ?

i really have tried to follow all of your guides and read and read and read before i ever thought about posting this bc i feel like i can do it myself lol but im getting really frustrated bc either i boot to fastboot or i get stuck at logo or no boot at all or i do get it to boot and i dont have cell or sms or data its like the onlything working is stock.... am i missing something ???

Please help mrmazak if your not too busy
i know you are bc i see all the work you do on gethub and things you upload
they all have helped my greatly and i along with EVERYONE here appreciate you and the work you do

sorry long winded just a fanboy writing for the first time

ok well please if you can some help would be greatly appreciated

Thank you for the kind words. Believe me I am at best still on the bottom rung of the development ladder
, But I do try to help where I can.

As far as getting full function on gsi, I did give up. O never tried above phh v110. So maybe the newer releases made it better. But they all have wifi-tether not working, so that was a no go for me , as I need that to work.

I did get similar results when flashing gsi , both with dm-verity patched and not patched.

Also same for force encryption enabled and disabled ( disabled as in modifying the fstab file in /vendor/etc)

I never updated the first post with the updated guide, because I never got one to work 100%
18th May 2019, 05:50 PM |#46  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by mrmazak

Thank you for the kind words. Believe me I am at best still on the bottom rung of the development ladder
, But I do try to help where I can.

As far as getting full function on gsi, I did give up. O never tried above phh v110. So maybe the newer releases made it better. But they all have wifi-tether not working, so that was a no go for me , as I need that to work.

I did get similar results when flashing gsi , both with dm-verity patched and not patched.

Also same for force encryption enabled and disabled ( disabled as in modifying the fstab file in /vendor/etc)

I never updated the first post with the updated guide, because I never got one to work 100%



you did say this in the post though.....

.................................................. .................................................. .................................................. .................................................. .................................................. .........
EDIT 2

Finally got around to trying again. his time I started with vanilla version of phh-treble gsi.

4G data and sms, calls in out all work. Camera , video both work.
WiFi tethering did not work.

Setup that worked :
force encryption removed with universal dm-verity patcher, ( bothboot.img and vendor partitions both edited).
magisk patched boot

.................................................. .................................................. .................................................. .......................

i cant duplicate that to save my life....
i just want to be able to theme thats my only reason for trying a gsi in the first place
i cant stand the BLU overlays they add ... i like stock magisk rooted 8.1 generic that you posted and id stick with it if i could somehow theme the notification shade or remove the stock overlay or something

ive rooted and xposed and tweaked with substratum and swift installer and all those , but i cant seem to get anything to touch the settings.apk like turning them black or changing anthing about them . swift installer can change the notifications black and turning on battery saver with a dark wallpaper can get the notification shade dark but is there ANY WAY to either delete the stock system overlay of settings or something that i can do to help me theme this thing lol

ive tried magisk modules
xposed
substratum

but nothing really does it for me

any advice?????
18th May 2019, 07:38 PM |#47  
mrmazak's Avatar
OP Senior Member
Thanks Meter: 1,115
 
More
Quote:
Originally Posted by jwesterheide

you did say this in the post though.....

.................................................. .................................................. .................................................. .................................................. .................................................. .........
EDIT 2

Finally got around to trying again. his time I started with vanilla version of phh-treble gsi.

4G data and sms, calls in out all work. Camera , video both work.
WiFi tethering did not work.

Setup that worked :
force encryption removed with universal dm-verity patcher, ( bothboot.img and vendor partitions both edited).
magisk patched boot

.................................................. .................................................. .................................................. .......................

i cant duplicate that to save my life....
i just want to be able to theme thats my only reason for trying a gsi in the first place
i cant stand the BLU overlays they add ... i like stock magisk rooted 8.1 generic that you posted and id stick with it if i could somehow theme the notification shade or remove the stock overlay or something

ive rooted and xposed and tweaked with substratum and swift installer and all those , but i cant seem to get anything to touch the settings.apk like turning them black or changing anthing about them . swift installer can change the notifications black and turning on battery saver with a dark wallpaper can get the notification shade dark but is there ANY WAY to either delete the stock system overlay of settings or something that i can do to help me theme this thing lol

ive tried magisk modules
xposed
substratum

but nothing really does it for me

any advice?????

You go with the Oreo gsi instead of the pie gsi. Supposedly there are much less bugs in that. As far as mtk is concerned. I have not tried myself though.
20th May 2019, 06:04 AM |#48  
I know there is a lot of related issues between these phone but can we get a BLU Vivo Xi+ Just to keep stuff from getting jumbled up.
Post Reply Subscribe to Thread

Tags
blu-vivo-xl4, vivo-xi, xl4

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes