FORUMS

[Tutorial][Recovery] Flash TWRP on Moto C (namath) with locked bootloader

2,966 posts
Thanks Meter: 1,198
 
By Mysteryagr, Recognized Developer / Recognized Contributor on 10th November 2017, 08:08 PM
Post Reply Email Thread
25th September 2019, 04:18 PM |#91  
Junior Member
Thanks Meter: 0
 
More
Load preloader or DSP_BL
Quote:
Originally Posted by AndroidCUT

Keep getting the error "load pre-loader or DSP _BL" whenever I press "write memory, what should i do?

EDIT: Nevermind got it!

I'm getting same error when trying to root a Motorola C xt1750
Is preloader_wt98737.bin missing in download package?
13th February 2020, 09:14 PM |#92  
Junior Member
Thanks Meter: 0
 
More
Hello!
My Motorola Moto C phone won't boot into System OS. Whatever I do (turn it off, take out the battery, put back the battery again) it will only boot to TWRP.
What happened? Well I must have made one awful mistake: I tried to restore to factory (stock) from the System menu like every other ordinary non-rooted non-flashed phone.
And so I thought why not use TWRP to install a new OS so I tried LineageOS, followed the instructions and everything, but even after I'm done I still end up booting into TWRP!
Last I tried installing TWRP again, followed the instructions literally, but still can't boot into any OS.
I also tried several "dd if=/dev/zero something" commands or something like that to no avail.
Any help would appreciated.
Thanks in advance.
13th February 2020, 09:27 PM |#93  
Junior Member
Thanks Meter: 0
 
More
Fix
Quote:
Originally Posted by Pichu Pichu

Hello!
My Motorola Moto C phone won't boot into System OS. Whatever I do (turn it off, take out the battery, put back the battery again) it will only boot to TWRP.
What happened? Well I must have made one awful mistake: I tried to restore to factory (stock) from the System menu like every other ordinary non-rooted non-flashed phone.
And so I thought why not use TWRP to install a new OS so I tried LineageOS, followed the instructions and everything, but even after I'm done I still end up booting into TWRP!
Last I tried installing TWRP again, followed the instructions literally, but still can't boot into any OS.
I also tried several "dd if=/dev/zero something" commands or something like that to no avail.
Any help would appreciated.
Thanks in advance.

Hello Pichu Pichu,

I've had the same problem a few months ago. The fix for this issue is simply flashing the firmware. If you need any further help, feel free to contact me.
17th February 2020, 10:42 PM |#94  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Some_user

Hello Pichu Pichu,

I've had the same problem a few months ago. The fix for this issue is simply flashing the firmware. If you need any further help, feel free to contact me.

Hi, Some_user! Thank you for your prompt reply.
I tried flashing the stock firmware I got from androidfilehost and selecting the file DA_SWSEC_NAM.Moto-XT1754_XT1755_XT1756.bin I got from kurdishfirmware.
First I went to the Format tab and ticked the validation box and format whole flash except bootloader. Format Ok.
Then I wen to the Download tab and using Download Only I selected the Scatter-loading File included in the stock files. Everything but preloader selected. Download Ok.
When I tried to turn on my phone, it didn't. So I was like "hmmm maybe I should redo the steps again. I carelessly did the format thing again without ticking the validation box and leaving Format whole flash ticked!
Now whenever I wanna do any operation the following message pops up lS_AUTH_HANDLE_IS_NOT_REASY(5000) This is a secure Base-band Chip! Please select the authentication file first.
So apparently I screwed up.

Is there anything left to do other than resign myself to the loss of this phone?

SOLUTION
Apparently the Download-Agent didn't match the Authentication File.
What to do?
Well, I downloaded SP Flash Tool version 5.1628.00.
I opened the tool (as administrator) and in Download-Agent I selected MTK_AllInOne_DA_6737m_98736_71604.bin (the file was included in the tool foolder).
I pressed "CTRL + ALT + S" and Auth File button became visible.
I clicked it and selected auth_sv5_LenovoNamath.auth (which was included in the tool folder).
But, before I forgot, where's the Scatter-loading File?
Oh, yes. I chose MT6737M_Android_scatter.txt which is included in NAMATH_56_NRD90M.046_subsidy-UNLOCKED_CFC.zip that I got from androidfilehost.
I left all the boxes checked and also Download Only.
To my surprise, it worked!
After the Download Ok prompt, I disconnected the device from the PC, put the battery back on and turned it on.
To quote Back To The Future, IT'S ALIVE !

NEW PROBLEM
My IMEI is now 0000000000000.
I've been looking about, but so far none of the posted solutions here worked.
So if somebody else got around this issue, please let me know.
Thank you so much for reading this. I hope it's of use to anyone.
Cheers!
Post Reply Subscribe to Thread

Tags
moto, moto c, motorola-moto-c, namath, recovery, twrp, xt1754

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes