FORUMS
Remove All Ads from XDA

[Recovery][cv1] TWRP 3.2.3.0 For LM-X210 Devices

210 posts
Thanks Meter: 39
 
By NonStickAtom785, Senior Member on 23rd January 2019, 04:00 PM
Post Reply Email Thread
22nd March 2019, 07:21 PM |#11  
Junior Member
Thanks Meter: 0
 
More
Lmx210cm twrp
Do you happen to have anything for the lmx210cm?
28th March 2019, 06:16 AM |#12  
Account currently disabled
Thanks Meter: 4
 
More
Quote:
Originally Posted by Ausboz

Do you happen to have anything for the lmx210cm?

Just created a whole EDL firmware for the Aristo 2 aka Phoenix 4. PM me for the links if you'd like a copy. I also found our prog_emmc_firehose_8917_ddr.mbn to flash with (it works)

---------- Post added at 05:16 AM ---------- Previous post was at 05:13 AM ----------

Quote:
Originally Posted by tdawgg777

Hey man thanks for pointing out that this will work with the all cv1 devices... I have the Aristo 2 on Metro... Is it possible to flash twrp while on the official Oreo firmware or do I have to downgrade to Nougat?

Last time I was on xda it was stated that you couldn't flash in fastboot while on official Oreo...

I tested oreo and it works file
15th April 2019, 11:26 PM |#13  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by AustinGarrick1818

Just created a whole EDL firmware for the Aristo 2 aka Phoenix 4. PM me for the links if you'd like a copy. I also found our prog_emmc_firehose_8917_ddr.mbn to flash with (it works)

---------- Post added at 05:16 AM ---------- Previous post was at 05:13 AM ----------



I tested oreo and it works file

Hi would mind telling how to flash that firmware amd whats the prog_+++++++ddr.mbn to flash i have aristo 2 android 8.1 metro and i cant do any flash in fastboot or root it anything you know about it will be appreciated so much...
16th April 2019, 03:11 AM |#14  
Senior Member
Flag Mexico D.F.
Thanks Meter: 1,068
 
Donate to Me
More
@NonStickAtom785 Any solution to start fastboot mode, the phone? Whenever I try to start it from CMD the phone restarts normally, there is no way to get into fastboot mode.

I already probe manually, with combination of buttons, and it does not work either, the model is the LX210HM
16th April 2019, 04:31 PM |#15  
NonStickAtom785's Avatar
OP Senior Member
Flag Warrenton, Mo
Thanks Meter: 39
 
More
Quote:
Originally Posted by tazlooney89

@NonStickAtom785 Any solution to start fastboot mode, the phone? Whenever I try to start it from CMD the phone restarts normally, there is no way to get into fastboot mode.

I already probe manually, with combination of buttons, and it does not work either, the model is the LX210HM

Have you tried installing the Aristo 2 firmware on your phone? In theory these phones have the same build and processors. Also in theory, but proven to work on some other cv1 devices (LG Phoenix 4), you should be able to flash Aristo 2 firmware and unlock your phone that way. I would also check your system.img to see if anything such as a security patch is in place to keep your phone from rebooting to the bootloader. You can backup the system.img manually and send me the img and I will look for anything that different from the Aristo 2 system.img.

Also by backing up the system.img and sending it to me, I can retrieve any "extra" carrier settings and add them to the cv1 img. I'm working on a full stock cv1 firmware img that will work on all the cv1 devices as a root strategy.
2nd May 2019, 09:11 AM |#16  
Junior Member
Thanks Meter: 0
 
More
I have Lg K9 ( lmx210em ) and it's IMPOSSIBLE enter in fastboot mode, either with key combinations, either with adb command... The phone always boot in normalk mode !!!
Download mode and recowery mode work properly, but fastboot mode DID NOT !!!
16th June 2019, 07:37 PM |#17  
Junior Member
Thanks Meter: 0
 
More
urgent
i need the firmware the phoenix 4 please
25th June 2019, 08:24 AM |#18  
noidodroid's Avatar
Senior Member
Flag Innernetz
Thanks Meter: 42
 
More
Quote:
Originally Posted by NonStickAtom785

[B]Compatible Devices:
LG K8+
LG Aristo 2, 2+
LG K9
LG Phoenix 4


Thanks to @AustinGarrick1818 who discovered that this TWRP originally started and developed for the Aristo 2, by @messi2050 and @armandop_, then later updated to the latest version by @tecknight, was able to be flash on the Phoenix 4 leading to the idea that any cv1 device is cable of a ROOT method/TWRP Recovery.


..............
[/COLOR][/SIZE]

I'm assuming this will not work on the LG Aristo 2 Verizon PrePaid LM-X210VPP ? Or am i wrong? I have one here in inventory that just needs a new LCD and Digitizer ($20) and I was thinking about fixing it and modding it but worried about Verizon and the bootloader being locked. Have not found a lot of info on this device just yet so debating whether or not to keep / fix or get rid of it.

---------- Post added at 01:24 AM ---------- Previous post was at 01:22 AM ----------

Quote:
Originally Posted by AustinGarrick1818

Just created a whole EDL firmware for the Aristo 2 aka Phoenix 4. PM me for the links if you'd like a copy. I also found our prog_emmc_firehose_8917_ddr.mbn to flash with (it works)

---------- Post added at 05:16 AM ---------- Previous post was at 05:13 AM ----------



I tested oreo and it works file

Did anyone get this guys debrick package? And does it have the xml's already created? Either way I would like a copy. If someone can pm me a link to a download or email me it that would be awesome.
1st July 2019, 02:01 AM |#19  
Junior Member
Flag louisville ky
Thanks Meter: 0
 
More
i installed twrp and rooted the lmx210cm however now when i boot i shows a black bar at bottom of screen... top of image is cut off and touch screen is unresponsive.... works fine in twrp... what did i do wrong?
4th July 2019, 05:35 AM |#20  
tecknight's Avatar
Recognized Contributor
Flag Las Vegas
Thanks Meter: 737
 
More
Quote:
Originally Posted by jdthomas4181

i installed twrp and rooted the lmx210cm however now when i boot i shows a black bar at bottom of screen... top of image is cut off and touch screen is unresponsive.... works fine in twrp... what did i do wrong?

The issue you describe appears to be caused by kernel incompatibilities between certain partitions of the phone.
The fact that TWRP does not have the screen glitching issue implies that the kernel embedded in the TWRP image you flashed IS compatible, but perhaps the kernel within your boot image is NOT.
My first question would be:
You mention that you rooted your phone from fastboot.
Did you:
1. patch the stock boot image on your phone or
2. flash a pre-rooted boot image to your boot partition or
3. Flash a pre rooted ROM to your phone
If you answered #2 or #3, then my secondary question would be:
Specifically which boot image or ROM did you flash to your phone ?

---------- Post added at 08:35 PM ---------- Previous post was at 08:32 PM ----------

Quote:
Originally Posted by noidodroid

I'm assuming this will not work on the LG Aristo 2 Verizon PrePaid LM-X210VPP ? Or am i wrong? I have one here in inventory that just needs a new LCD and Digitizer ($20) and I was thinking about fixing it and modding it but worried about Verizon and the bootloader being locked. Have not found a lot of info on this device just yet so debating whether or not to keep / fix or get rid of it.

---------- Post added at 01:24 AM ---------- Previous post was at 01:22 AM ----------



Did anyone get this guys debrick package? And does it have the xml's already created? Either way I would like a copy. If someone can pm me a link to a download or email me it that would be awesome.

I did not get the edl package, but I really want it and of course his account is suspended.
Anybody have it ?
Also this method should be capable of working on your phone, as it is a cv1 device.
You may have to downgrade the firmware to Nougat before proceeding if the device is currently running Oreo.

If the device is currently running Oreo or later, you can downgrade the phone to Nougat using the LGUP utility
4th July 2019, 06:29 PM |#21  
Senior Member
Thanks Meter: 50
 
Donate to Me
More
Quote:
Originally Posted by tecknight

The issue you describe appears to be caused by kernel incompatibilities between certain partitions of the phone.
The fact that TWRP does not have the screen glitching issue implies that the kernel embedded in the TWRP image you flashed IS compatible, but perhaps the kernel within your boot image is NOT.
My first question would be:
You mention that you rooted your phone from fastboot.
Did you:
1. patch the stock boot image on your phone or
2. flash a pre-rooted boot image to your boot partition or
3. Flash a pre rooted ROM to your phone
If you answered #2 or #3, then my secondary question would be:
Specifically which boot image or ROM did you flash to your phone ?

---------- Post added at 08:35 PM ---------- Previous post was at 08:32 PM ----------



I did not get the edl package, but I really want it and of course his account is suspended.
Anybody have it ?
Also this method should be capable of working on your phone, as it is a cv1 device.
You may have to downgrade the firmware to Nougat before proceeding if the device is currently running Oreo.

If the device is currently running Oreo or later, you can downgrade the phone to Nougat using the LGUP utility

anybody had any success with downgrade on the phoenix 4?
I have one and it wont reboot to fastboot,
and so I think I need the Lk image from the nougat version,
mines on oreo.
any help for this?

I know how to downgrade the lk but id need a copy from a different device...
Post Reply Subscribe to Thread

Tags
lm-x210; cv1; aristo 2; phoenix 4; k9 tv

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes