FORUMS
Remove All Ads from XDA

ROM][UNOFFICIAL][PIE] LineageOS 16.0 for Samsung Galaxy C5

206 posts
Thanks Meter: 425
 
By vm03, Recognized Developer on 1st June 2019, 06:13 PM
Post Reply Email Thread
25th June 2019, 01:31 AM |#11  
Junior Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by chasemedown

Thank you for creating a ROm with such great performance and battery life! HOWEVER, there is one critical bug that I have been encountering consistently, no matter how many times I wipe and clean install following the instructions exactly (I have the correct bootloader and gapps versions).

>>>What happens:
Sometimes, when I try to turn on the screen after it has timed out (using the home or power button), the lockscreen would rapidly blink between screen on and screen off, causing a "lockscreen loop" that prevents me from unlocking the phone. This would repeat infinitely, and the only thing I can do to get out of it is hold the power button and hit power off or restart if I time it correctly between the blinking. Once the phone restarts, it would usually go back to normal, but once in a while, the phone would reboot back into the exact same "lockscreen loop". When this happens, this loop NEVER stops, no matter how many times I reboot, so I am eventually forced to wipe/factory reset and reinstall the ROM again from scratch.

>>>How frequently/when does it happen:
This happens after every clean install within 2 to 72 hours (I've done 5 clean installs now), but happens randomly with no apparent trigger. After a reboot, sometimes it would go back to normal, but eventually, it will happen again and cause the death loop I described above. It has happened even after a fresh install with no 3rd party apps/gapps/magisk installed, and has never occured with your other Lineage OS 15.1 ROM.

>>>A secondary problem:
If the phone is able to recover from the initial "lockscreen loop" after a reboot, the LED light for charging and notifications would stop working completely (same issue described by dragon170 above). Although, this issue is not important since the phone will stop booting into the OS soon after.

I would love to continue using this ROM as my daily driver if there's anyway to resolve this issue. Any advice would be greatly appreciated!

for lockscreen loop preblem you can delet locksettings.db from twrp and will boot to system i had the problem before directory : data/system/locksettings.db
delete this file this way worked for me
don't forget to mount system
but you will need to resetting lock pattern
The Following 2 Users Say Thank You to ammar mk For This Useful Post: [ View ] Gift ammar mk Ad-Free
 
 
25th June 2019, 01:56 AM |#12  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by ammar mk

for lockscreen loop preblem you can delet locksettings.db from twrp and will boot to system i had the problem before directory : data/system/locksettings.db
delete this file this way worked for me
don't forget to mount system
but you will need to resetting lock pattern

Thank you very much!!! I just deleted locksettings.db and restarted; so far so good. Fingers crossed this resolves the issue permanently.

UPDATE: Deleting locksettings.db alone did not resolve the issue. HOWEVER, it lead me to figuring out the cause was a fingerprint scanner issue. I deleted data/system/user/0/settings_fingerprint.xml and stopped using the fingerprint scanner; everything is fine now!
25th June 2019, 12:22 PM |#13  
Junior Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by chasemedown

Thank you very much!!! I just deleted locksettings.db and restarted; so far so good. Fingers crossed this resolves the issue permanently.

you welcome bro
27th June 2019, 06:28 AM |#14  
Junior Member
Thanks Meter: 0
 
More
Well i like the rom. I have a humble request to developers and team of the rom can you please add a additional lte band to it.. i need lte bnd 5 to be working on it. Thank you
1st July 2019, 04:57 PM |#15  
OP Recognized Developer
Flag Odintsovo
Thanks Meter: 425
 
Donate to Me
More
Quote:
Originally Posted by chasemedown

Thank you for creating a ROm with such great performance and battery life! HOWEVER, there is one critical bug that I have been encountering consistently, no matter how many times I wipe and clean install following the instructions exactly (I have the correct bootloader and gapps versions).

>>>What happens:
Sometimes, when I try to turn on the screen after it has timed out (using the home or power button), the lockscreen would rapidly blink between screen on and screen off, causing a "lockscreen loop" that prevents me from unlocking the phone. This would repeat infinitely, and the only thing I can do to get out of it is hold the power button and hit power off or restart if I time it correctly between the blinking. Once the phone restarts, it would usually go back to normal, but once in a while, the phone would reboot back into the exact same "lockscreen loop". When this happens, this loop NEVER stops, no matter how many times I reboot, so I am eventually forced to wipe/factory reset and reinstall the ROM again from scratch.

>>>How frequently/when does it happen:
This happens after every clean install within 2 to 72 hours (I've done 5 clean installs now), but happens randomly with no apparent trigger. After a reboot, sometimes it would go back to normal, but eventually, it will happen again and cause the death loop I described above. It has happened even after a fresh install with no 3rd party apps/gapps/magisk installed, and has never occured with your other Lineage OS 15.1 ROM.

>>>A secondary problem:
If the phone is able to recover from the initial "lockscreen loop" after a reboot, the LED light for charging and notifications would stop working completely (same issue described by dragon170 above). Although, this issue is not important since the phone will stop booting into the OS soon after.

I would love to continue using this ROM as my daily driver if there's anyway to resolve this issue. Any advice would be greatly appreciated!

Try to disable AOD.
3rd July 2019, 07:01 PM |#16  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by vm03

Changelog

20190531:
- First public release
Possibly update from 15.1 without wipe:
1. install LineageOS 16.0
2. install gapps 9.0
3. reboot

Will a new update come for lineageos updates and bugs?
6th July 2019, 07:12 AM |#17  
Junior Member
Thanks Meter: 3
 
More
wifi dose not work again
9th July 2019, 10:25 AM |#18  
Senior Member
Thanks Meter: 52
 
More
Quote:
Originally Posted by ammar mk

for lockscreen loop preblem you can delet locksettings.db from twrp and will boot to system i had the problem before directory : data/system/locksettings.db
delete this file this way worked for me
don't forget to mount system
but you will need to resetting lock pattern

Same issue on my Galaxy Note 3.
I was able to get rid of the loop after deleting locksetting.db
Thank you sir!
S.
12th July 2019, 08:32 AM |#19  
OP Recognized Developer
Flag Odintsovo
Thanks Meter: 425
 
Donate to Me
More
20190711:
- Fix USB and WiFi tethering
- mainstream LineageOS updates
12th July 2019, 08:34 AM |#20  
OP Recognized Developer
Flag Odintsovo
Thanks Meter: 425
 
Donate to Me
More
Quote:
Originally Posted by thinhx2

Can you tell me about nokia x2 ara?

msm8610 very-very old for current android world....
12th July 2019, 09:11 AM |#21  
thinhx2's Avatar
Senior Member
Flag Quảng Ninh
Thanks Meter: 2,036
 
Donate to Me
More
Quote:
Originally Posted by vm03



msm8610 very-very old for current android world....

I mean fix RIL on cm13,cm14


* Do you interest WP on Ara ?
Attached Thumbnails
Click image for larger version

Name:	IMG_20190712_123342.jpg
Views:	20
Size:	259.4 KB
ID:	4791031   Click image for larger version

Name:	IMG_20190712_123249.jpg
Views:	20
Size:	277.0 KB
ID:	4791032   Click image for larger version

Name:	IMG_20190712_122807.jpg
Views:	18
Size:	257.5 KB
ID:	4791035   Click image for larger version

Name:	IMG_20190712_004614.jpg
Views:	18
Size:	281.1 KB
ID:	4791036  
Post Reply Subscribe to Thread

Tags
samsung-galaxy-c5

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes