FORUMS
Remove All Ads from XDA

[ADB+FASTBOOT Binaries] for OS X inclusive installer

245 posts
Thanks Meter: 110
 
By simmac, Senior Member on 15th November 2014, 01:33 PM
Post Reply Email Thread
Hello,
I couldn't find an up to date thread with this, so I decided to create it.
I uploaded the newest adb and fastboot binaries out of the Android SDK for OS X and Linux and wrote a little script, which installs it for you.
You can find the script and the binaries here: https://github.com/simmac/minimal_adb_fastboot
I will try to keep the binaries up to date! You can help me by posting an answer as an heads up, I will do the rest.

How to install:
  1. Download the zip
  2. unzip it
  3. cd to the directory (probably Downloads/minimal_adb_fastboot ) *
  4. Start the shell script with ./install.sh
*You don't longer have to do this. Since v1.1 you can call the script with /path/to/script/./install.sh . (eg Downloads/minimal_adb_fastboot-master/./install.sh )


You can either download the zip directly ( https://github.com/simmac/minimal_ad...ive/master.zip ) or clone the repository ( https://github.com/simmac/minimal_adb_fastboot ).

[LEGACY] Installer Package! You can now install the binaries via my installer package, which simply copies the binaries to /usr/bin. Download: https://github.com/simmac/minimal_ad...Installer.mpkg NOTE: The package isn't supported anymore, please use the script!


NOTE: This is for OS X and Linux!

I hope I help you with this.
The Following 22 Users Say Thank You to simmac For This Useful Post: [ View ] Gift simmac Ad-Free
 
 
15th November 2014, 01:34 PM |#2  
OP Senior Member
Flag Vienna
Thanks Meter: 110
 
Donate to Me
More
Changelog:
The Following 3 Users Say Thank You to simmac For This Useful Post: [ View ] Gift simmac Ad-Free
16th November 2014, 01:32 PM |#3  
OP Senior Member
Flag Vienna
Thanks Meter: 110
 
Donate to Me
More
Info 2 v1.1 release
I just released v1.1 of my script.
Changes: The script can now be called from everywhere, you don't have to navigate to the folder anymore.
The Following User Says Thank You to simmac For This Useful Post: [ View ] Gift simmac Ad-Free
16th November 2014, 05:13 PM |#4  
Senior Member
Thanks Meter: 409
 
More
Thanks! Working great for me.
The Following User Says Thank You to TotallyAnxious For This Useful Post: [ View ] Gift TotallyAnxious Ad-Free
16th November 2014, 06:12 PM |#5  
OP Senior Member
Flag Vienna
Thanks Meter: 110
 
Donate to Me
More
Good to hear, @JennyLikesSka !
18th November 2014, 06:43 PM |#6  
Senior Member
Thanks Meter: 168
 
More
Excellent. The first link on Google didn't support sideload but this did so thanks so much!
The Following User Says Thank You to GigabitEthernet For This Useful Post: [ View ] Gift GigabitEthernet Ad-Free
18th November 2014, 06:53 PM |#7  
OP Senior Member
Flag Vienna
Thanks Meter: 110
 
Donate to Me
More
Quote:
Originally Posted by AlecRobertson

Excellent. The first link on Google didn't support sideload but this did so thanks so much!

You are welcome!
That's exactly why I made this I couldn't find the newest Binaries anywhere, so I downloaded the whole SDK and extracted the bins.
Maybe a mod wants to pin the thread?
23rd November 2014, 02:49 PM |#8  
OP Senior Member
Flag Vienna
Thanks Meter: 110
 
Donate to Me
More
v 1.1.1 release notes + installer package
I just released v1.1.1, which changes the name to "Quick ADB/Fastboot installer" due to name conflict with the "Minimal ADB and Fastboot" tool.
Also, I did some cleanups in the code and made an installer package, which simply copies the binaries in /usr/bin.


Download the installer package here: https://drive.google.com/file/d/0B_i...dvRTVpZU0/view
And the normal command line installer here: https://github.com/simmac/minimal_ad...hive/1.1.1.zip
The Following User Says Thank You to simmac For This Useful Post: [ View ] Gift simmac Ad-Free
25th November 2014, 02:40 AM |#9  
dholms's Avatar
Member
Thanks Meter: 6
 
More
I run accross the issue with flashing my N5 with stock 5.0 and adb needing to be updated to 1.0.32

I have downloaded and run command prompts up to where it says - Installation completed successfully! adb version 1.0.32 is now installed.
I then tried to flash again, but still get the error to update my adb?
25th November 2014, 02:54 AM |#10  
Senior Member
Thanks Meter: 409
 
More
Quote:
Originally Posted by simmac

I just released v1.1.1, which changes the name to "Quick ADB/Fastboot installer" due to name conflict with the "Minimal ADB and Fastboot" tool.
Also, I did some cleanups in the code and made an installer package, which simply copies the binaries in /usr/bin.


Download the installer package here: https://drive.google.com/file/d/0B_i...dvRTVpZU0/view
And the normal command line installer here: https://github.com/simmac/minimal_ad...hive/1.1.1.zip

The package won't open on my mac. Just get an error message.
25th November 2014, 06:49 AM |#11  
OP Senior Member
Flag Vienna
Thanks Meter: 110
 
Donate to Me
More
@dholm: How do you run adb/fastboot?
With "adb" or "./adb"?

@JennyLikesSka: Which Message?
Did you try open it with rightclick - > Open?
Which OS X version do you run?
Post Reply Subscribe to Thread

Tags
adb, bin, binary, fastboot, os x

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes