FORUMS
Remove All Ads from XDA

ColorOS 5.0: How to allow apps running in the background

2 posts
Thanks Meter: 0
 
By arungp, Junior Member on 27th September 2018, 05:27 PM
Post Reply Email Thread
I am using Oppo F7 with ColorOS 5.0.
All my apps that required Autostart and running in the backround, that worked in CynaogenOS are no longer working in ColorOS.

Oppo's Color OS is a Control freak. Only it doesn't know how to control. There you go.... Double points scored.
Apparently ColorOS is also well known for it's agressive taskmanagement. It does NOT work even after making changes in the following sections
=> Settings -> Dual SIM & Cellular -> Data Saving, turning the feature Off
=> Settings -> Battery, turning Power Saving Off
=> Settings -> App Management -> providing all permissions to the selected application
NOTE: But WhatsApp and Telegram are working though. It has to be noted that they each have an account in Settings -> Accounts and Sync. Also the task windows of these apps were automatically locked once I started them. And they retain across reboots.

That's right, if the task windows are locked they properly run in the background and retain this across reboots.

To do this, perform the following steps
  • Start the required application and make sure you are in
  • Press the Task list button. All your Task windows should be listed
  • Select the required app and do a downward pull. That should lock the app window and a lock button should appear on the top left-hand side
  • Click the X button to clear tasks. The required app window should still remain in the Task list

Apparently this should persist across reboots for most apps.
 
 
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes