FORUMS
Remove All Ads from XDA

[FIX] Unknown USB device (Device Descriptor Request Failed) Fastboot Windows 10

1 posts
Thanks Meter: 15
 
By BoBo Rich, Junior Member on 8th May 2016, 09:11 PM
Post Reply Email Thread
First of all, I have a HTC Droid DNA. I was searching for about a year. Finally I got a solution for my problem and I know some of you are still out there with no solution.

The Fail Code is: Unknown USB device (Device Descriptor Request Failed)
Windows has stopped this device because it has reported problems. (Code 43)

So I found a German solution where you have to go to regedit.

Step 1: You need to install the HTC drivers (Google, Samsung etc...) in the normal mode your PC will find your phone, but when you turn into Fastboot you get that error "Unknown USB device (Device Descriptor Request Failed) "

Step 2: Make sure you see that error in your Device Manager under USB - Controller

Step 3: Open "regedit"

Step 4: Navigate to : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\usbflags

Step 5: Create a new Key called

0BB40FF00100

Step 6: In that Key you create a Binary Value

Name: SkipBOSDescriptorQuery
Value: 01 00 00 00 (ignore the "0000" at the beginning)

Step 7: Reconnect the Phone and enjoy your FIX

I hope I helped you. I can just tell you that it worked for me. I m not sure if it works on all HTC devices.
The Following 15 Users Say Thank You to BoBo Rich For This Useful Post: [ View ] Gift BoBo Rich Ad-Free
4th November 2016, 12:08 AM |#2  
Psy0ch's Avatar
Member
Thanks Meter: 4
 
More
tried it with a S7 right now, didnt work. thanks for your post tho!
4th February 2017, 11:23 PM |#3  
Junior Member
Flag Copenhagen
Thanks Meter: 0
 
More
Had the solution for windows 8.1, from a blog on microsoft MSDN. (Sorry can't link to it. Since I'm new @ xda)
But as it turned out the Datatype for SkipBOSDescriptorQuery has changed from windows 8.1 to 10. Instead of a DWORD Value in Windows 8.1 it should be a Binary Value in Windows 10 .

So thanks Now I can connect via fastboot to my HTC Incredible S.

Ps. Google this:
why-does-my-usb-device-work-on-windows-8-0-but-fail-on-windows-8-1-with-code-43
And blogpost will show as top result
14th February 2017, 11:33 PM |#4  
maxsteel1947's Avatar
Junior Member
Thanks Meter: 0
 
More
Thank you very much the regedit method worked for sure..

I spent 5 hours on my computer and laptop different usb cables different ports installing uninstalling drivers and ADB nothing

Thanks BoBo Rich
16th March 2017, 12:09 AM |#5  
Member
Thanks Meter: 8
 
More
Thnx!!
28th March 2017, 05:43 PM |#6  
Junior Member
Flag Tehran
Thanks Meter: 0
 
More
Didn't work for HTC Explorer (Pico)
27th August 2017, 08:28 PM |#7  
Junior Member
Thanks Meter: 0
 
More
Worked with the HTC Aria on Win10 x64!

Thanks a ton.

edit: Hrm. Seems to have cropped up again. Time to continue the battle *sigh*
edit 2: Got it! Thankfully I had a Win7 laptop that I was able to fire up. The HTC Aria's fastboot hardware ID is "USB\VID_0BB4&PID_0FFF&REV_0100" which means the vvvvpppprrrr is 0BB40FFF0100. So follow the instructions above but using the key of 0BB40FFF0100
27th October 2017, 07:33 AM |#8  
Senior Member
Thanks Meter: 3
 
More
Has anyone else gotten this to work?

My Pixel XL isn't recognized at all when plugged in while in system, but it shows up as unrecognized when plugged in while in fastboot. But despite installing the drivers, Windows still refuses to recognize the phone. I tried the various solutions in this thread, but none of them worked. Perhaps it's because my Pixel's fastboot hardware ID is different, but I can't seem to find out what it is.
30th March 2018, 08:26 PM |#9  
Junior Member
Thanks Meter: 2
 
Donate to Me
More
work perfectly for htc one xl (evita). Thanks !!
5th August 2018, 09:07 AM |#10  
Junior Member
Thanks Meter: 0
 
More
Thanks
After 48 Hours of searching!! thanks man! HTC ONE S (Ville)
23rd August 2018, 08:11 AM |#11  
o-l-a-v's Avatar
Senior Member
Flag Oslo
Thanks Meter: 490
 
Donate to Me
More
Thanks! I have this problem with my Shield TV Pro, will try this after work.
Here's some PowerShell code for doing the registry editing, if anyone is interested.

Code:
#Requires -RunAsAdministrator
[string] $Path = 'HKLM:\SYSTEM\CurrentControlSet\Control\usbflags\0BB40FF00100'
[string] $Name = 'SkipBOSDescriptorQuery'

if ($false) {
    # Create the path if not exist
    if (-not(Test-Path -Path $Path)){New-Item -Path $Path -ItemType 'Directory'}

    # Set "SkipBOSDescriptorQuery" to $true
    Set-ItemProperty -Path $Path -Name $Name -Value 1 -Type 'DWord'

    # Set "SkipBOSDescriptorQuery" to $false
    Set-ItemProperty -Path $Path -Name $Name -Value 0 -Type 'DWord'

    # Remove item
    Remove-ItemProperty -Path $Path -Name $Name

    # Remove path and item(s)
    Remove-Item -Path $Path -Recurse -Force
}
Edit: This did not work for my Shield TV 2015 Pro unfortunately..
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes