FORUMS
Remove All Ads from XDA

[FIX] USB Tethering lags/freezes on windows 8.1

169 posts
Thanks Meter: 128
 
By mpjoe2000, Senior Member on 24th February 2015, 01:39 PM
Post Reply Email Thread
Everytime i tried to use USB Tethering with my Xperia U on my Windows 8.1 (Bing's single language Edition [Genuine Licence]) have always lags or even freeze the taskbar and some other tool settings on my operating system. After some testing and googling a little bit i found a solution for this Microsoft Issue: Update your NDIS 5 Driver to NDIS 6.x.

Verify if your device is using RNDIS 5 driver (1):
  • Open Device Manager from Control Panel and expand “Network Adapters.”
  • Plug in your device and enable USB Tethering so that the device is detected as Remote NDIS based device.
  • This should now create a Network Adapter named as “ [Your Device Name] Remote NDIS based [internet Sharing/network] Device.”
  • Right-click the Adapter and select Properties.
  • Select the Driver tab and then click Driver Details.
  • You can see the driver files if the files are named usb8023x.sys and rndismpx.sys you are using RNDIS 5 Driver.


Updating your driver:
  • Option 1: Update your driver NDIS driver manually by selecting the driver's list option on windows wizard driver's update. Unselect show all compatible hardware option, you will get a Microsoft's driver list. You should seek for a RNDIS 6 USB device and click next. This should work on 32bits or 64bits edition.
  • Option 2 (64 bits only)(2): Just Download and update your NDIS driver from the attachment below. On Driver's Wizard installation must go through selecting the driver from a list.
Sources:
http://support.microsoft.com/kb/2923775 (1)
http://www.driverscape.com/download/...patible-device (2)
https://msdn.microsoft.com/en-us/lib...=vs.85%29.aspx. Microsoft says NDIS 6.4 is included on Windows 8.1, don't know why windows chooses RNDIS 5 over RNDIS 6 on my laptop.
Attached Files
File Type: zip rndiscmp.inf_amd64_8cb932739fef737d.zip - [Click for QR Code] (1.8 KB, 34762 views)
The Following 39 Users Say Thank You to mpjoe2000 For This Useful Post: [ View ] Gift mpjoe2000 Ad-Free
 
 
28th February 2015, 06:49 PM |#2  
Senior Member
Flag Munich
Thanks Meter: 79
 
More
Thanks for your great tutorial. I tried updating the drivers but stupid windows doesn't let me do it. If I try the first method to install and click the "RNDIS 6 Adapter" drivers in the "Microsoft" list, it shows an error that some "required line in the INF file could not be found" (translated from german).

Then if I try the manual method (downloading the zip), windows refuses to install and says "the latest drivers is already installed" (translated).

I also tried uninstalling the drivers but as soon as I plug in the device it installs the wrong drivers again manually. I cannot stop this also because of the extremely lag in the taskbar...

Thanks windows!

regards
1st March 2015, 11:14 PM |#3  
OP Senior Member
Thanks Meter: 128
 
More
Quote:
Originally Posted by MHP2013

Thanks for your great tutorial. I tried updating the drivers but stupid windows doesn't let me do it. If I try the first method to install and click the "RNDIS 6 Adapter" drivers in the "Microsoft" list, it shows an error that some "required line in the INF file could not be found" (translated from german).

Then if I try the manual method (downloading the zip), windows refuses to install and says "the latest drivers is already installed" (translated).

I also tried uninstalling the drivers but as soon as I plug in the device it installs the wrong drivers again manually. I cannot stop this also because of the extremely lag in the taskbar...

Thanks windows!

regards

Try this before installing the NDIS 6 driver:
http://www.tomshardware.com/faq/id-2...ers-icons.html

If above didn't work try to disable driver signature verification:
http://www.howtogeek.com/167723/how-...igned-drivers/
The Following 2 Users Say Thank You to mpjoe2000 For This Useful Post: [ View ] Gift mpjoe2000 Ad-Free
22nd July 2015, 06:56 PM |#4  
Senior Member
Flag Maassluis
Thanks Meter: 90
 
More
Thumbs up
Perfect, Thanks for this fix! Didn't need the driver as RNDIS6 driver is already included in Windows 8.1

NDIS Compatible works without huge driver lockups, but RNDIS6 USB Adapter also works like a charm. (Nexus 5)
6th August 2015, 10:03 PM |#5  
Senior Member
Flag Dar es salaam, Tanzania
Thanks Meter: 30
 
More
Facing the same problem, here.

Tried both options, still facing the same problem..

Any ideas?
Attached Thumbnails
Click image for larger version

Name:	2015-08-07_000247.png
Views:	4984
Size:	9.5 KB
ID:	3430617  
13th October 2015, 08:53 AM |#6  
Member
Thanks Meter: 3
 
More
I am having the same issue in Windows 10 64-Bit.
18th November 2015, 01:27 PM |#7  
Senior Member
Thanks Meter: 45
 
More
Got this issue after upgrading Windows 10 (I was already on 10). This solved the problem perfectly. Thanks for fixing yet another fail from Microsoft.
10th December 2015, 02:37 AM |#8  
DubleJayJ's Avatar
Senior Member
Flag Pittsburgh
Thanks Meter: 95
 
More
Quote:
Originally Posted by Ano59

Got this issue after upgrading Windows 10 (I was already on 10). This solved the problem perfectly. Thanks for fixing yet another fail from Microsoft.

I keep trying to update it on Windows 10 but it keeps telling me it's the most up to date driver(it definitely isn't). How did you go about doing it?
10th December 2015, 10:30 PM |#9  
Senior Member
Thanks Meter: 45
 
More
Quote:
Originally Posted by DubleJayJ

I keep trying to update it on Windows 10 but it keeps telling me it's the most up to date driver(it definitely isn't). How did you go about doing it?

As OP said, manually select the proper driver.
22nd December 2015, 09:59 PM |#10  
inkaine's Avatar
Member
Thanks Meter: 18
 
More
Windows 10 best solution: rename the RNDIS5 .inf file
The issue drove me nuts on Windows 10 as well. Selecting another driver as suggested did not work for me as well, since Windows kept jumping back to the RNDIS5 driver all the time.

But I found the solution: Just rename the .inf-file containing the RNDIS5 driver. That way Windows will automatically use the RNDIS6 driver.
  1. Go to C:\Windows\INF folder
  2. Find file wceisvista.inf
  3. Take ownership of that file and grant yourself permissions
  4. Rename the file extension to anything but .inf (for me I used .in_)
  5. Enjoy the RNDIS6 driver
The Following 2 Users Say Thank You to inkaine For This Useful Post: [ View ] Gift inkaine Ad-Free
28th January 2016, 01:36 PM |#11  
Junior Member
Flag Paris
Thanks Meter: 9
 
More
Something is not logical in this tutorial :
The content of the inf file in the attachment is rndiscmp.inf; but this file is already in Win8.1 system (C:\Windows\Inf). Hash are similar

This could explain why windows refuses to install it again and says "the last drivers is already installed"
Renaming extension of wceisvista.inf doesn't work for me in Win 8.1

Maybe you could tell us the name of driver files when using RNDIS 6 Driver ...
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes