FORUMS
Remove All Ads from XDA

[Guide][Video Tutorial] How to build Custom ROMs and Kernel Modification![P,O,N,M,L]

1,838 posts
Thanks Meter: 3,922
 
Post Reply Email Thread
31st July 2019, 11:04 AM |#1441  
Senior Member
Thanks Meter: 115
 
More
Quote:
Originally Posted by coach0512

Did you ever find a fix for this?

No actually not.
 
 
31st July 2019, 07:04 PM |#1442  
DJABHipHop's Avatar
Senior Member
Thanks Meter: 387
 
More
Im trying to build LineagOS based Rom for the Samsung Galaxy Tab 4 10.1 & 8.0

Anyone know how to fix this error & get the front camera working?
AudioTrack: Could not get audio output for session 273, stream type -1, usage 1, sample rate 44100, format 0x1000000, channel mask 0x3, flags 0x11
AudioSink: Unable to create audio track

All Repos: cm-14.1-test
Kernel: cm-14.1-test
Board repo: cm-14.1

Rom: https://github.com/LightningFastRom
Device: Samsung Galaxy Tab 4

Device Tree A-1: Samsung Galaxy Tab 4 10.1-(matisse)
https://github.com/matissewifi

Device with broken Front camera Samsung Galaxy Tab 4 8.0-(millet all 3 variance)
Device Tree A-2: Samsung Galaxy Tab 4 8.0-(millet)
https://github.com/milletwifi
31st July 2019, 09:45 PM |#1443  
Junior Member
Thanks Meter: 6
 
More
Quote:
Originally Posted by lucki1000

No actually not.

damn I'm trying to build RR for the OP7P and had this issue using Lineage sources. I'll keep trying. I think I need to merge some vendor commits.
5th August 2019, 04:41 PM |#1444  
Senior Member
Thanks Meter: 68
 
Donate to Me
More
Quote:
Originally Posted by coach0512

Hello Community,

How can I define a module?
I create a fork from a similar device tree(same brand, and with allmost same specs) and now I get an error while compiling.
I'm building Los 16.

Error:



Did you ever find a fix for this?

Well first you can try checking your device tree to see if the fingerprint blobs are all there and defined correctly in the makefiles. If you're using a commonly used source then everything should be good to go so RR could be changing something. Maybe try checking the vendor makefiles and blobs from RR, after making sure your device tree is in order, and see if it defines any modules itself or is calling the wrong paths somewhere
The Following User Says Thank You to RebelLion_ For This Useful Post: [ View ] Gift RebelLion_ Ad-Free
9th August 2019, 04:31 AM |#1445  
Senior Member
Thanks Meter: 43
 
More
I'm making an RR Nougat ROM for my Samsung Galaxy Tab 3 10.1. The security patches are really old, however (Dec 5, 2017). I've successfully added Jan 1, 2018 patches, but now I'm confused about Jan 5, 2018 patches. Some of them don't link to a commit that I can use and the others are OEM specific. Do I need to add the OEM specific patches if I'm only building for Samsung? And how do I add the patches with no links?
12th August 2019, 01:47 PM |#1446  
Member
Thanks Meter: 3
 
More


I need help with this, please I've tried for days and now it's stuck at 99% with this stupid error..

How to fix? Really thanks to everyone who replies
12th August 2019, 04:03 PM |#1447  
SamuelBegui's Avatar
Senior Member
Flag /home/coolbeans/
Thanks Meter: 734
 
More
Quote:
Originally Posted by guyzz6370





I need help with this, please I've tried for days and now it's stuck at 99% with this stupid error..



How to fix? Really thanks to everyone who replies

It looks like the compilation is crashing because LLVM_ENABLE_THREADS is off, have you tried enabling the flag and compiled again?

Sent from my Pixel 2 XL using Tapatalk
13th August 2019, 02:56 AM |#1448  
DJABHipHop's Avatar
Senior Member
Thanks Meter: 387
 
More
Quote:
Originally Posted by Soumy1234

I'm making an RR Nougat ROM for my Samsung Galaxy Tab 3 10.1. The security patches are really old, however (Dec 5, 2017). I've successfully added Jan 1, 2018 patches, but now I'm confused about Jan 5, 2018 patches. Some of them don't link to a commit that I can use and the others are OEM specific. Do I need to add the OEM specific patches if I'm only building for Samsung? And how do I add the patches with no links?

Have you gotton Skype working on the Samsung Galaxy Tab 3 yet because I'm also making custom rok for legacy Samsung devices like the Samsung Galaxy Tab 4 10.1, Samsung Galaxy Tab 4 8.0, Samsung Galaxy Tab E 9.6 & I'm also upgradeing 6 Samsung Galaxy Tab 4 3 10.1 & 3 8.0, 1 10.1/8.0 WiFi, 1 10.1/8.0 3G & 1 10.1/8.0 LTE.
14th August 2019, 05:27 PM |#1449  
Senior Member
Thanks Meter: 34
 
More
Hello guys,
I am building Dirty Unicorns for device X00TD (Asus Zenfone Max Pro M1) which does not officially supports it. I added all of the required files and fetched required repos but when I run brunch command it gives this error.


[email protected]:~/DU# brunch du_X00TD-userdebug
including vendor/du/vendorsetup.sh
build/core/product_config.mk:240: *** _nic.PRODUCTS.[[device/asus/X00TD/du.mk]]: "frameworks/native/build/phone-xxhdpi-3072-dalvik-heap.mk" does not exist. Stop.
Device X00TD not found. Attempting to retrieve device repository from DU Github (http://github.com/DirtyUnicorns).
Repository for X00TD not found in the DU Github repository list. If this is in error, you may need to manually add it to .repo/local_manifests/du_manifest.xml
build/core/product_config.mk:240: *** _nic.PRODUCTS.[[device/asus/X00TD/du.mk]]: "frameworks/native/build/phone-xxhdpi-3072-dalvik-heap.mk" does not exist. Stop.
build/core/product_config.mk:240: *** _nic.PRODUCTS.[[device/asus/X00TD/du.mk]]: "frameworks/native/build/phone-xxhdpi-3072-dalvik-heap.mk" does not exist. Stop.

** Don't have a product spec for: 'du_X00TD'
** Do you have the right repo manifest?




Can someone please help?
No such item in brunch menu. Try 'breakfast'
14th August 2019, 05:49 PM |#1450  
Senior Member
Thanks Meter: 43
 
More
Quote:
Originally Posted by DJABHipHop

Have you gotton Skype working on the Samsung Galaxy Tab 3 yet because I'm also making custom rok for legacy Samsung devices like the Samsung Galaxy Tab 4 10.1, Samsung Galaxy Tab 4 8.0, Samsung Galaxy Tab E 9.6 & I'm also upgradeing 6 Samsung Galaxy Tab 4 3 10.1 & 3 8.0, 1 10.1/8.0 WiFi, 1 10.1/8.0 3G & 1 10.1/8.0 LTE.

I've installed Skype, but I haven't signed in or made calls. What's wrong with Skype on your device?
14th August 2019, 06:58 PM |#1451  
DJABHipHop's Avatar
Senior Member
Thanks Meter: 387
 
More
Quote:
Originally Posted by Soumy1234

I've installed Skype, but I haven't signed in or made calls. What's wrong with Skype on your device?

microphone or camera don't work in Skype neither do the speaker It's like Skype refuses to see that the device has a microphone & a camera on on all 6 Samsung Galaxy Tab 4 & the speaker Samsung Galaxy Tab 4 10.1 msm8226/msm8926
Post Reply Subscribe to Thread

Tags
compile, guide, kernel, rom, video

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes