FORUMS
Remove All Ads from XDA

[GUIDE] How to enter developer mode on 2017 Honda Civic (and now root & install apps)

98 posts
Thanks Meter: 56
 
By codeage, Member on 14th June 2017, 09:27 AM
Post Reply Email Thread
Finally somebody here in China found a way to enter the developer mode on 2017 civic. The trick is, when you see the prompt "Please enter a passcord", just click the top 4 list items in a special order (1, 4, 2, 3) and then the developer mode will be unlocked.

But after entering the developer mode, it is still impossible to make a adb connection over tcpip to the head unit because no open port found for adb. Can someone here find a way to establish the adb connection so we can root the head unit using the same method on 2016 pilot?

======================
Updated 2017.06.26
Now we can root the head unit and install apps. Below are the detailed steps, please use at your own risk.


======================
Updated 2017.09.27
Finally I solved the auto reboot problem while remounting the /system partition. Now we can root the head unit with just one click. Enjoy it!!!


1. Download all files from GitHub: https://github.com/codeage/root-honda
2. Enter developer mode in the head unit and enable USB debugging.
  • In the Android Settings window, click About.
  • Click the Build Number seven times.
  • Now you will see the Please enter a passcord prompt.
  • Click the top 4 items in order 1, 4, 2, 3 and you should unlock the developer mode.
Click image for larger version

Name:	civic-1.jpg
Views:	19244
Size:	92.2 KB
ID:	4181203 Click image for larger version

Name:	civic-2.jpg
Views:	18230
Size:	166.3 KB
ID:	4181204 Click image for larger version

Name:	civic-3.jpg
Views:	15758
Size:	164.3 KB
ID:	4181205 Click image for larger version

Name:	civic-4.jpg
Views:	24208
Size:	93.4 KB
ID:	4181206
3. Change the USB mode of the head unit from 'Host' to 'Device'. Click here for details: http://www.civicx.com/threads/how-to...-models.12479/
  • Press the power, menu, and brightness button at once, and hold until you enter a new menu with two options. Click the bottom option called Detail Information & Settings.
  • Now hold the menu key to enter another menu.
  • Finally, hold the home key enter the last menu. You should first hear two consecutive beeps and then one final beep.
  • Now you should connect your laptop to the front Android Auto/CarPlay Port using the USB A to A cable.
  • Lastly, change the role of USB Port from Host to Device.
  • Your laptop should automatically install the drivers, and to check if you're connected just type in the command "ADB devices" and your head unit should show up.
4. Run the following script to root the head unit. You will see "Success" at last if everything goes well.
  • Mac/Linux: ./root.sh
  • Windows: root.bat
5. Restart the head unit and you will see SuperSU (v2.78) in the app list.
6. Run the following script to install app:
  • Mac/Linux: ./install.sh file.apk
  • Windows: install.bat file.apk
7. If you see the message "This function is not available while the vehicle is in motion" while driving, please refer to this post: http://www.civicx.com/threads/2016-c...-driving.9983/


Some files and scripts were obtained from this thread: https://forum.xda-developers.com/and...honda-t3487644 and all credit goes to @jersacct.
The Following 35 Users Say Thank You to codeage For This Useful Post: [ View ] Gift codeage Ad-Free
 
 
14th June 2017, 03:33 PM |#2  
Junior Member
Thanks Meter: 3
 
More
Great job, I'm going to try this on my Honda CRV 2017 later today to see if it works!
14th June 2017, 04:08 PM |#3  
Junior Member
Flag Richmond, VA
Thanks Meter: 2
 
More
I tried this this morning on my 2016 Civic and it works!

Port 5000 is open for adb on my Civic. Not sure if the port is different on a Pilot or not, but it's different than the standard adb port (5555). I found it by running an nmap scan of my headunit's IP.

Unfortunately even after I enabled Developer mode on my HU, my adb does the same thing it did before. That is, I can adb connect to port 5000 on my HU's IP, but when I do "adb devices", it shows the device there but "offline".

My expectation was that once Developer mode was enabled, connecting via adb would bring up a prompt on the HU asking if I wanted to authorize that remote device.

However, I was doing the adb connection from my PC inside my house, then running out to my garage to check the screen. So maybe I just didn't get there in time to see it. I'm going to try it again from my laptop sitting in my car tonight when I have more time to mess with it.
14th June 2017, 11:31 PM |#4  
Junior Member
Thanks Meter: 1
 
More
Works on my 2017 cr-v! Has anyone had a chance to try usb debugging?
16th June 2017, 10:33 AM |#5  
OP Member
Thanks Meter: 56
 
More
Quote:
Originally Posted by josby

I tried this this morning on my 2016 Civic and it works!

Port 5000 is open for adb on my Civic. Not sure if the port is different on a Pilot or not, but it's different than the standard adb port (5500). I found it by running an nmap scan of my headunit's IP.

Unfortunately even after I enabled Developer mode on my HU, my adb does the same thing it did before. That is, I can adb connect to port 5000 on my HU's IP, but when I do "adb devices", it shows the device there but "offline".

My expectation was that once Developer mode was enabled, connecting via adb would bring up a prompt on the HU asking if I wanted to authorize that remote device.

However, I was doing the adb connection from my PC inside my house, then running out to my garage to check the screen. So maybe I just didn't get there in time to see it. I'm going to try it again from my laptop sitting in my car tonight when I have more time to mess with it.

Yes, same problem here. I think port 5000 is not for adb but some other service from Honda.
16th June 2017, 03:09 PM |#6  
Junior Member
Flag Richmond, VA
Thanks Meter: 2
 
More
Quote:
Originally Posted by codeage

Yes, same problem here. I think port 5000 is not for adb but some other service from Honda.

I hadn't considered that. You might be right. I tried connecting adb on my PC to another computer of mine on a port number that I know for sure isn't an adb listener, and it gives that same behavior of just showing that device is "offline".

But, everything I've read indicates you can't connect with adb over wifi until you first connect with USB and authorize the instance of adb on that computer to connect to the device. So I think that could also be the reason we can't get anywhere on port 5000.

I don't have a TypeA-to-TypeA USB cable to try connecting to the car's USB ports with though.
16th June 2017, 05:01 PM |#7  
Junior Member
Thanks Meter: 0
 
More
https://forum.xda-developers.com/and...1#post70868431

try adb with the usb port on device mode
17th June 2017, 03:06 PM |#8  
OP Member
Thanks Meter: 56
 
More
Quote:
Originally Posted by YurS0D1a0

https://forum.xda-developers.com/and...1#post70868431

try adb with the usb port on device mode

Already tried this but does not work.
Click image for larger version

Name:	IMG_7961.jpg
Views:	5754
Size:	256.0 KB
ID:	4184875
20th June 2017, 12:11 AM |#9  
Junior Member
Thanks Meter: 5
 
More
Quote:
Originally Posted by codeage

Already tried this but does not work.
Attachment 4184875

Hey just making sure before I end up trying the same thing. You tried connecting through the USB port right?

Edit: Turns out you can. I had a friend post about it since my account is new.
20th June 2017, 08:14 AM |#10  
OP Member
Thanks Meter: 56
 
More
Quote:
Originally Posted by OldAmber

Hey just making sure before I end up trying the same thing. You tried connecting through the USB port right?

Yes, I tried connecting through the USB port.
20th June 2017, 11:54 AM |#11  
Junior Member
Thanks Meter: 0
 
More
thanks
nice information
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes