FORUMS
Remove All Ads from XDA

UMIDIGI S3 Pro

1,473 posts
Thanks Meter: 1,120
 
By ghost45, Senior Member on 13th March 2019, 09:22 AM
Post Reply Email Thread
19th April 2019, 08:07 AM |#31  
Senior Member
Flag MTL
Thanks Meter: 81
 
More
Quote:
Originally Posted by ghost45

All the procedure described to use mtkdrodtools is too old and not actualized with our new devices with new hardware and not run at all because this Russian tool is not actualized it remained at 2012/13 how could be to create a recovery with new partitions? with new details?
I studied from too many years these Mtk devices and i know well all the hardware of Mtk devices.

Please i tell you to have respect to the work to everybody....if you want to give me an hand you are welcome! But ask and change opinions with me please!

I totally agree!
 
 
19th April 2019, 12:48 PM |#32  
Member
Thanks Meter: 2
 
More
Issue with unlock bootloader
Hi All,
I just got my S3 Pro and was trying to root it. I couldn't connect to mtktools nor flash using the SP tools. When trying to use oem unlock command, it throws error. "Adb devices" & Fastboot devices provide a name and id of the phone.
Not sure if it's a driver issue on my Windows 10 PC or the phone issue. I feel that I always have issue with installing MTK drivers on Windows 10 (eg: Code 10 or device unrecognized, etc.)
Anyway facing same issues or any solution for the problem, let me know. Thank you in advance.

Regards,
Raghav
19th April 2019, 02:21 PM |#33  
Senior Member
Flag MTL
Thanks Meter: 81
 
More
Quote:
Originally Posted by raghav2984

Hi All,
I just got my S3 Pro and was trying to root it. I couldn't connect to mtktools nor flash using the SP tools. When trying to use oem unlock command, it throws error. "Adb devices" & Fastboot devices provide a name and id of the phone.
Not sure if it's a driver issue on my Windows 10 PC or the phone issue. I feel that I always have issue with installing MTK drivers on Windows 10 (eg: Code 10 or device unrecognized, etc.)
Anyway facing same issues or any solution for the problem, let me know. Thank you in advance.

Regards,
Raghav

Same here, it's related to the drivers
Make sure you disable verify driver signature for windows when you install but even after all this.. I cannot establish connection :/
19th April 2019, 04:12 PM |#34  
ghost45's Avatar
OP Senior Member
Thanks Meter: 1,120
 
Donate to Me
More
Try to use this drivers to recognize your device:


For fastboot command...
after downloading the adb drivers from first page....
inside the msdos windows and inside the folder where is the adb command extracted!

If you test the command writing:
"Fastboot devices"
you must receive the number of your device connected...

to the contrary if you don't see the number of your device probably you have skipped some steps.

If you see the number of your device you can go ahead...
now you must use the command:
" fastboot oem unlock "
The Following User Says Thank You to ghost45 For This Useful Post: [ View ] Gift ghost45 Ad-Free
19th April 2019, 04:41 PM |#35  
Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by ghost45

Try to use this drivers to recognize your device:



For fastboot command...
after downloading the adb drivers from first page....
inside the msdos windows and inside the folder where is the adb command extracted!

If you test the command writing:
"Fastboot devices"
you must receive the number of your device connected...

to the contrary if you don't see the number of your device probably you have skipped some steps.

If you see the number of your device you can go ahead...
now you must use the command:
" fastboot oem unlock "

Attached is the error. Fastboot oem unlock alone fails. Can you explain this? Kindly help me to overcome this
Attached Thumbnails
Click image for larger version

Name:	cmd.jpg
Views:	172
Size:	43.3 KB
ID:	4745639  
19th April 2019, 04:46 PM |#36  
ghost45's Avatar
OP Senior Member
Thanks Meter: 1,120
 
Donate to Me
More
In setting system you must tap many times to see the develped menu... After you make oem unlock there... Try!
19th April 2019, 04:55 PM |#37  
Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by ghost45

In setting system you must tap many times to see the develped menu... After you make oem unlock there... Try!

I already selected OEM bootloader unlock option in developer settings. Error is after that...
19th April 2019, 05:24 PM |#38  
ghost45's Avatar
OP Senior Member
Thanks Meter: 1,120
 
Donate to Me
More
Quote:
Originally Posted by raghav2984

I already selected OEM bootloader unlock option in developer settings. Error is after that...

After make fastboot oem unlock you will receive in the screen of the device a question...

But in the screen of the device you must make ok to unlock the bootloader.. You have made this step?
With the one of the buttons.
Try again and attention to the device screen!
19th April 2019, 06:34 PM |#39  
Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by ghost45

After make fastboot oem unlock you will receive in the screen of the device a question...

But in the screen of the device you must make ok to unlock the bootloader.. You have made this step?
With the one of the buttons.
Try again and attention to the device screen!

unlock oem is ON in the mobile.
19th April 2019, 10:23 PM |#40  
Senior Member
Flag MTL
Thanks Meter: 81
 
More
If someone's have th absolute recipe for these drivers to work.. Let me know.. It's rare.. But this time I'm really stuck!

Cheers
20th April 2019, 12:20 AM |#41  
Junior Member
Thanks Meter: 0
 
More
Can anyone tell is there any improvements in terms of photo and video quality in 20190412 firmware compared to the 20190404 or they just fixed some bugs in the camera app?
Post Reply Subscribe to Thread

Tags
umidigi-s3-pro

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes