FORUMS
Remove All Ads from XDA

UMIDIGI S3 Pro

1,473 posts
Thanks Meter: 1,130
 
By ghost45, Senior Member on 13th March 2019, 09:22 AM
Post Reply Email Thread
13th August 2019, 05:03 PM |#391  
Senior Member
Thanks Meter: 42
 
More
Quote:
Originally Posted by Paulicat

I can confirm Omni does not work with our devices sim cards.
I flashed Omni just to see what its like and it reports no imeis...flash phhusson aosp and imeis were fine so its an Omni specific issue.

Seriosuly, you've got us trying to fix it for you just to run omni!!
For windows 10 try disabling driver signature verification and install the drivers
 
 
13th August 2019, 06:03 PM |#392  
Senior Member
Flag Paris
Thanks Meter: 312
 
More
Quote:
Originally Posted by Nickthegr8

Seriosuly, you've got us trying to fix it for you just to run omni!!
For windows 10 try disabling driver signature verification and install the drivers

Thank you for this enlightened comment. Omni was just a ROM that I tried because I had a good experience with it on a previous device.

If you read carefully my previous posts I mentioned already that I tried many different drivers and that each time the outcome was negative.

My sincere thanks @Paulicat, I did flash Havok and the SIM card was recognized. Phone/Data work seamlessly. However the IMEI information is still not displayed in the settings, I don't know why.

I will keep looking for my ROM of choice. Thank you for your help.

P.S. Tethering works fine on Havoc.
13th August 2019, 10:55 PM |#393  
Senior Member
Thanks Meter: 882
 
More
One issue I'm having is flashing opengapps (any version) on lineage (or any rom without gapps included) gsi latest build.
Everything flashes fine but no gapps.
So I checked in adb shell and instead of gapps installing to /system/system/priv-app they are being installed to /system/priv-app which is not the right folder.
I don't know the technical reason we have /system/system/ but we do, and I know other phones have it too, maybe its an A+B thing I don't know.
I don't think it's a lineage problem because the same thing happened in Omni.
And I can't seem to use magicgapps on this phone, always an error during module install in twrp.
Any suggestions on how to get gapps onto gsi roms without gapps built in?

Ok I asked in the lineage gsi thread and got the right answer.
Backstory...when I first tried gsi roms I was using the original rom that came with the phone. I didn't update at all.
I had no issue installing gsi and flashing gapps.
After some days I decided to update to the very latest umidigi rom to make sure I had up to date kernel/vendor etc.
Seems the latest boot.img removed a critical piece of info for gapps to install correctly.
There is supposed to be a kernel parameter "slot_suffix" that must have been removed from the latest boot.img.
Two choices to get around this problem.
One, flash old boot.img (assuming the parameter is in there which I know it must be because I flashed lineage and gapps without issue before updating)
Two, modify opengapps installer.sh to force it to go to the right system as root layout.

I modified the gapps as recommended from the lineage gsi thread:

Make the edit to installer.sd as follows:
# Detect A/B partition layout https://source.android.com/devices/tech/ota/ab_updates
# and system-as-root https://source.android.com/devices/b...system-as-root
#if [ -n "$(cat /proc/cmdline | grep slot_suffix)" ];
#then
device_abpartition=true
SYSTEM_MOUNT=/system
SYSTEM=$SYSTEM_MOUNT/system
VENDOR=/vendor/vendor
#elif [ -n "$(cat /etc/fstab | grep /system_root)" ];
#then
# device_abpartition=false
# SYSTEM_MOUNT=/system_root
# SYSTEM=$SYSTEM_MOUNT/system
# VENDOR=/vendor
#else
# device_abpartition=false
# SYSTEM_MOUNT=/system
# SYSTEM=$SYSTEM_MOUNT
# VENDOR=/vendor
#fi
14th August 2019, 12:27 AM |#394  
Senior Member
Thanks Meter: 882
 
More
One last thing I found.
This google camera app is old but it actually supports the full 48mp.
The pictures come out quite nice, no telephoto zoom support though.
This is not my work and I stumbled on it googling like crazy and cannot find the original thread.
I believe it was initially buried in a miui forum.
<edit>Found original source</edit>
http://en.miui.com/thread-4956713-1-1.html
I'm on latest lineage gsi right now and it's going very good so far.
On latest lineage google camera installs straight from play store, however it only sees 4.9mp as max...if we could get one of those gcam apk modder guys here!
https://www.androidfilehost.com/?fid...31924117936183
14th August 2019, 08:22 AM |#395  
Junior Member
Thanks Meter: 0
 
More
I have found this (works with 48MP, no zoom 2x)
Google Camera 2.7.008
https://www.apkmirror.com/apk/google...-apk-download/
14th August 2019, 06:32 PM |#396  
Junior Member
Thanks Meter: 0
 
More
@Paulicat

Do you use ARM64-AONLY or ARM64-AB?
Thanks
14th August 2019, 07:00 PM |#397  
Senior Member
Thanks Meter: 882
 
More
ARM64 AB
15th August 2019, 06:57 PM |#398  
Junior Member
Thanks Meter: 1
 
More
I use "One S10Camera style" from the Google Playstore, works great!
16th August 2019, 08:06 PM |#399  
stazz83's Avatar
Senior Member
Thanks Meter: 41
 
More
Has anyone managed to capture what's new in the 20190816-1750 update? My phone started updating before I managed to read the changelog...

Edit: Umidigi has published it on their FB page. Here it is.

Sent from my S3_Pro using Tapatalk
Attachment 4807236
16th August 2019, 09:44 PM |#400  
Junior Member
Thanks Meter: 1
 
More
I installed the august update too, and what i have read on russian forum is that they combined the two cameras from the former update to one, so now you have one camera app.
the have seemed to have fixed the screen freeze issue ( i never had any trouble with this ) and fixed NFC
and they added cellbroadcast app.
The Following User Says Thank You to Amiga1000 For This Useful Post: [ View ] Gift Amiga1000 Ad-Free
16th August 2019, 09:52 PM |#401  
MikeyLee's Avatar
Senior Member
Flag Phoenix
Thanks Meter: 637
 
More
Has anyone manually updated to the latest update while having your bootloader unlocked?
Post Reply Subscribe to Thread

Tags
umidigi-s3-pro

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes