FORUMS
Remove All Ads from XDA

UMX U683CL Root Tutorial

89 posts
Thanks Meter: 33
 
By sc0rp1, Member on 20th November 2019, 09:58 PM
Post Reply Email Thread
22nd November 2019, 08:00 PM |#21  
Junior Member
Thanks Meter: 0
 
More
Info
Quote:
Originally Posted by sc0rp1

i'd be happy to help if you'd like. PM me

Sorry disregard looks like XDA is doing weird crap for me today loaded a scrambled page
22nd November 2019, 08:03 PM |#22  
OP Member
Thanks Meter: 33
 
Donate to Me
More
Glad you corrected it.
The Following User Says Thank You to sc0rp1 For This Useful Post: [ View ] Gift sc0rp1 Ad-Free
22nd November 2019, 09:06 PM |#23  
OP Member
Thanks Meter: 33
 
Donate to Me
More
Quote:
Originally Posted by poisonliverpool

Any idea why it might fail on that step? The log gives this error result (timestamps edited out):

ERROR: function: sahara_rx_data:237 Unable to read packet header. Only read 0 bytes.
ERROR: function: sahara_main:924 Sahara protocol error
ERROR: function: main:303 Uploading Image using Sahara protocol failed
Download Fail:Sahara Fail:QSaharaServer Fail:Process fail
Finish Get GPT

Install QPTS and run Qfil from start menu. It should fix the problem.
The Following User Says Thank You to sc0rp1 For This Useful Post: [ View ] Gift sc0rp1 Ad-Free
22nd November 2019, 09:07 PM |#24  
OP Member
Thanks Meter: 33
 
Donate to Me
More
Quote:
Originally Posted by X--Force

You are absolutely fkng awesome! Thank you so much for everything!

Install QPTS and run Qfil from start menu. It should fix the problem.
The Following User Says Thank You to sc0rp1 For This Useful Post: [ View ] Gift sc0rp1 Ad-Free
22nd November 2019, 11:07 PM |#25  
Junior Member
Thanks Meter: 1
 
More
I finally found my answer for my "Qsaharaserver fail." error message and it was such /facepalm moment. Make sure that you have Qfil loaded and ready to go so that you can hit Partition Manager IMMEDIATELY after you type "adb reboot edl". The phone only gives you a few seconds before it shuts off entirely.
The Following User Says Thank You to Sorrow Heart For This Useful Post: [ View ] Gift Sorrow Heart Ad-Free
23rd November 2019, 12:23 AM |#26  
Junior Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by sc0rp1

Install QPTS and run Qfil from start menu. It should fix the problem.

Progress! I had to download 5 different versions of QPTS from at least three different sites before I found one which worked (several wouldn't even complete installation, one of them had the same problem as the earlier Qfil), but I got it to work as instructed!

Unfortunately after following the next steps in your original instructions, leading to the phone restarting, it got stuck in what I guess is a bootloader loop (never seen one before), restarting every few seconds, as long as I left the USB plugged in; once I unplugged it, it goes to the second bootup screen (the one with a starry background) and stays there. When restarted (manually) it does that again--it does start the booting process and go through the first screen to the second, but it never ever moves on past the second.

Still, this is definite progress! Any ideas for next steps?

---------- Post added at 06:23 PM ---------- Previous post was at 06:21 PM ----------

Quote:
Originally Posted by Sorrow Heart

I finally found my answer for my "Qsaharaserver fail." error message and it was such /facepalm moment. Make sure that you have Qfil loaded and ready to go so that you can hit Partition Manager IMMEDIATELY after you type "adb reboot edl". The phone only gives you a few seconds before it shuts off entirely.

Glad that worked for you, but FWIW I was doing that all along and still getting the sahara error, so it doesn't fix the problem for everyone. However in my case, using the QPTS version of Qfil (trying out several until I found one that worked), per sc0rp1's additional instructions, did finally overcome the sahara problem.
The Following User Says Thank You to poisonliverpool For This Useful Post: [ View ] Gift poisonliverpool Ad-Free
23rd November 2019, 12:24 AM |#27  
OP Member
Thanks Meter: 33
 
Donate to Me
More
Quote:
Originally Posted by poisonliverpool

Progress! I had to download 5 different versions of QPTS from at least three different sites before I found one which worked (several wouldn't even complete installation, one of them had the same problem as the earlier Qfil), but I got it to work as instructed!

Unfortunately after following the next steps in your original instructions, leading to the phone restarting, it got stuck in what I guess is a bootloader loop (never seen one before), restarting every few seconds, as long as I left the USB plugged in; once I unplugged it, it goes to the second bootup screen (the one with a starry background) and stays there. When restarted (manually) it does that again--it does start the booting process and go through the first screen to the second, but it never ever moves on past the second.

Still, this is definite progress! Any ideas for next steps?

Flash stock boot that I provided. Boot phone to make sure it works. Reboot to edl. Follow the new instructions to flash twrp instead. Then in twrp flash magisk.zip. reboot to system. Download and install magisk manager. Enjoy
The Following User Says Thank You to sc0rp1 For This Useful Post: [ View ] Gift sc0rp1 Ad-Free
23rd November 2019, 01:54 AM |#28  
Junior Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by sc0rp1

Flash stock boot that I provided. Boot phone to make sure it works. Reboot to edl. Follow the new instructions to flash twrp instead. Then in twrp flash magisk.zip. reboot to system. Download and install magisk manager. Enjoy

Ok, it's still getting stuck on the second screen (stars background). FWIW, I installed your TWRP image in the recovery partiton, and that's working fine; can I use it to install the rooted boot? (Or even just successfully reinstall the stock boot?)
23rd November 2019, 02:34 AM |#29  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by sc0rp1

You're very welcome. Please let me know your android version if you have higher than 8.1.0 or did the recent OTA update so i can update my patched boot image.

Flashed your stock boot with QFIL, but still getting stuck at splash during boot.
23rd November 2019, 03:38 AM |#30  
OP Member
Thanks Meter: 33
 
Donate to Me
More
Quote:
Originally Posted by geniusx000

Flashed your stock boot with QFIL, but still getting stuck at splash during boot.

Was your phone on 8.1 or was it higher? Did you recently update the phone?
23rd November 2019, 03:40 AM |#31  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by sc0rp1

Was your phone on 8.1 or was it higher? Did you recently update the phone?

8.1.0 with the Oct 2019 security patch.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes