Remove All Ads from XDA

[Q] Alcatel OneTouch Evolve will not boot past the T-Mobile screen :c

1 posts
Thanks Meter: 0
By acklesbae_, Junior Member on 20th August 2014, 04:26 AM
Post Reply Email Thread
Last night my Alcatel OneTouch Evolve was working perfectly fine and I was sitting on my bed, playing on it like usual until I got sleepy enough to lay down but when I went to change out the battery (I have an older phone, the exact same kind, that still charges so I use the battery in it as an extra) and when I booted it up (or tried to) it got stuck on the white T-Mobile screen. I've tried take out the battery and booting into recovery and then hard reset it, but it still gets stuck. I was beginning to think I bricked it by rooting it but it's rooted since a week or so after I first got the phone (which was 3-4 months ago) so if that's the case, why would it act up so late? Thanks for any help and suggestions, I tried hard reset again but it did the same thing and it's been that way for 4 hours.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes