FORUMS
Remove All Ads from XDA

Android (LG G6) won't connect as MTP to Macos (as ADB it does)

30 posts
Thanks Meter: 3
 
By Shynepo, Member on 14th February 2020, 10:53 AM
Post Reply Email Thread
Hello everyone,
a) My guess is, it might a problem with the drivers. I installed some LG programes earlier, already deinstalled it... But, Maybe you know better how to renew the Android drivers on the Mac and get rid off the stuff which probably blocks me from having the file transfer function again.

b) do you know at least any other (free) Programe that uses ADB to connect the phone to Mac?

c) something I have not thought of... You tell me



Once it was possible to connect the phone to my Mac and transfer files with Android File Transfer. Now it is not. I tried several other programmes, none can connect to the phone via MTP (for file transfer).
When I chose not "data transfer" but "photo transfer" as an option in the phone, the Photo app on Mac opens and I could trnasfer photos - so it works!
But I need file transfer....

I have and try several cables. Phone works without any problems with windows.

The only thing works now for transfering files via cable is MacDroid, which can connect the phone via ADB insetad of MTP. --> Problem: it costs money (and why should it now work in MTP in the first place).
The phone generally is found by the computer:
Click image for larger version

Name:	Screenshot 2020-02-14 13.34.21.png
Views:	6
Size:	162.8 KB
ID:	4950209

I use as OS "El Capitan". On the phone Android 9.0. Phone LG G6

Thank you!

PS: The phone even asks me if I want the Mac to authorize:
Click image for larger version

Name:	debug.png
Views:	4
Size:	118.3 KB
ID:	4950243

PS2: Macdroid works with the phone even in MTP Mode when Debugging is deactivated. So what is this... I do not get it.
Yesterday, 02:18 PM |#2  
OP Member
Thanks Meter: 3
 
More
Guys, girls, anybody, please give me a hint, think with me, tell me where to look for answers ...
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes