FORUMS

DKB-TAN2go app on rooted device

63 posts
Thanks Meter: 7
 
By scarline, Member on 29th August 2018, 01:15 PM
Post Reply Email Thread
On Angler (Nexus 6p) I flashed the latest stock rom. (After a complete wipe) Afterwards I flashed TWRP and unzipped Magsik. Subsequently I did update to the latest version. After that I changed the packagename of Magsik manager. Furthermore I installed Xposed framework. Afterwards I enabled root hide for the TAN app:
https://play.google.com/store/apps/d...bpushtan&hl=en
This software is meant to give you the tan without using sms services.

Still, the app crashed right at the start without any error notification. Android Version is 8.1 and Magsik is v16. While I did the test, the bootloader was unlocked and TWRP was still the recovery. Can these two things affect the verification of the Banking app? I tried this several times ago in the past, but I was never to make this app running.
If anyone would be able to give helpful advice here, it would be very much appreciated.

Best,
scarline
6th September 2018, 09:37 PM |#2  
Member
Thanks Meter: 7
 
More
I have heard that DKB Tan2Go does not work with newer Android versions like Oreo 8.1.x at all.
I can also confirm that. I tried it on a Sony cellphone. The cellphone was not rooted and with a completely new and 'clean' ROM. It was to no avail.

A friend has been forced to buy a chip reader. I am fortunate to be able to use normal TAN lists at the moment. If the DKB tries to exclude me from online banking, I will change the bank.

DKB Tan2Go seems to be one of the worst and most insecure apps ever. The reviews in Google PlayStore confirm this conclusion.

Maybe there will be a solution someday?
4th November 2018, 05:56 PM |#3  
Member
Thanks Meter: 10
 
More
DKB TAN2go works with Magisk:
1. Install the TAN2go app (but don't open it)
2. Add the TAN2go app in Magsik Manager in the menu "Magisk Hide"
3. Reboot the phone (I don't know if this is necessary)
4. Open TAN2go, works fine.

**** DKB and this stupid security features which bring absoltuely no security.
6th November 2018, 12:25 AM |#4  
Member
Thanks Meter: 7
 
More
That's exactly what I tried - without success. I read that it only worked with an old, obsolete version of Tan2Go. However, I could not find this version and I'm not sure if it still works at all. Did you have the latest version of Tan2Go from Google PlayStore? According to DKB, the recent Tan2Go does not work with devices that was once rooted or had a CustomROM. Even if you go back to stock the Root Counter changed and DKB Tan2Go will never work on this device. Unfortunately, I have to confirm that.

I am working on it to change the bank, because of that.

Quote:
Originally Posted by exaveal

DKB TAN2go works with Magisk:
**** DKB and this stupid security features which bring absoltuely no security.

Indeed!
6th November 2018, 04:27 PM |#5  
Member
Thanks Meter: 10
 
More
Yes, I have installed the latests version of LineageOS, latest version von Magisk and the latests version of the TAN2go app.
8th November 2018, 09:04 AM |#6  
Member
Thanks Meter: 7
 
More
I tried that to no avail. I heard once the root counter has a value other than 0, one can't go back. Probably it is also the Sony bootloader and it is different with other devices?


Quote:
Originally Posted by exaveal

Yes, I have installed the latests version of LineageOS, latest version von Magisk and the latests version of the TAN2go app.

11th December 2018, 07:06 AM |#7  
GorgiGR's Avatar
Junior Member
Flag Stuttgart
Thanks Meter: 1
 
More
I have a Xiomi Mi5 rooted with Magisk and Tan2go used to work for the last year or so. But yesterday I tried to make a transaction and BOOM! App crashed without an error message. Tried to use a newer Magisk, tried reinstalling the App, nothing helped.
The worst thing is that I do not know if some of my programs have a battery checker or a screen reader plugin that I am not aware of, or if Tan2Go suddenly detects my root. Regardless, crashing without an explanation is like the worst programming practice ever.
Since I do not need this kind of shite in my life I will probably change Bank, I mean what good is an internet Bank if you cannot do transactions over your mobile device?
16th December 2018, 08:44 PM |#8  
Member
Thanks Meter: 7
 
More
Well, willy-nilly I try to use the only other option from DKB: the German TAN Generator. Every other bank equips you with such a device, if they want you to use it. The DKB does not. Actually, I ordered the 3rd TAN Generator and fully paid for it. The first one drains the battery within days. The second one let me type in all the numbers and for no reason the TAN code does not show up on display.
These devices are very annoying anyway, because you have to type in a lot of numbers for every money transfer, the characters are very small (on the laptop) and you have to carry the TAN Generator + the DKB debitcard all the time. Of course this is less secure.
I would change the bank immediately, but want to keep the Visa credit card. I have higher limits on it. That's the only reason. As soon as I found an alternative bank in Europe, I will leave the DKB for good.
28th March 2019, 08:47 PM |#9  
Junior Member
Thanks Meter: 3
 
More
It dont worked with Lineage 14.1 but with 15.1 unoffical build on Samsung S4 together with latest Magisk .Rom from here
https://www.cyanogenmods.org/forums/...roid-8-1-oreo/
15th April 2019, 10:37 PM |#10  
Junior Member
Thanks Meter: 0
 
More
Works for me
Just tried again. It hasn't been working for me in the past. When downloading & opening the app, I had the same problems.
Then I simply followed the above advice: downloading the app again, didn't open it, hide with Magisk, reboot and opened the app - worked well and was able to register for tan2go.
I am using Lineage 16.0 and Magisk v18.0
16th April 2019, 08:08 PM |#11  
Junior Member
Thanks Meter: 0
 
More
DKB already updated their app - they patched it
Quote:
Originally Posted by kyodhin

Just tried again. It hasn't been working for me in the past. When downloading & opening the app, I had the same problems.
Then I simply followed the above advice: downloading the app again, didn't open it, hide with Magisk, reboot and opened the app - worked well and was able to register for tan2go.
I am using Lineage 16.0 and Magisk v18.0

The app version from September (version 2.3.0) does work, the newer app version from 4.4.19 (version 2.4.0) does not...

Tested working combination: Magisk 18.0, Magisk Manager 6.1, DKB version 2.3.0
Post Reply Subscribe to Thread

Tags
banking, magisk 16, rooting, twrp

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes