FORUMS

Error in format+flashing ROM through SP Flash Tools, ended up with a bricked phone

8 posts
Thanks Meter: 0
 
By chiyarlz, Junior Member on 18th July 2018, 10:39 AM
Post Reply Email Thread
Hello!

My phone, Acer Liquid Z630s, recently had a problem and ended up shutting off as soon as it boots up. I turn it on, the Acer powered by Android white screen shows up then immediately shuts off. What was the problem here?

I couldn't access recovery mode either because it would also show up the same thing above then shut off immediately before it can even reach the recovery mode menu. But I could plug it in directly into download mode through SP Flash Tools because the phone vibrates when I hold down the volume up + power buttons (aka the recovery mode combination which was I think also the download mode combination). I downloaded the correct stock ROM off the Acer website (MT6753) and flashed it. The ROM was successfully flashed. But when I turned it on the screen lit up but it was just a blank black screen. It was lit up, but it was just dark black. I tried to wipe the system and flash the ROM again and at the end of the process, an error message appeared and I looked up the error code and this was exactly it:

"Error 6104

Message: BROM ERROR: S_SECURITY_SECURE_USB_DL_DA_RETURN_INVALID_TYPE (6104), MSP ERROR CODE : 0X00

Meaning: Wrong flash settings or firmware

Solution:
Ensure you set the correct Download-Agent in SP flash tool and are using a firmware for your exact model
Go to Options > Option > Connection > USB Speed > Full Speed
Go to Options > Option > Download > Untick DA DL All with Checksum"

I did what the solution told me, and as I tried to flash the ROM again, but I couldn't turn on my phone anymore. The volume up + power button combination no longer produces a vibration, and when I plug it into my computer it gets detected as a MediaTek USB Port (COM6) but SP Flash Tools no longer detects my phone and gives off this error:

"Error 0x13BE

Message: S_DL_GET_DRAM_SETTING_FAIL (0x13BE)

Meaning: The firmware you're trying to flash is either not compatible with your device or you have selected the wrong flashing settings

Solution:
Ensure that the file(s) you're trying to flash are actually for your exact phone model
Ensure you tick the boxes for only the files present in the ROM you're about to flash"

I don't know what to do at this point. Is it beyond salvation? But my phone still gets detected by my computer and it still produces the sound when you connect a device through the USB ports. Help me please.

Thank you in advance.
18th July 2018, 10:34 PM |#2  
Senior Member
Thanks Meter: 171
 
More
Hi , flash this firmware and in Sp Flash Tool set to Download only !!! When you Do Format + Download you lose your imei !
https://drive.google.com/uc?id=12Cdm...xport=download
23rd May 2020, 10:32 PM |#3  
lexpizarro's Avatar
Junior Member
Flag Las PiƱas City
Thanks Meter: 0
 
More
Quote:
Originally Posted by Teddy Lo

Hi , flash this firmware and in Sp Flash Tool set to Download only !!! When you Do Format + Download you lose your imei !
https://drive.google.com/uc?id=12Cdm...xport=download

Hi there Teddy. Maybe you could help me. I was actually trying to make use of the same thing. SPFT. i flashed the stock rom. i tried rebooting it. seems that it has been bricked. I am using Starmobile Up Prime.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes