FORUMS
Remove All Ads from XDA

Super Mario Run on Android Devices that are Rooted

155 posts
Thanks Meter: 26
 
By CyanogenLover, Senior Member on 23rd March 2017, 09:33 AM
Post Reply Email Thread
This is a starter thread for getting Nintendo's latest Android app (which has finally come from iOS over three months later), Super Mario Run, to work on Android devices that have been rooted. Developers, please contribute your findings!

FOR THOSE WHO DO NOT HAVE GOOGLE PLAY, PLEASE POST YOUR FINDINGS! I am desperately trying (in vain) to get Super Mario Run working on a device without Google Play. If any of you do not have Google Play, or have Google Play and want to sever ties between it and Super Mario Run, please tell us what you did!
 
 
23rd March 2017, 09:37 AM |#2  
CyanogenLover's Avatar
OP Senior Member
Thanks Meter: 26
 
More
Reserved for future info.
23rd March 2017, 10:21 AM |#3  
OmegaBowser's Avatar
Junior Member
Flag Toulouse
Thanks Meter: 2
 
More
Does this even work with manual installation (apk) ? Or is it blocked at startup ? (I guess it is, since I couldn't play Miitomo when first launched...)
23rd March 2017, 11:45 AM |#4  
Junior Member
Thanks Meter: 5
 
More
It is blocked at startup.. maybe with suhide? Anyone?
23rd March 2017, 11:48 AM |#5  
Senior Member
Thanks Meter: 77
 
More
On my rooted Galaxy S5 with stock Android it works without problems from apkmirror (it is incompatible on play store).
Update:
Now it doesn't work anymore. Error 804-5100 at start...
The Following User Says Thank You to rogxd For This Useful Post: [ View ] Gift rogxd Ad-Free
23rd March 2017, 12:00 PM |#6  
Junior Member
Flag Gatineau
Thanks Meter: 8
 
More
For me, it works for the first 5minutes and it crashes. Tried to hide using magisk and Rootcloak, but same problem after 5-10 minutes.
23rd March 2017, 12:47 PM |#7  
Junior Member
Thanks Meter: 14
 
More
The game immediately exits on my OnePlus One running Lineage OS.

My device is not rooted, is certified according to the Play Store and a SafetyNet test passes. How is this even possible?
The Following 3 Users Say Thank You to headsh0t95 For This Useful Post: [ View ] Gift headsh0t95 Ad-Free
23rd March 2017, 03:40 PM |#8  
Senior Member
Flag Kansas City
Thanks Meter: 155
 
More
Quote:
Originally Posted by headsh0t95

The game immediately exits on my OnePlus One running Lineage OS.

My device is not rooted, is certified according to the Play Store and a SafetyNet test passes. How is this even possible?

I'm running Resurrection Remix (based on LOS) on Axon 7 -- rooted, passing SafetyNet, magisk-hide enabled for the app, still immediately exits just like you.
23rd March 2017, 04:20 PM |#9  
Junior Member
Thanks Meter: 0
 
More
Doesnt run on my rooted Huawei Honor X5 (kiwi) with lineageos, tried to cloak the root - crashed all the time. after this i unrooted the phone, but it didnt work either ...
23rd March 2017, 04:45 PM |#10  
Junior Member
Thanks Meter: 5
 
More
I tried everything listed here and nothing work.. Uninstalled the magisk, unroot, installing Super Mario from the Play Store, doesn't work either... I'm using a Moto Z Play with custom LineageOs
23rd March 2017, 05:04 PM |#11  
Balashe's Avatar
Junior Member
Thanks Meter: 2
 
More
OnePlus 3T
Last version of NucleaROM and his kernel (Custom ROM)
Rooted (Tried without root too)
Doesn't work
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes