Remove All Ads from XDA
Honor 9 Lite

"Ok, Google" killed

1,975 posts
Thanks Meter: 573
By Artim_96, XDA Ad-Free Senior Member on 4th August 2014, 11:50 AM
Post Reply Email Thread
Here my problem: a few weeks ago Commandr was introduced here on xda. I've tested it and everything just worked fine. Then, the developer made an update so you don't have to use "Note to Self" anymore with using Androids Accessibility option...this broke the "Ok, Google" feature. It seems that it's not easy to repair that.
First, I turned the Accessibility option out, uninstalled Commandr, set Google Search back to factory version - it was just not working. The option was still in the menue of the Search app, but it was not shown nor just even in the App and in the Search widget (Nova Launcher, "Ok, Goolge" turned on). So I've made a complete backup of everything (with Titanium, except Search and Commandr, then coppied the internal memory to computer, at least /storage/emulated/0), whiped everything with TWRP and installed latest firmware (LG G2, D80220f). After installing "Ok, Google" worked just fine again, what I expected. So I started restoring. I started with internal storage, so there was no app restored and I stopped PlayStore when it wanted to restore my apps. I had not restored everything from internal storage, only this part, restarted the system for the first time...and "Ok, Google" was just broken again
So I think there has to be something in these folders that stops the Google Search working, but I have no idea what that can be. For testing I erased /Android/data/ because I thought there is something that stopped the Search from using the microphone. Nothing changed.
But it's interesting, that sometimes when I quit the Search, the microphone in the Search Widget turns black for a moment as if it would work again, but it doesn't. In the debug settings of the app (opened with Unleash the Google) in the config flags under hotword_supported_locales, de-DE is listed, so I should be able to use it because this locale is which I need and have.

Does anybody knows help?
3rd September 2014, 08:12 PM |#2  
OP Senior Member
Thanks Meter: 573
Interesting. Went back to D80220D, "Ok, Google..." just working fine. Reinstalling Commandr, same problem. Thankfully I hade an TWRP-backup.

Any idea to this behaviour?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes