FORUMS
Remove All Ads from XDA

[Q&A] [GAPPS][2015-06-01] Open GApps for Android 5.1, 5.0, 4.4

n/a posts
Thanks Meter: 0
 
By QA Bot, Guest on 1st June 2015, 04:00 PM
Post Reply Email Thread
11th September 2015, 03:40 PM |#101  
Recognized Developer
Flag The Hague
Thanks Meter: 2,228
 
Donate to Me
More
Quote:
Originally Posted by adrman

@MastahF Is there any chance of including Google Connectivity Services in one of the packages? Project Fi wants to see GCS as a system app. I know Fi users are probably a pretty small percentage of the general community, but thought I'd inquire anyway. Thanks.

Hi, I am very interested in your findings about GCS requiring to be on /system/.
Could you post your results/findings and arguments in this issue: https://github.com/opengapps/opengapps/issues/5
Then we can discuss the technical details about this and decide if we can include it in some way
The Following User Says Thank You to MastahF For This Useful Post: [ View ]
 
 
11th September 2015, 06:22 PM |#102  
adrman's Avatar
Senior Member
Flag NYC
Thanks Meter: 623
 
More
Quote:
Originally Posted by MastahF

Hi, I am very interested in your findings about GCS requiring to be on /system/.
Could you post your results/findings and arguments in this issue: https://github.com/opengapps/opengapps/issues/5
Then we can discuss the technical details about this and decide if we can include it in some way

Just posted the same to github. Speak to you there.
13th September 2015, 09:53 AM |#103  
Romano2K's Avatar
Member
Flag Paris
Thanks Meter: 0
 
More
Hello!

Sorry for the delay, I've been on vacations.

Quote:
Originally Posted by MastahF

It sounds like really weird behaviour, if pico flashes fine, and stock doesn't and you are sure that the downloaded ZIP file is not corrupt, and you get that error, best would be to approach the TWRP maintainer of your device.

I haven't contacted the TWRP maintainer, but I switched to CWM and I've been able to flash the stock ZIP with its config file flawlessly.

I was happy after flashing and disabling your updater (see the screenshot).

Quote:
Originally Posted by MastahF

To get the name to be used by the universal remover: use a file-manager on your Android devices, navigate to /system/app (or sometimes /system/priv-app) and look at the foldername that the APK you'd like to remove resides in. Use this foldername as the keyword between the ( and ).

OK, thank you!
Attached Thumbnails
Click image for larger version

Name:	CyanogenMod 12.0 sur HP TouchPad.png
Views:	174
Size:	192.9 KB
ID:	3472083  
14th September 2015, 12:02 AM |#104  
Member
Flag Chieri
Thanks Meter: 13
 
More
@MastahF how can I do the things you said??
15th September 2015, 05:01 AM |#105  
Junior Member
Flag Seoul
Thanks Meter: 10
 
More
I installed Open gaps pico version. but there is no google play.
My device is Atrix 4G. and android version 4.4.4

I installed Open gaps pico version(2015-09-14).
But there is no google play.
later I also installed Open gaps nano version(2015-09-14).
But It's Installed anything.

I tried three times.

Here is log and log file. http://fehead.linuxstudy.pe.kr/open_...ug_logs.tar.gz

=============================
# Begin Open GApps Install Log
-----------------------------------------------------------------------------
ROM Android Version | 4.4.4
ROM ID | cm_olympus-userdebug 4.4.4 KTU84Q 10f9605efb test-keys
ROM Version | 11-20150825-UNOFFICIAL-olympus
Device Recovery | CWM-based Recovery 6.0.5.1
Using Bundled XZdec | true
Device Name | olympus
Device Model | MB860
Device Type | phone
Device CPU | armeabi-v7a
getprop Density | 240
default.prop Density | 240
build.prop Density | 240
Display Density Used | 240dpi
Install Type | Dirty[Data NOT Wiped]
Google Camera Installed¹ | false
Google Keyboard Installed¹ | false
FaceUnlock Compatible | true
Google Camera Compatible | true
Current GApps Version | No GApps Installed
Installing GApps Version | 20150914
Installing GApps Type | pico
Config Type | [Default]
Using gapps-config | Not Used
Remove Stock/AOSP Browser | false[NO_Chrome]
Remove Stock/AOSP Clock |
Remove Stock/AOSP Email | false[NO_Gmail]
Remove Stock/AOSP Gallery | false[NO_Photos]
Remove Stock/AOSP Launcher | false[NO_GoogleNow]
Remove Stock/AOSP MMS App | false[NO_Hangouts]
Remove Stock/AOSP Pico TTS | false[NO_GoogleTTS]
Remove Stock/AOSP NFC Tag |
Remove Stock/AOSP WebView |
Total System Size (KB) | 1094564
Used System Space (KB) | 385352
Current Free Space (KB) | 709212
Post Install Free Space (KB) | 632380 << See Calculations Below
-----------------------------------------------------------------------------
¹ Previously installed with Open GApps
# End Open GApps Install Log

# Begin GApps Size Calculations
-----------------------------------------------------------------------------
TYPE | DESCRIPTION | SIZE | TOTAL
| Current Free Space | 709212 | 709212
Remove | Existing GApps | + 0 | 709212
Remove | Obsolete Files | + 8 | 709220
Install | Core² | - 66384 | 642836
Install | calsync³ | - 1240 | 641596
| Buffer Space² | - 9216 | 632380
-----------------------------------------------------------------------------
Post Install Free Space | 632380
-----------------------------------------------------------------------------
² Required (ALWAYS Installed)
³ Optional (may be removed)

# End GApps Size Calculations

# Begin User's gapps-config
*** NOT USED ***
# End User's gapps-config
=============================
15th September 2015, 08:17 AM |#106  
Recognized Developer
Flag The Hague
Thanks Meter: 2,228
 
Donate to Me
More
Quote:
Originally Posted by fehead

My device is Atrix 4G. and android version 4.4.4

I installed Open gaps pico version(2015-09-14).
But there is no google play.
later I also installed Open gaps nano version(2015-09-14).
But It's Installed anything.

I tried three times.

Here is log and log file. http://fehead.linuxstudy.pe.kr/open_...ug_logs.tar.gz

I check the log and our recovery is (next to being officially unsupported) seriously outdated. Which is very probably the reason why the 'tar' command in you recovery is broken, because when the scripts call 'tar' it always receies the error
Code:
tar: short read
Illegal instruction
which results in not being able to extract the data from the compressed archives.

So please update your recovery, preferably to TWRP, and next time please read article #1 in the FAQ ( https://github.com/opengapps/opengap...i-do-to-fix-it ) because it resolves 99% of the problems.

---------- Post added at 09:17 ---------- Previous post was at 09:12 ----------

Quote:
Originally Posted by Andy31233

@MastahF how can I do the things you said??

About the Open GApps debug log, read the FAQ: https://github.com/opengapps/opengap...eed-to-help-me
About getting a logcat: Logcat on Android (there are many tutorials available)
The Following User Says Thank You to MastahF For This Useful Post: [ View ]
19th September 2015, 02:59 AM |#107  
Junior Member
Thanks Meter: 1
 
More
Installation Failed
Hi, I really appreciate to have open gapps website, because it updates everyday. When I tried to update my cm 12.1 nightly on my moto e, the gapps installation failed. It says error code 70, and I don't know what to do. I haven't update my gapps for like 2 months, so I really need help. Thank You
19th September 2015, 09:58 AM |#108  
Recognized Developer
Flag The Hague
Thanks Meter: 2,228
 
Donate to Me
More
Quote:
Originally Posted by HongJie Lin

Hi, I really appreciate to have open gapps website, because it updates everyday. When I tried to update my cm 12.1 nightly on my moto e, the gapps installation failed. It says error code 70, and I don't know what to do. I haven't update my gapps for like 2 months, so I really need help. Thank You

Error 70 means that there is not enough space on /system/. Take look at the installation log to see the diskspace calculations.
You can use a gapps-config file to exclude some applications from installing on /system/ to reduce the installation size. Check the wiki (and the forums) for details how to do this: https://github.com/opengapps/opengap...ps-config-file
29th September 2015, 04:33 AM |#109  
Junior Member
Thanks Meter: 0
 
More
Question from a new OnePlus One owner who hadn't played around with custom ROMs only other devices (because I'm paranoid about violating the warranty on everything else but OnePlus put a more flexible warranty in place). Any time I've tried installing GApps on a custom ROM so far (I've tried Sultan's CM12.1 and Exodus), Hangouts wouldn't work properly. It would handle SMS fine, but it would never receive new messages from Hangouts/GChat. Installing a more bare version of GApps when I flashed and then installing Hangouts from the Google Play Store instead worked fine.

Is there any kind of known issue here? A fix I should be aware of so I can just make life easier and install a full GApps package the next time I need to?

Thanks!
29th September 2015, 08:57 PM |#110  
Junior Member
Thanks Meter: 0
 
More
So i have twrp and tried to install gapps but when i go into the install wich apps (AROMA) i cant use the touch screen.
How do i fix
1st October 2015, 12:40 PM |#111  
Recognized Developer
Flag The Hague
Thanks Meter: 2,228
 
Donate to Me
More
Quote:
Originally Posted by davidbix

Question from a new OnePlus One owner who hadn't played around with custom ROMs only other devices (because I'm paranoid about violating the warranty on everything else but OnePlus put a more flexible warranty in place). Any time I've tried installing GApps on a custom ROM so far (I've tried Sultan's CM12.1 and Exodus), Hangouts wouldn't work properly. It would handle SMS fine, but it would never receive new messages from Hangouts/GChat. Installing a more bare version of GApps when I flashed and then installing Hangouts from the Google Play Store instead worked fine.

Is there any kind of known issue here? A fix I should be aware of so I can just make life easier and install a full GApps package the next time I need to?

Hi, didn't hear of this issue before. But the issue would probably be in the ROM or within the Hangouts app itself, that doesn't play nice when it is installed on /system/.
What you maybe could try do is running a logcat when sending an SMS to yourself when having Hangouts installed via the GApps package, and try to see if we can catch any errors that are occuring. That could point in a direction to solve the problem.

Quote:
Originally Posted by Wiley3233

So i have twrp and tried to install gapps but when i go into the install wich apps (AROMA) i cant use the touch screen.
How do i fix

LibAroma has known issues, because it is old and we are still waiting for a new version of it. You can try another TWRP version, sometimes up/downgrading helps. If it doesn't resolve the issue, you'll have to wait until the new libaroma is released and use a manual created gapps-config for now.
Post Reply Subscribe to Thread

Tags
auto-qa

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes