FORUMS
Remove All Ads from XDA

[Q&A] [APP] Linux-on-Android project (Complete Linux Installer)

n/a posts
Thanks Meter: 0
 
By QA Bot, Guest on 24th October 2014, 10:56 PM
Post Reply Email Thread
Q&A for [APP] Linux-on-Android project (Complete Linux Installer)

Some developers prefer that questions remain separate from their main development thread to help keep things organized. Placing your question within this thread will increase its chances of being answered by a member of the community or by the developer.

Before posting, please use the forum search and read through the discussion thread for [APP] Linux-on-Android project (Complete Linux Installer). If you can't find an answer, post it here, being sure to give as much information as possible (firmware version, steps to reproduce, logcat if available) so that you can get help.

Thanks for understanding and for helping to keep XDA neat and tidy!
 
 
24th October 2014, 10:56 PM |#2  
Junior Member
Thanks Meter: 0
 
More
Info 2 +1 Like Tweet Rate Thread Add Poll [Q] Android 4.4.2 i9506 "Complete Linux Inst
"Complate Linux Installer" program after I installed the "ubuntu image", "BusyBox", "terminal emulator" and "vnc" I've installed.
The phone has root;
But "Complate Linux Installer" from the image, in the image whenever you start with the error I'm having. If you have information or who will be able to direct; I'm waiting for help.

"Checking loop device... MISSING
Creating loop device... /data/data/com.zpwebsites.linuxonandroid/files/bootscript.sh[130]: /data/data/com.zpwebsites.linuxonandroid/files/busybox: Permission denied FAİLED
Error: UNABLE TO CREATE LOOP DEVİCE!
1 root@ks01lte:/stoage/extSdCard/ubuntu #"
31st October 2014, 04:02 AM |#3  
hiack's Avatar
Junior Member
Thanks Meter: 0
 
More
you should type 'su' on the first to get the root permission.

Sent from my A0001 using XDA Free mobile app
1st November 2014, 04:24 PM |#4  
Junior Member
Thanks Meter: 0
 
More
busyboX permission denied
Hi,
i have this problem
u0_a68@lt03wifi:/ $
u0_a68@lt03wifi:/ $ cd /sdcard/ubuntu
u0_a68@lt03wifi:/sdcard/ubuntu $ su
sh /data/data/com.zpwebsites.linuxonandroid/files/bootscript.sh /sdcard/ubuntu/ubuntu.img
sh /data/data/com.zpwebsites.linuxonandroid/files/bootscript.sh /sdcard/ubuntu/ubuntu.img
root@lt03wifi:/storage/emulated/legacy/ubuntu # sh /data/data/com.zpwebsites.linuxonandroid/files/bootscript.sh /sdcard/ubuntu/ubuntu.img
MD5 file found, use to check .img file? (y/n)
y
Validating image checksum... /data/data/com.zpwebsites.linuxonandroid/files/bootscript.sh[81]: /data/data/com.zpwebsites.linuxonandroid/files/busybox: Permission denied
FAILED!
Error: Checksum failed! The image is corrupted!
1|root@lt03wifi:/storage/emulated/legacy/ubuntu #
the app have permission root. I have reinstalling busybox from launch, but not work.
i have change permission in folder data/data/com.zpwebsites.linuxonandroid/files/ in 0777, but not work.
thanks
10th November 2014, 05:12 AM |#5  
hiack's Avatar
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by damooo90

Hi,
i have this problem
u0_a68@lt03wifi:/ $
u0_a68@lt03wifi:/ $ cd /sdcard/ubuntu
u0_a68@lt03wifi:/sdcard/ubuntu $ su
sh /data/data/com.zpwebsites.linuxonandroid/files/bootscript.sh /sdcard/ubuntu/ubuntu.img
sh /data/data/com.zpwebsites.linuxonandroid/files/bootscript.sh /sdcard/ubuntu/ubuntu.img
root@lt03wifi:/storage/emulated/legacy/ubuntu # sh /data/data/com.zpwebsites.linuxonandroid/files/bootscript.sh /sdcard/ubuntu/ubuntu.img
MD5 file found, use to check .img file? (y/n)
y
Validating image checksum... /data/data/com.zpwebsites.linuxonandroid/files/bootscript.sh[81]: /data/data/com.zpwebsites.linuxonandroid/files/busybox: Permission denied
FAILED!
Error: Checksum failed! The image is corrupted!
1|root@lt03wifi:/storage/emulated/legacy/ubuntu #
the app have permission root. I have reinstalling busybox from launch, but not work.
i have change permission in folder data/data/com.zpwebsites.linuxonandroid/files/ in 0777, but not work.
thanks

you don't get the permission .if you get the '$' will be turn into '#'

Sent from my A0001 using XDA Free mobile app
17th November 2014, 10:07 PM |#6  
Junior Member
Thanks Meter: 0
 
More
Linux on Android
Hi,
when I start Linux on the App "Linux on Android" i see the folling Error Message "/root/init.sh: line 133 [: ==: unary operator expected". I can't not start the VNC Connection. Whout I con Do?

Thanks for request, Stefan Harbich
25th November 2014, 01:24 PM |#7  
Junior Member
Flag Kalasin
Thanks Meter: 1
 
More
I can not run..
How to run on Xiaomi Mi4, It's have internal rom don't have sd card..
30th December 2014, 08:54 AM |#8  
jcfunk's Avatar
Senior Member
Thanks Meter: 492
 
More
Quote:
Originally Posted by makgun

I had tried your bootscript.sh but it doesn't work again.
Full log with terminal is
"u0_a156@g2:/ $
u0_a156@g2:/ $ su
/data/data/com.zpwebsites.linuxonandroid/files/busybox chroot /data/local/mnt /root/init.sh

/data/data/com.zpwebsites.linuxonandroid/files/busybox chroot /data/local/mnt /root/init.sh

ox chroot /data/local/mnt /root/init.sh <
ERROR: ld.so: object '/vendor/lib/libNimsWrap.so' from LD_PRELOAD cannot be preloaded: ignored.
Start VNC server? (y/n)
y
/root/init.sh: line 110: [: ==: unary operator expected
Start SSH server? (y/n)
ERROR: ld.so: object '/vendor/lib/libNimsWrap.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/vendor/lib/libNimsWrap.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/vendor/lib/libNimsWrap.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/vendor/lib/libNimsWrap.so' from LD_PRELOAD cannot be preloaded: ignored.
* Starting OpenBSD Secure Shell server sshd ERROR: ld.so: object '/vendor/lib/libNimsWrap.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/vendor/lib/libNimsWrap.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/vendor/lib/libNimsWrap.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/vendor/lib/libNimsWrap.so' from LD_PRELOAD cannot be preloaded: ignored.
[ OK ]
If connecting from a different machine on the same network as the android device use the address below:
ERROR: ld.so: object '/vendor/lib/libNimsWrap.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/vendor/lib/libNimsWrap.so' from LD_PRELOAD cannot be preloaded: ignored.
eth0: error fetching interface information: Device not foundSave settings as defaults? (y/n) (You can always change it later in the app)
y
Config saved to /root/cfg/linux.config

To shut down the Linux environment, just enter 'exit' at this terminal - and WAIT for all shutdown routines to finish!

ERROR: ld.so: object '/vendor/lib/libNimsWrap.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/vendor/lib/libNimsWrap.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/vendor/lib/libNimsWrap.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/vendor/lib/libNimsWrap.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/vendor/lib/libNimsWrap.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/vendor/lib/libNimsWrap.so' from LD_PRELOAD cannot be preloaded: ignored.
root@localhost:/# "

This is happening becuase of SU, chainfire's uses it's own shell.
Clockworkmod SU, defaults back to /, so the cd made before su command cause script to fail. On newer android ChainsDD doesn't work.

App needs to be updated to do su before cd for CWM, and or run su with these options
for Chainfire's "su -p -s /system/bin/sh"
8th January 2015, 06:37 PM |#9  
Junior Member
Thanks Meter: 0
 
More
Great app guys. My only issue besides a black screen I've been battling with vnc..is when I download a distro and attempt to open to zip I get "bad file size" and a series of numbers. The only one that didn't do that to me was the small version ofdebian. It anyone has the large or small version of either ubuntu id appreciate a link. And yes I've tried redownloading multiple times.

The torrents have no seeders and the sound forge site always gives be a bad download.

Also if anyone has a good vnc alternative id love to hear about it
9th January 2015, 06:36 PM |#10  
jcfunk's Avatar
Senior Member
Thanks Meter: 492
 
More
Quote:
Originally Posted by nowucmenowudont3

Great app guys. My only issue besides a black screen I've been battling with vnc..is when I download a distro and attempt to open to zip I get "bad file size" and a series of numbers. The only one that didn't do that to me was the small version ofdebian. It anyone has the large or small version of either ubuntu id appreciate a link. And yes I've tried redownloading multiple times.

The torrents have no seeders and the sound forge site always gives be a bad download.

Also if anyone has a good vnc alternative id love to hear about it

The torrents seem to have no seeders, I would download from sourceforge, try the 12.04 imgs they seem to work for the bigger imgs. Can always update them to 13 or 14.
3rd February 2015, 02:53 PM |#11  
Junior Member
Thanks Meter: 1
 
More
need help
i got this app /terminal / vnc/ images and im sure my kernel support loop devices but when i press 'start linux" button it just opens terminal but nothing happens and i dont have any clue what to do (i tried kali and ubuntu images)

(sorry for my bad english)
The Following User Says Thank You to saeedbs For This Useful Post: [ View ] Gift saeedbs Ad-Free
Post Reply Subscribe to Thread

Tags
auto-qa

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes