FORUMS
Remove All Ads from XDA

[Solved] [Magisk] Can't run a script at boot from /system/etc/init.d/ or /system/su.d

103 posts
Thanks Meter: 13
 
By callihn, Senior Member on 9th June 2019, 05:18 PM
Post Reply Email Thread
The script (br549) works as expected when ran directly so nothing is wrong with the script. Permissions are set to 0700 like the other two working scripts in the same directory, one that binds /system/init.d to /system/su.d I assume it was created by Magisk with 00 in front of it and one that Link2SD uses to bind the second partition on my sd card with 11 in front of the name which was created by that app, both work on boot, mine is 12br549, again the script works but will not run on boot, I even tried using a simple script in /system/su.d to run br549.sh from /root but it still doesn,t run at boot. Please tell me what's going on here?
 
 
12th June 2019, 09:14 PM |#2  
OP Senior Member
Thanks Meter: 13
 
More
Seems it's a Magisk thing. You can run a script on boot from /data/adb/service.d/
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes