FORUMS
Remove All Ads from XDA

sw rev check fail device 4 binary 2 error - Downgrade

1 posts
Thanks Meter: 0
 
By rfpg, Junior Member on 29th March 2019, 01:38 AM
Post Reply Email Thread
Is it not possible to downgrade Android when the bootloader is more updated than the firmware you want to install?

I want to downgrade my Android 8.0 to 7.0 on my Galaxy S7 (SM-G930F). The following error appears on my phone when I press start on Odin: sw rev check fail device 4 binary 2 error. .

Android Oreo is draining my phone's battery. Can't find the solution anywhere! Is there another way?

***
FYI
Current firmware (bought my phone in Spain, carrier free):
PDA version: G930FXXS4ESC1
CSC version: G930FPHE4ERKF

The one I'm trying to install (the latest firmware released in Spain for Android 7.0):
PDA version: G930FXXS2DRDI
CSC version: G930FPHE2DRB5

I have tried:
Using different USB ports and cables (incl the original) and Odin versions (v3.11; v3.12.5; v3.13.1).

Odin Log:
<ID:0/006> Added!!
<ID:0/006> Odin engine v(ID:3.1301)..
<ID:0/006> File analysis..
<ID:0/006> skip file list for home binary
<ID:0/006> param.bin
<ID:0/006> modem_debug.bin
<ID:0/006> Home Binary Download
<ID:0/006> Total Binary size: 4190 M
<ID:0/006> SetupConnection..
<ID:0/006> Initialzation..
<ID:0/006> Get PIT for mapping..
<ID:0/006> Firmware update start..
<ID:0/006> NAND Write Start!!
<ID:0/006> SingleDownload.
<ID:0/006> sboot.bin
<ID:0/006> FAIL!
<ID:0/006>
<ID:0/006> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1)
 
 
12th June 2019, 08:48 PM |#2  
b1k3rdude's Avatar
Senior Member
Flag London
Thanks Meter: 29
 
More
Same issue here, I get sw rev check fail bootloader device 5 binary 2 on my G930F

OEM unlock is enabled but ODIN is failing if I try to flash any android 7.x stock roms. I can flash TWRP and then 3rd party Android 7 roms but then the modem is broken as i dont have any data connection and/or the sim is not recognised.

There has to be a way to downgrade the bootloader and modem...

---------- Post added at 08:26 PM ---------- Previous post was at 07:42 PM ----------

Quote:
Originally Posted by b1k3rdude

There has to be a way to downgrade the bootloader and modem...

After some digging its looks like if you find a 7.0 stock rom with an updated (v2.0 versus v1.0) bootloader -

- https://www.youtube.com/watch?v=426gerYWsK4

The link you eventually get taken to is an Italian android 7.0 rom -

- https://updato.com/firmware-archive-...15FA163EE8F90B

But I am also going to try a Uk BTU 7.0 rom -

-https://updato.com/firmware-archive-select-model/?record=A59F8169512011E89F15FA163EE8F90B

---------- Post added at 08:48 PM ---------- Previous post was at 08:26 PM ----------

Well that was a complete waste of time, tried the Chile, Italy and UK stock 7.0 roms and no dice.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes