FORUMS
Remove All Ads from XDA

Issues with TDLS (Tunneled Direct Link Setup) prevent use of vlc remote control

1 posts
Thanks Meter: 0
 
By mike2017pi, Junior Member on 29th May 2017, 10:56 PM
Post Reply Email Thread
Hi,

I am just a Android user, but I believe my observations and questions are interesting and relevant to people in this forum.

I use a Samsung Galaxy A3 (2017) and wanted to use one of the many VLC remote control apps towards my Ubuntu computer that has a Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (Lite-on). Unfortunately none of them worked. All had network issues. I tried different ports and also used several browsers to access the http server of vlc directly, but even the browser had issues: it basically kept synchronised for 4 or 5 seconds, then lost synch and recovered only after roughly 15 seconds just to loose synch again after 4 or 5 seconds.

I checked the TCP connection. It did not break down. However, every 4th or 5th GET request got delayed by around 14 seconds.

I digged into it and found out that the A3 sends a TDLS Setup Request to the QCA9565, gets a TDSL Setup Response and then sends a TDLS Setup Confirm which is replied by the QCA9565 with a TDLS Teardown. After that, the connection between the two hosts is dead for about 14 seconds.

Other hosts in the network did not have such issues, but as far as I can see, they are also not using TDSL. So I suspect that some issues with TDLS between my Samsung A3 and my Ubuntu machine regularly interrupt the local WiFi connection between the two.

So now my question: Is it somehow possible to disable TDLS on my Android phone? Or are there any vlc remote apps around that somehow suppress TDLS for such local WiFi communcation?

Thanks
Michael
 
 
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes