FORUMS
Remove All Ads from XDA

[APP] Xiaomi Mi Laser Projector tools

769 posts
Thanks Meter: 642
 
Post Reply Email Thread
1st November 2018, 01:48 AM |#21  
Member
Thanks Meter: 14
 
More
Awesome @spocky12 did you capture an incoming OTA update, is that how you got this? I have my updates disabled so I wouldn't know.

We've gotta reverse engineer how these update scripts work and just make a pre-rooted firmware and/or one that only installs the modified TWRP, I think thats the only way we're gonna make root widespread.
 
 
2nd November 2018, 06:46 PM |#22  
spocky12's Avatar
OP Recognized Developer
Flag Lyon
Thanks Meter: 642
 
Donate to Me
More
Quote:
Originally Posted by servo386

Awesome @spocky12 did you capture an incoming OTA update, is that how you got this? I have my updates disabled so I wouldn't know.

We've gotta reverse engineer how these update scripts work and just make a pre-rooted firmware and/or one that only installs the modified TWRP, I think thats the only way we're gonna make root widespread.

No I just made a little script to scan for possible updates url (OTA urls contain device codename, platform id, source firmware version and destination firmware version). Unfortunately, this is only true for xiaomi 6.0.1 "gitv" devices. Android TV 8.1 OTAs seem to be distributed through Google channels with url looking like md5, so kind of impossible to guess.

Concerning the ability to make a pre rooted rom, I still don't know how it could be done : stock recovery will refuse to flash any firmware not signed by Xiaomi (I didn't try to remove files and keep only certain files such as userdebug recovery, but custom files will certainly not flash).
The only possibility I can imagine for easy root access would be to flash through fastboot with amlogic tools, but I don't know how to get into that mode.
2nd November 2018, 07:06 PM |#23  
Member
Thanks Meter: 14
 
More
wow you made a script to trawl search engines for URLs? Also, has anyone/you received this update through the OTA app on the projector? if not, who was this intended for?
4th November 2018, 12:47 AM |#24  
spocky12's Avatar
OP Recognized Developer
Flag Lyon
Thanks Meter: 642
 
Donate to Me
More
Quote:
Originally Posted by servo386

wow you made a script to trawl search engines for URLs? Also, has anyone/you received this update through the OTA app on the projector? if not, who was this intended for?

Not really. After analysing a logcat for our device, I've seen that the OTAs urls look like this: http://ota.cdn.pandora.xiaomi.com/ro...6.0.1.1074.zip
Then it's not so hard to make a script to check for updates for 1074 firmware.

Now to answer your question, if you connect your xiaomi account on the projector, in the system update settings, you can ask to be part of a "closed beta test group". My status there is "pending", but not "approved" yet, so no beta firmware is sent to my device. That's why I had to find another way to get these updates
The Following User Says Thank You to spocky12 For This Useful Post: [ View ]
4th November 2018, 01:32 PM |#25  
Junior Member
Thanks Meter: 1
 
More
Thanks @spocky12 I installed the update on my 7000, it works well but YouTube stops after 5 seconds. I previously got it working using the version from June but now it stops during the add I think. Did you manage to get YouTube working? Do you have a solution for the google play services and store?
Thanks again
Cheers

---------- Post added at 02:32 PM ---------- Previous post was at 01:47 PM ----------

Ok my bad, youtube still works but not connected to my bluetooth speakers...
4th November 2018, 09:27 PM |#26  
Samckaz's Avatar
Member
Flag NYC
Thanks Meter: 8
 
More
Hi spocky12 I tried on my wemax one pro and error message in Chinese comes up which translates to Wrong! It is in root folder and fat32. Any help would be greatly appreciated
5th November 2018, 12:07 AM |#27  
spocky12's Avatar
OP Recognized Developer
Flag Lyon
Thanks Meter: 642
 
Donate to Me
More
Quote:
Originally Posted by jhordies

Thanks @spocky12 I installed the update on my 7000, it works well but YouTube stops after 5 seconds. I previously got it working using the version from June but now it stops during the add I think. Did you manage to get YouTube working? Do you have a solution for the google play services and store?
Thanks again
Cheers

---------- Post added at 02:32 PM ---------- Previous post was at 01:47 PM ----------

Ok my bad, youtube still works but not connected to my bluetooth speakers...

I've noted that latest YoutubeLeanback 2.03.06 (from september) doesn't work anymore, but 2.03.04 (from june) still works fine here. I've seen that september's version adds mic recording permission and I believe I've seen changes in code regarding to mic, which might explain it.

Quote:
Originally Posted by Samckaz

Hi spocky12 I tried on my wemax one pro and error message in Chinese comes up which translates to Wrong! It is in root folder and fat32. Any help would be greatly appreciated

A member of AvForums complained about the same issue. Unfortunately, I can't say that the message is really helpful to understand this issue. The post just above yours proves that it's not an issue related to Wemax, as jhordies' projector updated fine. Now, what can cause it... I have pretty mush no idea . Could you please install MiiInfo (from the 2nd post) and send me a screenshot ?
5th November 2018, 04:33 AM |#28  
Samckaz's Avatar
Member
Flag NYC
Thanks Meter: 8
 
More
Quote:
Originally Posted by spocky12

I've noted that latest YoutubeLeanback 2.03.06 (from september) doesn't work anymore, but 2.03.04 (from june) still works fine here. I've seen that september's version adds mic recording permission and I believe I've seen changes in code regarding to mic, which might explain it.



A member of AvForums complained about the same issue. Unfortunately, I can't say that the message is really helpful to understand this issue. The post just above yours proves that it's not an issue related to Wemax, as jhordies' projector updated fine. Now, what can cause it... I have pretty mush no idea . Could you please install MiiInfo (from the 2nd post) and send me a screenshot ?

Yes sir! I'll send as soon as I get a chance. Thanks for everything
6th November 2018, 01:40 AM |#29  
Junior Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by spocky12

I've noted that latest YoutubeLeanback 2.03.06 (from september) doesn't work anymore, but 2.03.04 (from june) still works fine here. I've seen that september's version adds mic recording permission and I believe I've seen changes in code regarding to mic, which might explain it.



A member of AvForums complained about the same issue. Unfortunately, I can't say that the message is really helpful to understand this issue. The post just above yours proves that it's not an issue related to Wemax, as jhordies' projector updated fine. Now, what can cause it... I have pretty mush no idea . Could you please install MiiInfo (from the 2nd post) and send me a screenshot ?

Hey spocky12, that update didn't work for me either. I don't really need the update but i thought you'd like to know. If you want to check my miinfo you can look on page 102 on that other forum. I'm too dumb to figure out how to post a pic here.
13th November 2018, 10:03 AM |#30  
Senior Member
Thanks Meter: 23
 
More
Great thread Spoky12,
is there any way to change the time on wemax? My projector is stucked with Chinese time and I can not find any where in setting to change the clock
13th November 2018, 10:18 AM |#31  
Totriet's Avatar
Senior Member
Flag Paris
Thanks Meter: 18
 
More
Quote:
Originally Posted by maquan

Great thread Spoky12,
is there any way to change the time on wemax? My projector is stucked with Chinese time and I can not find any where in setting to change the clock

In "MiProA1" is there no way to change the time zone ?

Envoyé de mon SM-G960F en utilisant Tapatalk
Post Reply Subscribe to Thread

Tags
mi laser projector, miproja1, wemax, xiaomi

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes