FORUMS

Bliss OS (x86) for PC's - 12.x Development - Beta Builds

2,746 posts
Thanks Meter: 4,879
 
Post Reply Email Thread
Announcement from electrikjesus: Team Bliss is rolling out with Alpha builds of Bliss OS 12.0, Android 10 for PC's
19th May 2020, 04:50 PM |#491  
Quote:
Originally Posted by mchipser

I have a few Acer Switch 10s that might be good for testing purposes..

Are you able to produce a log of Bliss OS currently?
21st May 2020, 04:50 PM |#492  
Senior Member
Flag Melbourne
Thanks Meter: 65
 
Donate to Me
More
Can anyone please tell me step by step on how to make Adaway working? Thank you.
23rd May 2020, 02:56 PM |#493  
Senior Member
Thanks Meter: 65
 
More
any idea why grub does't install when i select the install over the windows partition?
on reboot it just goes straight to windows..
PS: this is v12.. downloading v11 to see if it works
23rd May 2020, 03:00 PM |#494  
Member
Thanks Meter: 12
 
More
after installing this version of blissOS I get a blank screen when trying to boot the os
is there any solution for this

my laptop is
Intel Core i5-2467M
Intel HD 3000
4gb ram

Also when I try to run the liveCD
it just stays on the electric globe screen
23rd May 2020, 10:51 PM |#495  
Senior Member
Thanks Meter: 45
 
More
Quote:
Originally Posted by electrikjesus

Bliss OS "Merkaba" 12.6 Release Client 2.2 - 2020-05-05
!! Please remember to not quote these update posts, or any of the OP's !!

These builds represent huge changes to Bliss OS in the form of both updates and feature changes. Not all these features have been catered to PC users though so there are still a ton of mobile features and options throughout the OS.

!!PLEASE NOTE!! The builds that use Kernel-5.2+ are no longer compatible with the AUTO_LOAD=old kernel command line option. If you are using this option to boot, then you will not be able to. It will bootloop.

Here's a short list of some of those updates.

[..]

All changelogs (when they work) - https://sourceforge.net/projects/blissos-dev/files/Beta
[/CODE][/HIDE]

Thanks, and #stayblissful

Hi,
I have a Huawei Matebook 13 (Core i7-8565U, Whiskey Lake, UHD 620/MX 150). I am able to boot the may release of Android x86_x64 14.1 r4 k4.19 image but when I try to boot BlissOS live usb the booting just stops after Android has been detected at /dev/sda1. I've tried all three ISOs/kernals, but they all give the same result and I've tried adding GRALLOC=gbm.

I also tried to replace the BlissOS kernal with the one from Android x86 and that actually made the booting go as far as the "plasma circle" loading screen.. but it never made it passed that.

Is my laptop unsupported? Android x86 works "out of the box" with touch screen and everything. They can't be THAT different?

Edit: I tried BlissOS 11 with 4.19 kernel and it didn't work with the BlissIS kernel.. but for that release it kind of worked to use the Android x86 kernel... Android did load but touchpad, touchscreen and keyboard does not work.
25th May 2020, 11:49 AM |#496  
Member
Thanks Meter: 12
 
More
I can install bliss 11, but when I install v12.6, it would not boot
anyone can help solve this problem?
25th May 2020, 02:24 PM |#497  
Junior Member
Thanks Meter: 0
 
More
Hi there,

I successfull installed and good performance with Bliss 11.10 from 04-April 2020

The only issue that i have is I can`t play Lineage 2 Revolution ( i haven't tried any other game)

I try placing houdini.sfs on /system/etc and enablin ARM compatiblity but when game start crash on login screen.


I have ASUS T102-HA

thanks in advance
1st June 2020, 03:42 PM |#498  
Nonononoki's Avatar
Senior Member
Thanks Meter: 37
 
More
I have an Intel Atom notebook from 2016, which is unfortunately locked in 32 bit UEFI. Bliss 11 works, but unfortunately audio doesn't work. The BIOS doesn't even recognise Bliss 12 as a bootable USB device. Any workaround?
2nd June 2020, 10:30 PM |#499  
Bliss OS "Merkaba" 12.6 Release Client 2.2 - AMD - 2020-04-23 & Bliss OS Lite Alpha Release - Vulkan - 2020-05-31
!! Please remember to not quote these update posts, or any of the OP's !!

I ran into some issues with Bliss OS Yantra/Merkaba that I was not able to work around yet, so the first part of this release is a build of that (with the issues it has) but confirmed booting for AMD Ryzen CPU.
The second part of this update is the first release of Bliss OS Lite 1.2, which is a stripped down version of Bliss OS, adding minimal extras to not conflict with things on our PC's These Lite builds will let me focus on solidifying a strong base to work from moving forward and allow me to get things fixed faster without having to backtrack and revert things coming from the new features added weekly to BlissROM, I was having issues with lockscreen, security, updates, etc.. So I decided to roll the source all the way back to Bliss OS 12.2, when it was mostly AOSP, and started with only adding a few pixel additions for customization.

I will also be moving to a different plan for releasing these builds. As I have already started baking it into the build script. The plan is to now have a separate branch/build for Vulkan, AMD, Atom & Generic. Doing it this way will allow me to focus on giving each machine type the attention it needs to help make things as stable as possible on that machine type. Unfortunately, this is also a sign that I have given up on my dreams of a truly universal .iso for all devices...

!!PLEASE NOTE!! If you have a previous Bliss OS install and want to switch to Bliss OS Lite, you will need to wipe your data image/partition/folder as this is a different OS. Updating Bliss OS Lite to newer Bliss OS Lite will not require you to wipe data.

The builds that use Kernel-5.2+ are no longer compatible with the AUTO_LOAD=old kernel command line option. If you are using this option to boot, then you will not be able to. It will bootloop.

Here's a short list of some of those updates.

Updates and fixes included in Bliss OS Lite:
• Finished setting up Gralloc and HWC switches in init
• Fixes for random crashes on boot
• Used a ton of updates from @Fcuzzocrea and LOS-x86 (Still in development)
• Fixes for booting in Live Mode
• Fixes for power buttons and power dialog not showing
• Bunch more updates, too many to list. check the changes


PLEASE NOTE I recommend everyone testing to also use this in Vulkan mode or boot using gbm_gralloc, as I am considering making it the default. Vulkan mode can be done from the Advanced grub menu if you installed using the bootable installer, or if you used a different grub, you will want to add "VULKAN=1" to the grub entry before the word "quiet". If your device doesn't support Vulkan, you can add "GRALLOC=gbm" to the same place in your grub entry. Sleep states should work fine after that.
Other bootloop issues can also be solved by booting with GRALLOC=gbm command -line option.

Builds being uploaded:
  • Bliss-OS-Merkaba-v12.6-android_x86_64-OFFICIAL-202004231931_k-k5.6.2-si-yling-rmi_m-10.0.8-ax86_ld-2.4.100-ax86-ma_dg-_dh-_mg-_gms_cros-hd_cros-wv-amd.iso
  • Bliss-OS-Lite-v1.2-android_x86_64-OFFICIAL-202005310014_k-k5.6.2-si-yling-rmi_m-20.1.0_pie-x86_ld-2.4.100_q-x86_dg-freedreno_build_dh-pie-x86-drm_mg-aosp_pie-x86_gms_cros-hd_cros-wv-vulkan.iso

Known new issues:
  • Sleep states aren't working right on a few machines. Some can cause SystemUI to restart.
  • Widevine is not working in the Bliss OS Lite builds yet.
  • Some machines still have volume/sound issues, use 3rd party EQ or volume control.
  • Nativebridge is still not working in Android 10. Please stop complaining that you can't play your favorite game on these builds.

Download:

You still have to go through our website to download. The download section for Bliss OS 12 Betas will be updated soon.

Changelogs:

Code:
CHangelogs are half working and can be found in the download folder along with these builds,


Thanks, and #stayblissful
The Following 3 Users Say Thank You to electrikjesus For This Useful Post: [ View ] Gift electrikjesus Ad-Free
3rd June 2020, 01:08 AM |#500  
Member
Flag Stockholm
Thanks Meter: 18
 
More
HI Mr jesus - i have this machine and latest build won't boot. What is wrong ?

https://www.asus.com/Laptops/X553MA/overview/
3rd June 2020, 03:33 AM |#501  
Quote:
Originally Posted by Swehub

HI Mr jesus - i have this machine and latest build won't boot. What is wrong ?

https://www.asus.com/Laptops/X553MA/overview/

Without any logs, cpu info, install info, etc, you might as well be calling me Mrrs Cleo
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes