FORUMS
Remove All Ads from XDA

Bromite magisk module

247 posts
Thanks Meter: 120
 
Post Reply Email Thread
Announcement from clcombs262: 4.0.0 now available! Should work on stock ROMs too now
12th August 2019, 03:01 AM |#171  
clcombs262's Avatar
OP Senior Member
Flag Monticello
Thanks Meter: 120
 
Donate to Me
More
Quote:
Originally Posted by Juzman

Bromite is the only option and is selected, but when testing in Chrome I get 7/9 not 5/9.

That's probably because chrome doesn't use webview of Android
 
 
12th August 2019, 06:46 AM |#172  
Junior Member
Thanks Meter: 1
 
More
I cannot find it's use
12th August 2019, 12:55 PM |#173  
marcdw's Avatar
Senior Member
Flag Baldwin Park
Thanks Meter: 2,856
 
More
Quote:
Originally Posted by Juzman

Bromite is the only option and is selected, but when testing in Chrome I get 7/9 not 5/9.

As mentioned above, Chrome/Chromium(-based) browsers don't use webview. Neither do Mozilla-based browsers. If you don't want to install another browser just to test try the WEBVIEW TEST app or something already installed with a built-in browser, like a download manager or what have you.

P.S. For privacy advocates, WEBVIEW TEST has trackers.



LG G3 D851, PAC-ROM 6, MultiROM, XDA Legacy
13th August 2019, 08:05 AM |#174  
Junior Member
Thanks Meter: 2
 
More
I need some assistance with uninstalling. I did avoid the hassel with checking if installation is possible and probably got the consequences .. I use a Lineage-12.1. ROM on a Fire7 (https://forum.xda-developers.com/ama...-12-1-t3639447) and installed via Magisk 19.3., restarted after installation, browser crashes (https://forum.xda-developers.com/and...owser-t3500091). I tried to resolve the problem by deactivating (1st) and uninstalling (2nd) the module, browser still crashes. Any suggestions before I have to do a clean installation of the ROM?
13th August 2019, 12:05 PM |#175  
clcombs262's Avatar
OP Senior Member
Flag Monticello
Thanks Meter: 120
 
Donate to Me
More
Quote:
Originally Posted by arnabpal025

I cannot find it's use

As described by the README, a webview is something apps use to display web content, such as banking apps, the Google app, Outlook, other email apps, etc
13th August 2019, 12:13 PM |#176  
clcombs262's Avatar
OP Senior Member
Flag Monticello
Thanks Meter: 120
 
Donate to Me
More
Quote:
Originally Posted by Guttergorm

I need some assistance with uninstalling. I did avoid the hassel with checking if installation is possible and probably got the consequences .. I use a Lineage-12.1. ROM on a Fire7 (https://forum.xda-developers.com/ama...-12-1-t3639447) and installed via Magisk 19.3., restarted after installation, browser crashes (https://forum.xda-developers.com/and...owser-t3500091). I tried to resolve the problem by deactivating (1st) and uninstalling (2nd) the module, browser still crashes. Any suggestions before I have to do a clean installation of the ROM?

To be 100% honest, I'm not sure how webview works on lollipop and marshmallow

I would ask your maintainer what is the proper way to switch webview. Other issues with older ROMs have cropped up before, but Alexandria doesn't have a device that runs anything older than Oreo at the moment to test on and all of mine run pie


A couple of troubleshooting steps first:

Under the module directory, /data/adb/modules/bromitewebview/system/app/webview install the apk there as you would any other app, with the module enabled

If that doesn't help, I recommend you join the telegram group @Inlmagisk for further assistance
13th August 2019, 12:37 PM |#177  
Junior Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by clcombs262

To be 100% honest, I'm not sure how webview works on lollipop and marshmallow
install the apk there as you would any other app, with the module enabled

Thanks, that did it, I reinstalled the module and then bromite via f-droid. Works as intended, favourite weather site detects the adblocker.
14th August 2019, 01:03 AM |#178  
Senior Member
Thanks Meter: 48
 
More
Quote:
Originally Posted by westhaking

Progress! Installed and selectable in webview settings yet I'm not sure how to know that it is actually working or not. Webview test doesn't indicate bromite anywhere. Stock Pixel 2.

Using latest Yahfa beta and edxposed installer and everything seems to be working!
14th August 2019, 01:29 AM |#179  
clcombs262's Avatar
OP Senior Member
Flag Monticello
Thanks Meter: 120
 
Donate to Me
More
Quote:
Originally Posted by westhaking

Using latest Yahfa beta and edxposed installer and everything seems to be working!

It never says it's using bromite. That would break the anonymous nature of it
EDIT: Oops, quoted wrong post
Sent from my Moto Z3 Play using Tapatalk
The Following User Says Thank You to clcombs262 For This Useful Post: [ View ] Gift clcombs262 Ad-Free
14th August 2019, 03:54 PM |#180  
Senior Member
Thanks Meter: 17
 
More
I finally got bromite web view working on my OnePlus 7 pro but now a bunch of apps crash on start (Amazon, slice) so far and when I change the setting back to chrome it works fine so what's blocking it?
19th August 2019, 06:31 PM |#181  
clcombs262's Avatar
OP Senior Member
Flag Monticello
Thanks Meter: 120
 
Donate to Me
More
Good news everyone!

V4 is live in the Magisk repo, with all stock compatibility fixes

A clean flash is highly recommended for proper functionality of the module
The Following 5 Users Say Thank You to clcombs262 For This Useful Post: [ View ] Gift clcombs262 Ad-Free
Post Reply Subscribe to Thread

Tags
android, custom android rom, magisk 18.1, universal, webview

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes