FORUMS
Remove All Ads from XDA

Bromite magisk module

257 posts
Thanks Meter: 140
 
Post Reply Email Thread
Announcement from clcombs262: 4.0.0 now available! Should work on stock ROMs too now
7th January 2020, 04:21 PM |#291  
Senior Member
Thanks Meter: 42
 
More
Thanks for the update, but I think apps still crashing.
7th January 2020, 08:59 PM |#292  
DavidEUS's Avatar
Member
Thanks Meter: 2
 
More
I have updated since version 4.1 using Magisk and it does not work, I have had to uninstall and now I am unable to install it again, neither through Magisk, nor by installing in the internal memory, nor in system / app / webview.
8th January 2020, 02:18 AM |#293  
Junior Member
Thanks Meter: 2
 
More
Installed the Magisk module and I didn't see Bromite on the webview list, so I installed the Bromite Webview via fdroid and still don't see it on the list.

What am I missing here?
8th January 2020, 10:12 AM |#294  
twist3d0n3's Avatar
Senior Member
Flag Bath
Thanks Meter: 582
 
More
Quote:
Originally Posted by SoftwareSucks


What am I missing here?

Bromite webview by the looks of it
8th January 2020, 09:00 PM |#295  
Member
Thanks Meter: 30
 
Donate to Me
More
Quote:
Originally Posted by SoftwareSucks

Installed the Magisk module and I didn't see Bromite on the webview list, so I installed the Bromite Webview via fdroid and still don't see it on the list.

What am I missing here?

Latest 4.2.3?

Sent from my Pixel 2 XL using Tapatalk
9th January 2020, 11:43 AM |#296  
Junior Member
Thanks Meter: 0
 
More
Tried 4.2.2 on Oreo 8.1, it said "installed successfully" and even listed in installed apps but didn't show in webview implementation list. And installer removed chrome which has been disabled anyway. Today I installed 4.2.3 and amazingly it got worse. Again it won't show in developer options menu and it removed default webview along with chrome. So it left me stranded without any browsing options. Yeah, I uninstalled it on a spot and it brought back chrome, which, I remind you, I chose to disable. It took a while to sort out, I had to update webview from store and disable damn chrome again. So I mildly pissed. Degoogled webview sounds good but implementation lacks evidently.
11th January 2020, 08:54 PM |#297  
Member
Thanks Meter: 6
 
More
Updated to 79.0.3945.111 via Magisk module 4.2.3 on AICP 14.0 (p9.0) amami (Sony Z1 Compact).

Gmail is crashing on opening. Google services and preferences completely dead (not opening at all). How to roll back?
13th January 2020, 03:11 AM |#298  
Member
Thanks Meter: 30
 
Donate to Me
More
Evidently the boot scripts are borked because they should install the app and fix the crashing (if you'd like to do it manually install the apk in /sdcard/bromite)
New logic blocks the overlay being copied on custom ROMs. Evidently this is too aggressive and needs re-worked. I have a hunch on how to fix this, but I need user input to do so

Anyone who's having issues with webview not showing up, I need two things: your build.prop and the debug logs on /sdcard

Please be aware that I'm significantly more active on telegram. You can reach me via joining https://t.me/inlmagisk

Sent from my Pixel 2 XL using Tapatalk

---------- Post added at 02:09 AM ---------- Previous post was at 02:07 AM ----------

Also, for now, you can copy the apk in the common directory in the zip to /data/adb/modules/bromitewebview/vendor/overlay until I resolve this issue

Sent from my Pixel 2 XL using Tapatalk

---------- Post added at 02:11 AM ---------- Previous post was at 02:09 AM ----------

Quote:
Originally Posted by DaggerMadd

Tried 4.2.2 on Oreo 8.1, it said "installed successfully" and even listed in installed apps but didn't show in webview implementation list. And installer removed chrome which has been disabled anyway. Today I installed 4.2.3 and amazingly it got worse. Again it won't show in developer options menu and it removed default webview along with chrome. So it left me stranded without any browsing options. Yeah, I uninstalled it on a spot and it brought back chrome, which, I remind you, I chose to disable. It took a while to sort out, I had to update webview from store and disable damn chrome again. So I mildly pissed. Degoogled webview sounds good but implementation lacks evidently.

Chrome can always be re-enabled

I'm considering just disabling it instead of completely removing it, what do you think?

Sent from my Pixel 2 XL using Tapatalk
The Following User Says Thank You to linuxandria For This Useful Post: [ View ] Gift linuxandria Ad-Free
13th January 2020, 01:01 PM |#299  
Junior Member
Thanks Meter: 0
 
More
Yeah, disabling chrome is more reasonable. User should be allowed fallback option. If bromite install fails and there are no webview alternatives - that instantly breaks google menu, public wifi authentication and who knows what else.
Well, I tried to include a link to archive containing my build.prop and bromite debug log but apparently new users are not allowed to. I don't use telegram, so... an email maybe?
16th January 2020, 02:00 PM |#300  
Senior Member
Thanks Meter: 730
 
Donate to Me
More
Maybe it helps the dev or someone else with problems: after installing the latest Magisk module (4.2.3) on a clean flash of SuperiorOS Nemesis (Android Pie) plus Open Gapps Pico for arm64, I could see Bromite listed correctly in developer settings (Chrome was hidden/removed tho) but it was not working. I have checked the file system and it seemed fine. I then simply manually installed the latest Bromite SystemWebview from F-Droid, which was the exactly same version, and it started to work fine. Attached is the Bromite module log. Regards.
Attached Files
File Type: zip bromitewebview-debug.log.zip - [Click for QR Code] (17.7 KB, 4 views)
16th January 2020, 05:27 PM |#301  
Member
Thanks Meter: 3
 
More
For me the same. Everything crashes. Nothings gonna work since the latest update. No reinstall, no deinstall. Can't even install older version from f-Droid, install process failed. The above suggestion to copy the APK into .../vendor/ didn't worked out because there's no overlay folder. Everything seems broken now. Even viperfx lost its driver. Can't reinstall.hmm. I'm on LOS16 arm.
Post Reply Subscribe to Thread

Tags
android, custom android rom, magisk 18.1, universal, webview

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes