FORUMS

Bromite magisk module

70 posts
Thanks Meter: 47
 
Post Reply Email Thread
Announcement from clcombs262: 4.4.3 available! This release fixes some issues with 4.4.1
13th January 2020, 12:01 PM |#301  
Junior Member
Thanks Meter: 0
 
More
Yeah, disabling chrome is more reasonable. User should be allowed fallback option. If bromite install fails and there are no webview alternatives - that instantly breaks google menu, public wifi authentication and who knows what else.
Well, I tried to include a link to archive containing my build.prop and bromite debug log but apparently new users are not allowed to. I don't use telegram, so... an email maybe?
16th January 2020, 01:00 PM |#302  
Senior Member
Thanks Meter: 733
 
Donate to Me
More
Maybe it helps the dev or someone else with problems: after installing the latest Magisk module (4.2.3) on a clean flash of SuperiorOS Nemesis (Android Pie) plus Open Gapps Pico for arm64, I could see Bromite listed correctly in developer settings (Chrome was hidden/removed tho) but it was not working. I have checked the file system and it seemed fine. I then simply manually installed the latest Bromite SystemWebview from F-Droid, which was the exactly same version, and it started to work fine. Attached is the Bromite module log. Regards.
Attached Files
File Type: zip bromitewebview-debug.log.zip - [Click for QR Code] (17.7 KB, 6 views)
16th January 2020, 04:27 PM |#303  
Member
Thanks Meter: 3
 
More
For me the same. Everything crashes. Nothings gonna work since the latest update. No reinstall, no deinstall. Can't even install older version from f-Droid, install process failed. The above suggestion to copy the APK into .../vendor/ didn't worked out because there's no overlay folder. Everything seems broken now. Even viperfx lost its driver. Can't reinstall.hmm. I'm on LOS16 arm.
23rd January 2020, 11:54 PM |#304  
Senior Member
Flag Sydney
Thanks Meter: 305
 
More
After uninstalling it doesn't re-enable android system webview which causes many apps to crash and it took me some time to figure out what was happening.
25th January 2020, 12:45 PM |#305  
Member
Thanks Meter: 3
 
More
How did you manage to get it to work?
26th January 2020, 10:58 AM |#306  
Junior Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by euphore

How did you manage to get it to work?

after uninstalled via magisk, try to convert Android Web Browser to user app then convert back to system app, i used titanium backup to do that, idk about other apps, it should work. after that i reinstalled the latest version still work for me 4.1.1 . i tried installing the latest version 4.2.3 but it still didn't work.
27th January 2020, 07:07 AM |#307  
Junior Member
Thanks Meter: 2
 
More
4.2.3 also causes crashes for certain apps using WV for me.

How do you guys install a specific older version (e.g. 4.1.1) through Magisk? I cannot find archive of older versions in Magisk and cannot find any ready-made zip for an older version I'd install through Magisk manually
27th January 2020, 01:38 PM |#308  
Senior Member
Thanks Meter: 28
 
More
Quote:
Originally Posted by TF666

4.2.3 also causes crashes for certain apps using WV for me.

How do you guys install a specific older version (e.g. 4.1.1) through Magisk? I cannot find archive of older versions in Magisk and cannot find any ready-made zip for an older version I'd install through Magisk manually

I still use 4.0.0 and it's working fine for me.
You can install it within the "module"- section. Use the + in the yellow circle.
Attached Files
File Type: zip Bromite_Systemless_Webview-4.0.0(3060).zip - [Click for QR Code] (4.98 MB, 112 views)
The Following 2 Users Say Thank You to the_Pan For This Useful Post: [ View ] Gift the_Pan Ad-Free
27th January 2020, 09:12 PM |#309  
Junior Member
Thanks Meter: 2
 
More
Thanks, @the_Pan, however this still installs newest webview as it installs the newest release from their github repo in the setup script. So the resulting Bromite System WebView is 79.0.3945.139 even with your version.

I will try to manually change `unity_install.sh` to `URL=https://github.com/bromite/bromite/releases/download/78.0.3904.63/${ARCH}_SystemWebView.apk` and see whether that helps with currently broken version.

Do you have any specific site where you download older releases of magisk modules?
Thanks!
28th January 2020, 06:49 AM |#310  
Senior Member
Thanks Meter: 28
 
More
Quote:
Originally Posted by TF666

Thanks, @the_Pan, however this still installs newest webview as it installs the newest release from their github repo in the setup script. So the resulting Bromite System WebView is 79.0.3945.139 even with your version.

I will try to manually change `unity_install.sh` to `URL=https://github.com/bromite/bromite/r.../78.0.3904.63/${ARCH}_SystemWebView.apk` and see whether that helps with currently broken version.

Do you have any specific site where you download older releases of magisk modules?
Thanks!

For me it was the magisk module which causes trouble, not the webview itself.
4th February 2020, 04:20 AM |#311  
Junior Member
Thanks Meter: 9
 
More
Quote:
Originally Posted by the_Pan

I still use 4.0.0 and it's working fine for me.
You can install it within the "module"- section. Use the + in the yellow circle.

Thank you for the zip. Up and working.
The Following User Says Thank You to TheBlackMink For This Useful Post: [ View ] Gift TheBlackMink Ad-Free
Post Reply Subscribe to Thread

Tags
android, custom android rom, magisk 18.1, universal, webview

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes