FORUMS

Bromite magisk module

65 posts
Thanks Meter: 42
 
Post Reply Email Thread
Announcement from clcombs262: 4.4.3 available! This release fixes some issues with 4.4.1
4th February 2020, 05:20 AM |#311  
Junior Member
Thanks Meter: 9
 
More
Quote:
Originally Posted by the_Pan

I still use 4.0.0 and it's working fine for me.
You can install it within the "module"- section. Use the + in the yellow circle.

Thank you for the zip. Up and working.
The Following User Says Thank You to TheBlackMink For This Useful Post: [ View ] Gift TheBlackMink Ad-Free
10th February 2020, 02:48 PM |#312  
OP Member
Thanks Meter: 42
 
Donate to Me
More
New stable release of bromitewebview!


Available on magisk manager repo

Telegram: https://t.me/inlmagisk

Subscribe: https://t.me/bromitewebview

Discord: https://discord.gg/gTnDxQ6

If you like my work and want it to continue, donate at: https://paypal.me/linuxandria

Sent from my GM1917 using Tapatalk

---------- Post added at 01:47 PM ---------- Previous post was at 01:46 PM ----------

Quote:
Originally Posted by TF666

Thanks, @the_Pan, however this still installs newest webview as it installs the newest release from their github repo in the setup script. So the resulting Bromite System WebView is 79.0.3945.139 even with your version.

I will try to manually change `unity_install.sh` to `URL=https://github.com/bromite/bromite/releases/download/78.0.3904.63/${ARCH}_SystemWebView.apk` and see whether that helps with currently broken version.

Do you have any specific site where you download older releases of magisk modules?
Thanks!

From now on older versions are available here:

https://github.com/linuxandria/bromitewebview/releases

Sent from my GM1917 using Tapatalk

---------- Post added at 01:48 PM ---------- Previous post was at 01:47 PM ----------

Changes for 4.4.1:

Fix boot scripts

Rework install logic

Introduced better logging

Lots of things I missed

Final unity release, 5.0 will be MMT-ex

Sent from my GM1917 using Tapatalk
The Following 5 Users Say Thank You to linuxandria For This Useful Post: [ View ] Gift linuxandria Ad-Free
10th February 2020, 04:51 PM |#313  
Member
Thanks Meter: 18
 
More
For the first time on Android 10, installed without problems and selectable. Unfortunately doesn't block the majority of google sponsored ads, but that's a Bromite issue, not the module itself. Thanks for your continued efforts!
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20200210-094719.png
Views:	454
Size:	114.9 KB
ID:	4947317  
10th February 2020, 11:52 PM |#314  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by linuxandria

New stable release of bromitewebview!

Ok, so with new "stable" release my phone successfully entered bootloop. I do hope there is a way to uninstall it via, say, adb, is it? Or maybe via TWRP?
12th February 2020, 10:02 PM |#315  
Xspeed's Avatar
Senior Member
Thanks Meter: 654
 
Donate to Me
More
Quote:
Originally Posted by linuxandria

New stable release of bromitewebview!

My device (Xperia X) also died, currently looking for a way to undo the damage without completely reflashing everything from scratch.

EDIT: I found the issue, the post-fs-data.sh script breaks the overlays.xml file:
Code:
<item packageName="${OL}" userId="0" targetPackageName="android" baseCodePath="${DR}/treble-overlay-webview.apk" state="6" isEnabled="true" isStatic="true" priority="98" />
This was inserted several times at the end of the overlays.xml file. Note that the variables were not expanded properly. Did you test this, dear dev?
13th February 2020, 02:54 PM |#316  
Senior Member
Flag The SIN City
Thanks Meter: 18
 
More
Been trying many times and all the new modules never work for my devices, wonder if the developer or anyone able to get to work, and why the new update never work/fix the issue? Or is there any tricks we need to do to ever get it to be useful?

I finally found an old copy 4.1.1 in my hard drive somewhere, tested to be working ok.

Sent from my Mi 6 using XDA Labs
14th February 2020, 04:08 PM |#317  
Junior Member
Thanks Meter: 0
 
More
My guess is - developers move on, get themselves fancy new One devices and don't really care about us mere mortals with "outdated" tech. At least that what I do with apps which I develop
14th February 2020, 05:17 PM |#318  
Senior Member
Flag The SIN City
Thanks Meter: 18
 
More
Yeah... 🙄

Sent from my Mi MIX 2 using XDA Labs
18th February 2020, 04:20 PM |#319  
OP Member
Thanks Meter: 42
 
Donate to Me
More
Quote:
Originally Posted by woofwoof75

Been trying many times and all the new modules never work for my devices, wonder if the developer or anyone able to get to work, and why the new update never work/fix the issue? Or is there any tricks we need to do to ever get it to be useful?

I finally found an old copy 4.1.1 in my hard drive somewhere, tested to be working ok.

Sent from my Mi 6 using XDA Labs

Flash latest alpha from https://GitHub.com/linuxandria/bromitewebview/releases, zip up /sdcard/bromite/logs, and send it here (you'll need to wait ~2min after booting)

Sent from my GM1917 using Tapatalk

---------- Post added at 03:20 PM ---------- Previous post was at 03:20 PM ----------

Quote:
Originally Posted by DaggerMadd

My guess is - developers move on, get themselves fancy new One devices and don't really care about us mere mortals with "outdated" tech. At least that what I do with apps which I develop

Especially if you don't provide logs and device info's

Sent from my GM1917 using Tapatalk
18th February 2020, 04:40 PM |#320  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by linuxandria

Especially if you don't provide logs and device info's

My phone died, I wasn't thinking about logs and ways to get them from bricked device, y'know. Just reflashed and set it up from scratch, spent several hours. I think I'm done with bromite.
18th February 2020, 06:34 PM |#321  
OP Member
Thanks Meter: 42
 
Donate to Me
More
Quote:
Originally Posted by DaggerMadd

My phone died, I wasn't thinking about logs and ways to get them from bricked device, y'know. Just reflashed and set it up from scratch, spent several hours. I think I'm done with bromite.

Once again, without logs and device info's I HAVE NO IDEA WHY AND CAN'T FIX YOUR PROBLEM.

Anyhow for most users who tested in my telegram group from v4.3 onwards the bootloop issues are gone.

Sent from my GM1917 using Tapatalk

---------- Post added at 05:34 PM ---------- Previous post was at 05:33 PM ----------

I'm sorry but I get extremely tired of "I have a problem but no I'm not going to give you any other information" lol

Sent from my GM1917 using Tapatalk
Post Reply Subscribe to Thread

Tags
android, custom android rom, magisk 18.1, universal, webview

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes