FORUMS
Remove All Ads from XDA

MTK THAI Developer Tools Tools

11 posts
Thanks Meter: 10
 
Post Reply Email Thread
MTK-THAI-Developer-Tools




Change log
v1.0.1.3 (30-06-2016) Last version
  • Fix white space directory name in system.new.dat
  • Fix white space directory name in system.img
  • Update new user interface

v1.0.1.2 (30-06-2016)
  • Fix some bug
  • Fix system.img bug

v1.0.1.1 (30-06-2016)
  • Fix some bug

v1.0.1.0 (29-06-2016)
  • unpack system.new.dat file
  • repack system.new.dat file
  • unpack system.img file
  • repack system.img file
  • unpack bootimg file
  • repack bootimg file
  • unpack recovery file
  • repack recovery file
  • deodext android lollipop rom

DOWNLOAD
Blogger: https://harry-rom.blogspot.com/2016/...ols-tools.html

XDA:DevDB Information
MTK THAI Developer Tools Tools, Tool/Utility for all devices (see above for details)

Contributors
Harry_ET, carvil, xpirt, Joel Jeyachandran
Source Code: https://github.com/SonoSolitario/MTK...eveloper-Tools


Version Information
Status: Stable
Current Stable Version: 1.0.1.3
Stable Release Date: 2016-06-30

Created 2016-06-29
Last Updated 2016-07-10
The Following 9 Users Say Thank You to Harry_ET For This Useful Post: [ View ] Gift Harry_ET Ad-Free
 
 
29th June 2016, 11:24 PM |#2  
darknessmc's Avatar
Senior Member
Thanks Meter: 118
 
More
Link doesn't work

Sent from my D6503 using XDA-Developers mobile app
30th June 2016, 12:13 AM |#3  
Senior Member
Flag damascus
Thanks Meter: 46
 
More
pls fix link
1st July 2016, 12:54 PM |#4  
Member
Thanks Meter: 6
 
More
Please give alternate link, doesn't work
3rd July 2016, 04:58 AM |#5  
levanhau03's Avatar
Senior Member
Thanks Meter: 61
 
More
source code not file
13th September 2016, 09:30 PM |#6  
osygen's Avatar
Junior Member
Thanks Meter: 2
 
More
Link is still not working please

Sent from my SM-P555 using XDA-Developers mobile app
15th September 2016, 06:47 AM |#7  
reversegear's Avatar
Senior Member
Thanks Meter: 1,498
 
More
Quote:
Originally Posted by darknessmc

Link doesn't work

Sent from my D6503 using XDA-Developers mobile app

Quote:
Originally Posted by akino553

pls fix link

Quote:
Originally Posted by panchalgl

Please give alternate link, doesn't work

Quote:
Originally Posted by osygen

Link is still not working please

Sent from my SM-P555 using XDA-Developers mobile app


Here is the download link for latest version
https://www.androidfilehost.com/?fid=24591023225177339

Enjoy
25th January 2017, 06:16 PM |#8  
connerESP's Avatar
Senior Member
Flag Barcelona
Thanks Meter: 19
 
More
I readed the ROM from my phone (MTK6572) with MTK Droid tools and I made a backup of my ROM. I loaded it again in my phone and it works without problem. Now I'm trying to make changes to the ROM. Change the build.prop and install an apk. I use MTK Thai Developer Tools to unpack my system.img and I'm able to do it without problems. Afther make the changes I repack the file with the same tool and I get a file called system_ext4_new.img without errors or warnings. Now I rename the file to system.img and overwrite the original system.img in the forlder "!Files_to_flashtool". I'm able to write the ROM back to my phone with SP Flashtools but the phone doesn't work. It try to start but get stuck and I have to remove the battery. I tryed to simply unpak my system.img and repack it whitout changes but the problem remains. So I'm thinking that the file that I get from MTK Thai Tools can't be used in a ROM that will be flashed with SP Flashtools. What I'm doing wrong?. I need another tools to repack my system.img and use it with SP Flashtools?
Sorry if the question was already answered but I'm seaching over the forum and I found no answer.
Thanks in advance.
21st June 2017, 05:44 AM |#9  
Junior Member
Thanks Meter: 0
 
More
mtk6592 redmi mote 3 ?
2nd August 2017, 11:34 AM |#10  
Senior Member
Flag hamburg
Thanks Meter: 70
 
More
I have a Oukitel 6000 Pro,this have a MTK 6753,but the Tool shows mit MTK 6735 ??
What is wrong??
17th August 2017, 07:00 PM |#11  
Member
Thanks Meter: 5
 
More
I'm getting "E:Error executing updater binary in zip" when I unpack and repack without making ANY changes. I noticed that before I unpack, the original system.new.dat is 465 MB, whereas after I repack, the new system.new.dat is 427 MB. And the original system.transfer.list is 382 bytes, whereas after I repack, the new system.transfer.list is 1,125 bytes.

I am not making ANY changes. Just unpacking and repacking.

When I first used the tool, I was able to unpack, make changes, repack and flash the zip file and boot my phone with no issues. But suddenly it stopped doing it right. I have the proper java and python. I don't understand what happened.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes