FORUMS
Remove All Ads from XDA

Odin 3.12.3 worlds first :) att s7 odin firmware restore

166 posts
Thanks Meter: 103
 
Post Reply Email Thread
ODIN 3.12.3

fixes odin version error on s7 att
Attached Files
File Type: rar odin 3.12.3.rar - [Click for QR Code] (924.4 KB, 140560 views)
The Following 12 Users Say Thank You to ohap For This Useful Post: [ View ] Gift ohap Ad-Free
 
 
19th June 2016, 04:46 AM |#2  
Senior Member
Thanks Meter: 10
 
More
wow great

通过我的 SM-N9200 上的 Tapatalk发言
19th June 2016, 09:37 AM |#3  
Member
Thanks Meter: 14
 
More
Can i downgrade current att FW to original ofw?
19th June 2016, 03:42 PM |#4  
OP Senior Member
Flag austin
Thanks Meter: 103
 
Donate to Me
More
Quote:
Originally Posted by rafael707

Can i downgrade current att FW to original ofw?

try it , but i say maybe no as att is still locked bootloader
30th June 2016, 11:24 AM |#5  
Senior Member
Thanks Meter: 284
 
More
Worked fine flashing a FACTORY binary firmware, but only of equal or greater version as already on the phone (no downgrade!).
I haven't tried a regular USER binary firmware, so your milage may vary.
Then tried flashing an engineering rooted boot.img converted to TAR in the AP tab but it fails every time on a G930A
Here's the log:

<ID:0/003> Odin engine v(ID:3.1203)..
<ID:0/003> File analysis..
<ID:0/003> SetupConnection..
<ID:0/003> Initialzation..
<ID:0/003> FAIL! SHA256 is invalid
<OSM> All threads completed. (succeed 0 / failed 1)

Turns out that every TAR package also has a meta-data\1.mf file which contains a signature of each file hashed with SHA256 encryption.
Dang it, if anyone knows how to generate such file please share it.
1st July 2016, 02:17 AM |#6  
Shabby The Dev's Avatar
Senior Member
Flag Karachi
Thanks Meter: 10
 
More
Quote:
Originally Posted by billa

Worked fine flashing a FACTORY binary firmware, but only of equal or greater version as already on the phone (no downgrade!).
I haven't tried a regular USER binary firmware, so your milage may vary.
Then tried flashing an engineering rooted boot.img converted to TAR in the AP tab but it fails every time on a G930A
Here's the log:

<ID:0/003> Odin engine v(ID:3.1203)..
<ID:0/003> File analysis..
<ID:0/003> SetupConnection..
<ID:0/003> Initialzation..
<ID:0/003> FAIL! SHA256 is invalid
<OSM> All threads completed. (succeed 0 / failed 1)

Turns out that every TAR package also has a meta-data\1.mf file which contains a signature of each file hashed with SHA256 encryption.
Dang it, if anyone knows how to generate such file please share it.

I think it was not so easy to generate those hashes because this is new security from samsung and secured by samsung
but developers can welcome this security and play with it
4th July 2016, 07:18 PM |#7  
Junior Member
Thanks Meter: 1
 
More
Hi any idea where i can find firmwares for the at&t s7 edge (G935A) my firmware is corrupt and keeps restarting
4th July 2016, 09:58 PM |#8  
Senior Member
Thanks Meter: 284
 
More
SHA256 error has been solved
[/COLOR]
Quote:
Originally Posted by Shabby The Dev

I think it was not so easy to generate those hashes because this is new security from samsung and secured by samsung
but developers can welcome this security and play with it

The SHA256 error has been solved.
Here's the new moded Odin which will work with any S7 model including ATT.
http://forum.xda-developers.com/show...&postcount=104
The Following 2 Users Say Thank You to billa For This Useful Post: [ View ] Gift billa Ad-Free
20th July 2016, 08:18 AM |#9  
Senior Member
Thanks Meter: 22
 
More
Got 0din 3.12
So i got odin 3.12 and I no longer get the protocol error but instead, "SW REV CHECK FAIL DEVICE 2, BINARY 1" and I cannot fix it. Someone please help I need my phone to be stocked again.
22nd September 2016, 06:21 AM |#10  
ashyx's Avatar
Recognized Contributor
Thanks Meter: 9,325
 
Donate to Me
More
Quote:
Originally Posted by FreshIce21

So i got odin 3.12 and I no longer get the protocol error but instead, "SW REV CHECK FAIL DEVICE 2, BINARY 1" and I cannot fix it. Someone please help I need my phone to be stocked again.

Your're trying to downgrade your firmware.
You're trying to flash a revision 1 firmware on a revision 2 device. You need firmware that is XXU2 not XXU1
18th February 2017, 02:37 AM |#11  
Senior Member
Los Angeles
Thanks Meter: 329
 
More
Will this Odin fix an error ext4 with system.img? I believe the error has to do with different system partition sizes by region? Or is that error something you have to abide by and repartition your device?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes